2016 Beats Audio Disappointment THREAD [Update to fix now available] - Page 38 - Jeep Renegade Forum
 85Likes
Reply
 
Thread Tools
post #371 of 399 (permalink) Old 11-26-2016, 11:29 PM
Junior Member
 
Join Date: Oct 2016
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
I checked the paperwork on mine and it says that the AMP PCM and TCM were updated. AMP F2.07.00 - F2.08.00. PCM 68307045AD - AE. TCM 68307047AD - AE.

No idea what any of that means. After using it for awhile now and getting the sound set the way I like it, I have to say that I LOVE the stereo. It's really quite good now and I get a lot of compliments on it. This is what I expected out of the upgrade.

Also, I can say that Jeep did care on this one. Not only did Chrysler help me out, but they extended my warranty to 5 years / 100K miles for the hassle I had with the new car. Outstanding!

Everything is great now about a dozen computer upgrades. It's a shame they are not delivered to the customer this way, as I think the vehicle would have a much better reputation and it would help the residual. I can't imagine how many people drive around with the rough transmission, poor audio, and other issues that are an easy solve. Either way, I am ecstatic and my Jeep is driving beautifully.
AlyssaRose likes this.
cyberjad is offline  
Sponsored Links
Advertisement
 
post #372 of 399 (permalink) Old 12-15-2016, 01:19 PM
Junior Member
 
Join Date: Nov 2016
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
So a week ago I had the dealer check for an update on the AMP. Well there was one and it seems to be a step in the right direction as far as the beats sound. It sounds much better now.


Amp flash of mine went from 7203038000 -03-F2.08.00 -0000 to 7203038000 -03-F2.08.01 -0000
mykeym is offline  
post #373 of 399 (permalink) Old 12-15-2016, 01:27 PM
Member
 
BadHabit2Break's Avatar
 
First Name: Stephen
Join Date: Aug 2016
Location: Houston, Tx
Posts: 55
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Quote:
Originally Posted by mykeym View Post
So a week ago I had the dealer check for an update on the AMP. Well there was one and it seems to be a step in the right direction as far as the beats sound. It sounds much better now.


Amp flash of mine went from 7203038000 -03-F2.08.00 -0000 to 7203038000 -03-F2.08.01 -0000


So it looks like there is another update out and you are at F2.08.01

I wonder what they changed for that update?

----------------------------
Thanks,
Stephen

2016 Renegade Trailhawk
BadHabit2Break is offline  
 
post #374 of 399 (permalink) Old 12-17-2016, 02:54 PM
Junior Member
 
Join Date: Nov 2016
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
All I know is that I was having the same issues as most people and now it sounds much better.
BadHabit2Break likes this.
mykeym is offline  
post #375 of 399 (permalink) Old 12-29-2016, 07:26 AM
Junior Member
 
Join Date: Dec 2016
Location: Austin, TX
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Garage
Quote:
Originally Posted by Lane View Post
Just thought I'd pop on here and post an update. I purchased a Renegade 75th Anniversary Edition Tuesday November 15th. While I was test driving a similarly equipped one, I noticed that the sound system didn't sound "premium" at all. Granted, premium is a relative term but I had the upgraded Alpine audio in my 2014 Wrangler and it had presence... this thing sounded like a tin can as many have pointed out. Got home that night before I picked up mine the next day and came across this forum. After driving it for 2 days to work and back.. I was experiencing the same issues reported by a lot of folks. Hardly any sound coming from the door/back speakers, most of the range was coming from the front two dash speakers. Called the dealership Friday and made an appointment. Got there and had him specifically look for the TSB 08-065-16 update. Mine was manufactured in April of 2016 so it would have needed it from the information I'd learned from the forum. Vehicle had no history of that particular update, so they performed that one and a few others that had popped up in the system. I'm happy to report the audio sounds MUCH better. Night and day difference from what it was. I can actually hear audio coming from the back speakers and don't have to crank it up to 38 to do so. (Such an odd max volume number....)

Anyway, I'm now a very happy Jeep Renegade owner and wanted to thank everyone for the posts and directing me towards the fix!
Does anybody know what the work is that is to be performed in conjunction with this TSB? I just bought my Renegade last week and have been experiencing this exact same problem. I went to the dealer and asked them to determine whether or not this TSB applied to my vehicle and all they could tell me was that the unit had the latest version of the Uconnect software. I asked if that is all the TSB did, suggest an update to the software, and they said "yes." The problem is still as persistent as ever. I have a very tiny sounding "premium" stereo. I believe from their opinion is that if they hear sound coming from the speakers the unit is working correctly.

2016 Jeep Renegade Latitude 1.4 Liter

Last edited by RCR68; 12-29-2016 at 07:30 AM. Reason: Spelling
RCR68 is offline  
post #376 of 399 (permalink) Old 12-29-2016, 11:42 AM
Member
 
Join Date: Aug 2016
Location: VT
Posts: 72
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 19 Post(s)
They're full of it, the TSB has nothing to do with the uConnect software (which you can flash yourself), it's an amp update.
Lackadazikal likes this.
Chimera is offline  
post #377 of 399 (permalink) Old 12-30-2016, 03:45 AM
Junior Member
 
Join Date: Dec 2016
Location: Austin, TX
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Garage
Thank you for verifying. I'll head back to the dealer to try to get them to actually listen to me and do the fix.

2016 Jeep Renegade Latitude 1.4 Liter
RCR68 is offline  
post #378 of 399 (permalink) Old 12-30-2016, 10:54 AM
Senior Member
 
Join Date: Apr 2015
Posts: 477
Mentioned: 93 Post(s)
Tagged: 2 Thread(s)
Quoted: 135 Post(s)
Quote:
Originally Posted by RCR68 View Post
Does anybody know what the work is that is to be performed in conjunction with this TSB? I just bought my Renegade last week and have been experiencing this exact same problem. I went to the dealer and asked them to determine whether or not this TSB applied to my vehicle and all they could tell me was that the unit had the latest version of the Uconnect software. I asked if that is all the TSB did, suggest an update to the software, and they said "yes." The problem is still as persistent as ever. I have a very tiny sounding "premium" stereo. I believe from their opinion is that if they hear sound coming from the speakers the unit is working correctly.
Hi RCR68,

I'd be happy to check if this TSB applies to your vehicle. Just PM our page with your VIN and let me know!

Andrea
Jeep Social Care Specialist
JeepCares is offline  
post #379 of 399 (permalink) Old 12-30-2016, 12:34 PM
Junior Member
 
Join Date: Dec 2016
Location: Austin, TX
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Garage
Andrea:

Thanks for reaching out and for your offer to help. I'd be happy to do so but this forum won't let me send PM's until I have 15 posts and I'm only at 2 now. My VIN is ZACCJABW1GPE19965 If there is another way I can reach you, please let me know as I think you can send me PM's.

Thanks,
Ray

2016 Jeep Renegade Latitude 1.4 Liter
RCR68 is offline  
post #380 of 399 (permalink) Old 01-04-2017, 07:25 PM
Junior Member
 
Join Date: Jan 2017
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage
Funny I came across this thread, I was also a little let down from ours that we just picked up 5 days ago. I'll have to dig into this.
BT802 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Renegade Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
TSB - Beats -Amplifier Audio Enhancement Lackadazikal TSBs and Recalls 2 01-17-2017 02:32 AM
Did they fix the 9 speed for 2016 Yulee Mike Transmission 49 01-11-2017 12:09 AM
How can I add aftermarket beats audio? Vampyr Electronics, Audio, and Lights 13 07-31-2016 02:06 PM
Ordered 2015, Getting 2016: Audio? flyingfish Purchases and Orders 2 11-18-2015 03:59 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off