Welcome to JeepRenegadeForum.com - please post an introduction - Page 73 - Jeep Renegade Forum
 291Likes
Reply
 
Thread Tools
post #721 of 734 (permalink) Old 07-25-2019, 10:35 AM
Senior Member
 
Join Date: Oct 2014
Location: Reno/Lake Tahoe, Nevada USA
Posts: 237
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 36 Post(s)
Quote:
Originally Posted by Tigercone01 View Post
Purchased 2019 jeep renegade sport 4x4 less then 30 days ago. Noticing many issues first time jeep owner. Got ok on 2019 4x4 around $20k. But are jeeps known to have electrical issues? Having many system problems within first thirty days in shop currently even seat belt alarms going off when hooked on test drive with saleman. Seat belt alarms go off for no reason had to hook empty seat in back to stop beeping saleman even experienced this while on test drive n he said dont worry we will fix it. Back hatch popped open driving n has issues closing n keeps popping at certain times, park break coming on when pulling forward twice, tenp gauges off big time, tire sensors not reading correctly, dash odometer flashing, radio muting itself while listening to songs n on phone calls, Scraps on front n chips on back hatch noticed on walk around at dealership sales man took pic n said they fix it no worries. Backup camera stayed on for four minutes while driving forward showing road in back of us while going up a hill in drive n making a left turn then went off occured few times since. Dealership said they had to do a proxy alignment to reset computers n they think it will fix issues. Going to pick up now to see but anyone else having these issues on brand new 2019 got it less then 30 days had 1 mile when test drove 6 at title signing now has 3200 miles help not feeling to comfortable with jeep thinking i should have stayed with dodge cars n trucks.



Jesus Christ that was difficult to read, I didn't even finish. Either you have buyers remorse, overly exaggerate, or have the worst car in history. Welcome, I guess.
mad trapper likes this.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


2018 Renegade 2.4 (BU) *CURRENT*
2018 Wrangler 3.6 (JK-U) *CURRENT*
2017 Patriot 2.0 (MK74)
2017 Wrangler 3.6 Unlimited (JK-U)
2013 Grand Cherokee 3.6 Trailhawk (WK2)
2003 Grand Cherokee 4.7 Laredo (WJ)
2002 Liberty 3.7 Limited (KJ)
2000 Wrangler 4.0 Sport (TJ)
1993 Wrangler 4.0 Base (YJ) [Rubicon Trail Jeep Jamboree 7 Times]
1990 Wrangler 2.5 Base (YJ)
1989 Wrangler 2.5 Base (YJ)
CRZY4x4 is offline  
Sponsored Links
Advertisement
 
post #722 of 734 (permalink) Old 07-26-2019, 03:00 PM
Junior Member
 
Tigercone01's Avatar
 
Join Date: Jul 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Guess worse jeep in history cause honestly i did like deal i got just dont like electrical issues been checked out night i bought n not fixed then week ago n now they had day n half n still seat belts going off but now radio you cant take calls through or other person cant hear ya or mute comes on when on call or listening to music even jeep care told me he was calling back take car off radio n back to phone n on just phone clear as can be n usb not charging phone more then half time even bought two brand new usb n will not charge.
Tigercone01 is offline  
post #723 of 734 (permalink) Old 07-27-2019, 12:22 AM
Moderator
 
Mrsig's Avatar
 
First Name: Mrsig
Join Date: Jul 2015
Location: Davie, Fl
Posts: 2,695
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 165 Post(s)
Quote:
Originally Posted by CRZY4x4 View Post
Jesus Christ that was difficult to read, I didn't even finish. Either you have buyers remorse, overly exaggerate, or have the worst car in history. Welcome, I guess.
X2

Me 07 JKUSR, CEO of Black Sheep 4x4s org
White Jeep Club Member # 137
To see my mods or Jeep in action go to
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Wife
2017 Jeep Renegade Trailhawk 4x4 2.4L, 9 speed Auto.
White Jeep Club Member # BU01

Mrsig is offline  
Sponsored Links
Advertisement
 
post #724 of 734 (permalink) Old 07-31-2019, 12:37 PM
Junior Member
 
Join Date: Jul 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Hi there everyone,

I'm currently on my second Renegade. Love them! Having a few issues with the new one (purchased last September), so hoping the community can help me get them sorted. :-)

Mandy
Az_Mandy is offline  
post #725 of 734 (permalink) Old 07-31-2019, 01:09 PM
Senior Member
 
DCHARTIER's Avatar
 
Join Date: Jun 2017
Location: Stillwater
Posts: 336
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Quote:
Originally Posted by Az_Mandy View Post
Hi there everyone,

I'm currently on my second Renegade. Love them! Having a few issues with the new one (purchased last September), so hoping the community can help me get them sorted. :-)

Mandy
Welcome! What are your issues?
Az_Mandy likes this.
DCHARTIER is offline  
post #726 of 734 (permalink) Old 07-31-2019, 05:15 PM
Junior Member
 
Join Date: Jul 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Quote:
Originally Posted by DCHARTIER View Post
Welcome! What are your issues?
Biggest problem is that it started stalling out this week. I drove it about 100 miles on Monday morning, and then 15 minutes later it wouldn't run.

Starts just fine, runs for a few seconds, then dies. Revving the engine a bit will keep it running for an extra few seconds.

Tuesday morning it started up perfectly, but I was nervous to drive it all the way to the dealership so went ahead with the tow. Dealership still has it and says they can't replicate the issue. Not sure what to do if they call and say there's nothing wrong with it - clearly something was amiss the day before!

It was extremely hot here on Monday afternoon. Wondering if the temperature had anything to do with it. I thought maybe the fuel pump, but dealership hasn't said anything about it...

Worried it's going to die on me while I'm out, with my kid in the car, on the freeway, etc. Shouldn't feel nervous to drive a basically new car, right? lol
Az_Mandy is offline  
post #727 of 734 (permalink) Old 07-31-2019, 08:48 PM
Senior Member
 
Join Date: Oct 2014
Location: Reno/Lake Tahoe, Nevada USA
Posts: 237
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 36 Post(s)
Quote:
Originally Posted by Az_Mandy View Post
Biggest problem is that it started stalling out this week.



First off, check your oil. Low oil will trigger a stop engine command.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


2018 Renegade 2.4 (BU) *CURRENT*
2018 Wrangler 3.6 (JK-U) *CURRENT*
2017 Patriot 2.0 (MK74)
2017 Wrangler 3.6 Unlimited (JK-U)
2013 Grand Cherokee 3.6 Trailhawk (WK2)
2003 Grand Cherokee 4.7 Laredo (WJ)
2002 Liberty 3.7 Limited (KJ)
2000 Wrangler 4.0 Sport (TJ)
1993 Wrangler 4.0 Base (YJ) [Rubicon Trail Jeep Jamboree 7 Times]
1990 Wrangler 2.5 Base (YJ)
1989 Wrangler 2.5 Base (YJ)
CRZY4x4 is offline  
post #728 of 734 (permalink) Old 08-01-2019, 10:49 AM
Senior Member
 
DCHARTIER's Avatar
 
Join Date: Jun 2017
Location: Stillwater
Posts: 336
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
[QUOTE=Az_Mandy;901821]Biggest problem is that it started stalling out this week. I drove it about 100 miles on Monday morning, and then 15 minutes later it wouldn't run.QUOTE]

I agree with CRZY4x4, check your oil level.
DCHARTIER is offline  
post #729 of 734 (permalink) Old 08-01-2019, 03:25 PM
Junior Member
 
Join Date: Jul 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Quote:
Originally Posted by CRZY4x4 View Post
First off, check your oil. Low oil will trigger a stop engine command.
That was the very first thing I checked, and it was fine.

The dealership had it for two days and couldn't replicate the issue, so I have it back now. Crossing my fingers it doesn't happen again!

Thanks for the help! :-)

A
CRZY4x4 likes this.
Az_Mandy is offline  
post #730 of 734 (permalink) Old 08-08-2019, 02:26 PM
Junior Member
 
Join Date: Aug 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
New Member with Accessory Outlet Question

Just bought a '17 Latitude w/ about 21k miles. Enjoying it so far!

Instead of the factory tire repair kit, the dealer gave us a Slime kit with a 15 amp compressor. The manual says don't exceed 13A on the accessory outlets or you'll blow a fuse. Since the front accessory outlet is on a 15A fuse and the cargo outlet is on a 20A fuse, I would assume that most of the fuse's capacity is reserved for whatever you connect to the outlet, and less other equipment on the same circuit.

If that assumption is valid, would it make sense to upsize the fuses to 20A and 25A, if they exist and they fit? In any other case, this is a no-no, but what about in this case?

Last edited by kdk3ll3r; 08-08-2019 at 02:30 PM.
kdk3ll3r is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Renegade Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
New Member introduction Willy New Member Introductions 3 03-21-2016 04:01 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off