Climate Control Resetting Itself - Jeep Renegade Forum
Reply
 
Thread Tools
post #1 of 15 (permalink) Old 12-06-2018, 12:05 PM Thread Starter
Junior Member
 
First Name: Ray
Join Date: Nov 2018
Location: Effort PA
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Climate Control Resetting Itself

I have a 2018 Renegade Latitude with only 3000 miles. Lately I noticed that the climate control is resetting itself after a few starts (Auto start or Push button). Sometimes the climate control will turn itself off or turn the air condition on max. I tried turning off the Uconnect before turning off the car but it still happens. Does anyone else have this problem?
Skater is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 12-06-2018, 10:54 PM
Junior Member
 
NachesHawk's Avatar
 
Join Date: Sep 2018
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
When I use the remote start, mine sometimes resets the "auto climate control" to 73 driver and 75 passenger. Even when I have reset it to 68 and sync.
NachesHawk is offline  
post #3 of 15 (permalink) Old 12-07-2018, 02:44 PM
Junior Member
 
Anvil4x4's Avatar
 
Join Date: Nov 2018
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Garage
I am having the same issue 2018 latitude, I am in and out of my car up to 20 times a day working home health, put the heat on high synced to both sides when I turn the car off and come back 40 minutes later to find the air on Lo drivers side 74 passenger side and some other strange but consistent settings, radio and other settings remain unchanged but the HVAC does this sometimes a couple times a day. Dealer said it may need an update but I have yet to take it in. Keep us posted if you end up taking it to dealer, I may not get mine in until next year.

2018 4x4 Latitude
Anvil4x4 is offline  
Sponsored Links
Advertisement
 
post #4 of 15 (permalink) Old 12-07-2018, 03:05 PM Thread Starter
Junior Member
 
First Name: Ray
Join Date: Nov 2018
Location: Effort PA
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
I took my 2018 Renegade to the dealer today and they couldn’t find anything wrong with it. They reset all the sensors and climate settings. They also told me to raise the temp up to 75 degrees from the 68 degree I was using and to use the same remote when using remote start. No updates at this time but they will notify me if any come up.
Skater is offline  
post #5 of 15 (permalink) Old 12-11-2018, 10:26 PM
Junior Member
 
Join Date: Sep 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
I have a 2018 Renegade with this same problem. I have not brought it to the dealership yet as it only happens occasionally. Would like to know if there is a fix.
Rick Leinen is offline  
post #6 of 15 (permalink) Old 12-12-2018, 01:56 AM
Junior Member
 
Andreas's Avatar
 
First Name: Andreas
Join Date: Aug 2018
Location: Cyprus
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
I've been having the same issue with my 2018 since day 1. I have taken it to the dealers, they have opened a support ticket with FCA in Italy and now awaiting their response.


Will post here if and when it's sorted!
Andreas is offline  
post #7 of 15 (permalink) Old 12-13-2018, 07:38 AM
Senior Member
 
Join Date: Apr 2015
Posts: 853
Mentioned: 115 Post(s)
Tagged: 2 Thread(s)
Quoted: 209 Post(s)
Quote:
Originally Posted by Skater View Post
I have a 2018 Renegade Latitude with only 3000 miles. Lately I noticed that the climate control is resetting itself after a few starts (Auto start or Push button). Sometimes the climate control will turn itself off or turn the air condition on max. I tried turning off the Uconnect before turning off the car but it still happens. Does anyone else have this problem?
Quote:
Originally Posted by NachesHawk View Post
When I use the remote start, mine sometimes resets the "auto climate control" to 73 driver and 75 passenger. Even when I have reset it to 68 and sync.
Quote:
Originally Posted by Anvil4x4 View Post
I am having the same issue 2018 latitude, I am in and out of my car up to 20 times a day working home health, put the heat on high synced to both sides when I turn the car off and come back 40 minutes later to find the air on Lo drivers side 74 passenger side and some other strange but consistent settings, radio and other settings remain unchanged but the HVAC does this sometimes a couple times a day. Dealer said it may need an update but I have yet to take it in. Keep us posted if you end up taking it to dealer, I may not get mine in until next year.
Quote:
Originally Posted by Rick Leinen View Post
I have a 2018 Renegade with this same problem. I have not brought it to the dealership yet as it only happens occasionally. Would like to know if there is a fix.
Quote:
Originally Posted by Andreas View Post
I've been having the same issue with my 2018 since day 1. I have taken it to the dealers, they have opened a support ticket with FCA in Italy and now awaiting their response.


Will post here if and when it's sorted!
Hi all,

Thank you for sharing your experience. I am sorry to hear that you are having a tough time with the climate controls in your Jeep Renegades. If you are in need of additional assistance while you are at your dealers, please feel free to send us a private message.

Darlene
Jeep Social Care Specialist
JeepCares is offline  
post #8 of 15 (permalink) Old 12-13-2018, 08:46 AM
Junior Member
 
ManxDaddy2's Avatar
 
Join Date: Oct 2018
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Our 2018 Altitude does the same thing 3 to5 times a week. Synced to 78 and it doesn't matter what remote is used or if it is used at all. AC is on max and sync is reset to 65. Also, the odometer will switch to metric.Wifes not diggin it when it's frosty. 3500 miles. First new car.
ManxDaddy2 is offline  
post #9 of 15 (permalink) Old 12-13-2018, 09:06 AM
Member
 
Join Date: Feb 2018
Posts: 87
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
We've seen this reported on tons of 2018's. For sure it's a glitch in the hvac system. I wouldn't be surprised if there is a TSB already or shortly being released.

Keep reporting the issue. FCA might consider it a minor issue but it's annoying as heck to the customer.

Sent from my SAMSUNG-SM-G891A using Tapatalk
velocityc6 is offline  
post #10 of 15 (permalink) Old 12-13-2018, 02:07 PM
Member
 
Join Date: Nov 2018
Location: Houston
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Seems like those experiencing the reset all have different "resets". My '18 did the same, but seems less often now at ~2000 miles. It started out resetting to LO. Now I've noticed it resets itself to off. Then a few min in my drive I notice I feel no air blowing, then hit the auto button. Which then turns on with the LO setting...

18' Renegade Latitude 4x4
18' TrackHawk
18Rene is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Renegade Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Conversion to Auto Climate Control TroyD80 Interior 31 05-26-2019 01:39 PM
open front & rear diffs with computer traction control is not same as locking diffs Tom Jones Off-Road Discussion 30 05-19-2019 10:53 PM
Climate controls resetting Trayal Problems/Issues 37 01-02-2019 10:46 PM
Auto Climate Control mylilturtle DIY & How To 2 12-26-2018 12:29 PM
Climate control JimBob82 Jeep Renegade General Discussion 0 06-23-2018 07:48 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off