Jeep Renegade Forum banner

How many times has your Renegade been in for unscheduled service?

  • 0 times

    Votes: 122 72.6%
  • 1 times

    Votes: 30 17.9%
  • 2 times

    Votes: 10 6.0%
  • 3 times

    Votes: 5 3.0%
  • 4 times

    Votes: 0 0.0%
  • 5 times

    Votes: 0 0.0%
  • 6 times

    Votes: 0 0.0%
  • 7 times

    Votes: 0 0.0%
  • 8 times

    Votes: 0 0.0%
  • 9 times

    Votes: 1 0.6%
1 - 20 of 78 Posts

·
Super Moderator
Joined
·
3,685 Posts
Discussion Starter · #1 ·
Hurray! You made it to 2000 miles. Let us know how your Renegade is doing and if you needed any unscheduled maintenance or repairs. Help out your fellow forum members, and fill out the poll. Make a post, and summarize your tale of joy or woe as well.
 

·
Registered
Joined
·
100 Posts
Hurray! You made it to 2000 miles. Let us know how your Renegade is doing and if you needed any unscheduled maintenance or repairs. Help out your fellow forum members, and fill out the poll. Make a post, and summarize your tale of joy or woe as well.
2200 miles and no problems. I wish the gas mileage was a little better. I am getting 24 mpg, 70/30 highway/city. I was able to try out some of my TH's off-road features and I am very impressed. The look I get are entertaining, as well.
 

·
Registered
Joined
·
221 Posts
Around 2000 miles still no service visits. But I noticed a few weird characteristic showing in the Trailhawk.

- Exhaust bangs around when driving over bumps. I have taken it offroad a few times. It seems that the rubber hangers have broke in and become a bit soft. I'm thinking the heat from the exhaust and the bouncing around on the trails soften them up. It's hitting at the center of the car. There is a resonator and a heat shield under the resonator. As long as I new what it was the noise doesn't bother me. It usually only happens offroad, so on road it's fine.

- The Renegade rolls more than expected from a new car when switching into park, drive, and reverse. I've gotten use to it, but at first it scared me a couple of times. Where I think I forget if I did change it into the gear I wanted and the car is rolling away from me. It scares the spotter on the trails as well. It feels like an old worn out car when you put the gear in park and it rolls back a bit. But the Jeep seems to roll more than an old car. When I go from reverse to drive the car rolls back before it starts going forward. Which is a weird feeling because you think you are going forward but you roll back like you're going backwards. Can't get too close to an objects when maneuvering in parking lots or on the trail. Again, I've gotten use to it and now it's just a part of the Renegade.
 

·
Registered
Joined
·
3 Posts
I also passed the 2000 mile mark this week. I'm only getting 22 mpg but I would say I'm 60/40 highway/city. I haven't needed to take the car in for service (no check engine light or problems with the drive train) but I called my dealership and they have those software flashes available. The dealership didn't seem to think the car needed to be re-flashed if it wasn't having problems, but I wonder if anyone on this thread has anything different to say...
 

·
Registered
Joined
·
115 Posts
Interesting about the rolling, mine does the same. Also the other day I was emptying some things out of the back while the car was parked and leaned on it and it rolled forward a bit. Very strange and scared the S#&% out of me. 4500 miles and only have had the lock issue. Sometimes the shifting does some weird things but I haven't had it serviced yet. I am assuming there may be a recall on tranny software so have held off.
 

·
Registered
Joined
·
1,633 Posts
Do you two put on the parking brake before you move the shift lever to park? That's something I have always done when parking, auto or manual; apply the parking brake before shifting into park or letting the clutch out in gear.
 

·
Registered
Joined
·
216 Posts
Purchased a 2015 Jeep Renegade Limited almost 3 weeks ago and I just love itJ Got the FWD limited in Mojave sand with black leather interior, have had several comments about my new Jeep already! I also own a 14Jeep Cherokee Limited that my wife drives to work and we both love that vehicle as well. So far on the Renegade, I have updated all of the exterior lights to LED and replaced headlight and fog light bulbs with Sylvania Silver Star Ultra xe and they rock! Also replaced cargo with LED and will replace other interior bulbs later. Am having the “Lamp fault” in DIC so may have to switch out and get canbus error free LEDs. Have also installed K&N air filter; they dont make one yet just for renegade so I had to measure and match up best I could. K&N#33-2380 fits pretty good and have had no problems and am getting about 31mpg on highway.

I have also posted several posts on this forum site about an issue I am having with 6.5an Uconnect Infotainment System. I have called Uconnect and used Assist feature about 7 times (spent about 5hrs on phone over past week) and took Renegade to dealership and they don't know what to do. They called STAR for tech support, they told mechanic to contact Uconnect reps. Those reps told mechanic to call STAR. I have done like 5 factory resets, deleted and re-activated my Uconnect account like 4 times, 2 soft-resets, etc. Issues have been no YELP app feature, missing Uconnect Store and Wi-Fi app features and Uconnect Access advantage pkg states "pending" on my vehicle screen instead of "activated" or "trial". Everyone is scratching their heads on what to do next. I would just wish they would install a new infotainment head unit and see if that solves the problem. Mech at dealership cannot reload system software because no update is needed and the system will not allow you to load the same version of software... Anyone have any ideas on what to do??? Also, is anyone else with 6.5 system having any kind of issues????
 

·
Registered
Joined
·
1,633 Posts
Made it to 2,000

I have a little over 2,000 miles on my Trailhawk now. Not one bit of trouble so far. No quirks or other problems. Mine was shipped over with the first 3K cars that arrived in early April and the first Trailhawk my dealer had.

The transmission has been solid and its shifting very predictable. It does slightly over rev-match during the 5 to 4 shift and very slightly during the 8 to 7 shift, but it's not a problem and no need to update any software. If you step on it while driving at highway speed in one of the highest gears, it will downshift multiple gears winding up the motor for good passing power (for a little engine).

I'm totally satisfied with my car. :D
 

·
Registered
Joined
·
201 Posts
I have hit the 3000 mark and have had no issues outside the Service 4x4 light at 100 miles. The nervousness of having issues is quickly going away now and I am just enjoying my vehicle :)
This is a good thread and I like hearing reports of the TH running well after a few miles on it. I don't have mine... yet. But when i do, i'll be taking in on a big road trip in the fall. Driving from Dallas, to the Grand Canyon south rim, then to Monument Valley Utah, then back to Dallas. Close to 3000 miles. I don't want to break down in the desert, so i like reading of problem free TH's. haha
 

·
Registered
Joined
·
1 Posts
my renegade limited is almost to 2000 miles! & so far i love it. only a few issues. when it rains (which has been a lot recenty) if you open the back doors water spills out from the top of the door like it is pooling up in the seal when the door is closed. has anyone else had this issue & know if it is something that can be fixed or do i just have to live with it?! also, is there any way to get the doors to automatically lock when you put the car in drive? i have tried to looking on on the settings on the screen but i cant seem to find anywhere to change it.... maybe im over looking it. thanks for any suggestions in advance!
 

·
Premium Member
Joined
·
1,540 Posts
my renegade limited is almost to 2000 miles! & so far i love it. only a few issues. when it rains (which has been a lot recenty) if you open the back doors water spills out from the top of the door like it is pooling up in the seal when the door is closed. has anyone else had this issue & know if it is something that can be fixed or do i just have to live with it?! also, is there any way to get the doors to automatically lock when you put the car in drive? i have tried to looking on on the settings on the screen but i cant seem to find anywhere to change it.... maybe im over looking it. thanks for any suggestions in advance!
Hi and welcome!
There are a couple threads about the water around the seals. Some see it as an issue and others don't.
http://www.jeeprenegadeforum.com/fo...problems-solutions/13953-water-retention.html
http://www.jeeprenegadeforum.com/fo...edition/18121-water-leaking-around-doors.html

For the auto locks press the more button next to your screen
Then hit settings
Then doors and locks
And then I think auto lock is one of the first options. Press that and set it to on.
 

·
Registered
Joined
·
10 Posts
We traveled 2400 miles in a week to Orlando FL in our TH. No issues, 25.9 MPG, 3 adults and packed for a week. Now at 3900 miles and just had our first oil change - I was nervous and changed it before the indicator.
 

·
Registered
Joined
·
162 Posts
2000 miles complete... on to 5000

Reporting as ordered sir.

Ort has performed admirably. We have been on road and off, up mountains and down, in deluge and sand.

I have had one "glitch" with the reverse. It was such a non issue I don't even remember what exactly happened. I do remember the solution was, go back to park and start over.

I
LOVE
THIS
JEEP!
 

Attachments

1 - 20 of 78 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top