Jeep Renegade Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hoping that there is someone out there who may be able to help with the problem I'm having with my 2015 Jeep Renegade. Every six months or so, the automatic locks on the car stop working, then usually 3-4 weeks afterward the battery dies. It takes quite a bit of time to jump start the car once the battery dies, but once it is jump started, it is back to normal and the automatic locks work. Then six or so months later the process begins again. Has anyone else had this issue or any idea on what's happening? Thanks!
 

·
Registered
Joined
·
996 Posts
Hi Michael and welcome. Have you changed the battery since this all began?

If not there are a few excellent topics within the forum on which battery to use. You are not alone with the faults you are experiencing and some of us have suffered similar errors like you.

Only just the other day we had a chat about Yellow Top batteries and that seems to come out on top of the user Poll. I recently paid £163 for a new battery but it resolved all of my issues. The more you have a little snoop around the forum the more you will realise that the original Jeep battery IMHO is just not up to the job.

Jump starting if done correctly should be almost instant. However your length of time in jump starting suggests a DEAD battery as opposed to a flat battery. Have a local garage do a quick battery test for you as they are normally free.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks for the battery advice, I will definitely look into switching to Yellow Top. I have switched the battery twice before, when I have switched the problem was gone for about a year instead of the six months it returns when jump started. Whenever I have had shops run tests, after a jump start, everything has come back fine except the car computer saying there are problems for the first day or so.
 
1 - 4 of 4 Posts
Top