Jeep Renegade Forum banner
1 - 7 of 7 Posts

·
Registered
2015 Trailhawk
Joined
·
404 Posts
Has anyone else had an issue w/their trailhawk not starting. Mine has 1500 miles and has now had to go to the dealership twice for this issue
Nope, mine's been fine (at close to 7,000 miles now). I hope they can figure out what your issue is and get it taken care of quickly!
 
  • Like
Reactions: syzygy

·
Registered
Joined
·
1,628 Posts
Sorry to hear about your issues. Mine has been great without any problems. It has ~3,800 miles since early April.
 

·
Super Moderator
Joined
·
3,643 Posts
Yes some people have. So far the majority have been due to the line to the vapor recovery canister not being installed properly. It permits unmetered air in which causes idle and stalling issues.

Also, there were the issues with crushed wiring which seems to be 3/15 manufacturing and earlier that had the chance to draw the short straw. That messes up the body control module which can make all sorts of bad things happen.
 

·
Registered
Joined
·
13 Posts
Yes. my car lost all electricity today. I cannot get a single light to turn on. keyfob gets nothing. The horn doesnt work. The door locks issue was going on prior to complete power failure.
 

·
Registered
Joined
·
85 Posts
It happened with my trailhawk yesterday, it won't start and all the icons on my dashboard came up. I took out the negative cable from the battery and waited 30 second and restarted and all is good. If it happenes again I'll have the dealer take a look at it.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top