Jeep Renegade Forum banner

2016 Trailhawk UConnect 6.5 NO SETTINGS

398 Views 0 Replies 1 Participant Last post by  PSquared

Have had several UConnect 6.5 Radio Head Problems. Several years ago, I discovered what seemed to be a DST error - the clock time was off an hour for severa months in the summer. Last year the language choice suddenly reverted to Italian and would not set back to English. A quick check of YouTube and I found the fix. This time I am not having any luck and Chrysler Custoimer Support is no help.

I store the Jeep over the winter months and charge the battery periodically. After checking the manual, I decided to disconnect the battery this past winter. With the snow and road salt all gone, I hooked the battery back up and found the UConnect 6.5 radio clock was off - as I pretty much expected. The date had also reverted to 1/1/2016. The problem initially was that I could not set the time. I quickly found that only one of the other settings - displaying the time on the display - could be changed. Nothing else on the Clock Page could be changed. From there, it only got worse - I discovered that ~ 90% of the available settings could not be changed - including:

  1. Settings>Sirius XM Setup: SXM Tune Start does not respond
  2. Settings>Units: no selections can be made – Units displayed are OK
  3. Settings>Voice: settings can be changed
  4. Settings>Clock: The only setting that responds is Show Time in Status Bar
  5. Settings>Safety & Driving Assistance: no settings respond
  6. Settings>Lights: no settings respond
  7. Settings>Door & Locks Locks: no settings respond
What I find is that on any settings screen where a choice can be made, the selected choice has an amber background and if I change my choice, then the amber background moves to the new choice.

Check my attached photos for any idea of what I am seeing.

Vehicle audio Vehicle Automotive design Audio equipment Auto part

Car Vehicle audio Personal luxury car Plant Automotive design

The Radio and Navigatiojn all work normally.

I tried a reset from the system information page. About the only change I could find is that my audio equalizer and balance settings reverted to neutral. Settings could still not be changed.

The Uconnect firmware has never been updated. I enetered my VIN on the Chrysler UConnect page and nothing happens.

Anybody experienced anything like this, or have any ideas??


See less See more
1 - 1 of 1 Posts
1 - 1 of 1 Posts