Jeep Renegade Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi Guys, I have a 2019 renegade limited that has 8000 miles on it. Let me preface this by saying that after I purchased it at about 40 miles the entire car basically shut down one time after turning it on. every indicator light was on and the vehicle could not accelerate past 30 mph even pressing the gas all the way down. Anyway, jeep took it and fixed it. it took about 3 weeks and they were very unwilling to do anything compensation-wise for me other than give me a loaner.

fast forward- Now my issue is for the past several 1000 miles it seems that every time i drive highway speeds the service transmission light and check engine light come on until i park it and the next morning it is usually fine. I feel like this should not happen, I wanted to see if anyone else had something like this happen.
 

·
Super Moderator
Joined
·
3,702 Posts
welcomegroup

and enjoy the forum!

What are you talking about compensation? They gave you a loaner what did you wont them to do give you money?

I am on my 2nd little Jeep with 0 problems. Our Jeeps need software updates from time to time do to all the computer stuff in them. I bet that will fix your new problem.
 

·
Registered
Joined
·
207 Posts
Hi Guys, I have a 2019 renegade limited that has 8000 miles on it. Let me preface this by saying that after I purchased it at about 40 miles the entire car basically shut down one time after turning it on. every indicator light was on and the vehicle could not accelerate past 30 mph even pressing the gas all the way down. Anyway, jeep took it and fixed it. it took about 3 weeks and they were very unwilling to do anything compensation-wise for me other than give me a loaner.

fast forward- Now my issue is for the past several 1000 miles it seems that every time i drive highway speeds the service transmission light and check engine light come on until i park it and the next morning it is usually fine. I feel like this should not happen, I wanted to see if anyone else had something like this happen.
Drive train should still be under warranty. I would bring it back in and make them fix it.
 

·
Registered
Joined
·
242 Posts
Also have the Limited (19) the first problem sounds like good ol battery, lights up the dash, goes into limp mode. The second problem could be the dealers not clearing the codes properly, mine still says change oil when fired up but i know its been done. (y)
 
1 - 4 of 4 Posts
Top