Jeep Renegade Forum banner

How many times has your Renegade been in for unscheduled service?

  • 0 times

    Votes: 92 57.5%
  • 1 times

    Votes: 45 28.1%
  • 2 times

    Votes: 6 3.8%
  • 3 times

    Votes: 8 5.0%
  • 4 times

    Votes: 4 2.5%
  • 5 times

    Votes: 0 0.0%
  • 6 times

    Votes: 3 1.9%
  • 7 times

    Votes: 1 0.6%
  • 8 times

    Votes: 0 0.0%
  • 9 times

    Votes: 1 0.6%
1 - 20 of 89 Posts

·
Super Moderator
Joined
·
3,600 Posts
Discussion Starter · #1 ·
Hurray! You made it to 5000 miles. Let us know how your Renegade is doing and if you needed any unscheduled maintenance or repairs. Help out your fellow forum members, and fill out the poll. Make a post, and summarize your tale of joy or woe as well.
 

·
Registered
Joined
·
23 Posts
I have 13,000 on mine. Had it since March 31, 2015. No issues. I am posting it here as there is not a sticky for over 10,000. I have had 2 oil changes, have had a software update for the PCM and the TCM. Did not really notice any difference, except maybe MPG went up 1 MPG.
 

·
Registered
Joined
·
15 Posts
6500 Miles and happy

Very pleased. only issues wernt really issues. A valet guy at the hotel messed with the setup and disabled my backup camera and after my first oil change the dealer mechanic neglected to put the oil filler cap back on and sprayed the engine compartment with oil. All good now. about 27 in town, 31 or better on the turnpike at 74 mph. I got some aftermarket seat covers and they look and fit good. Rubber floor mats too. Happy to be a renegade owner.
 

·
Registered
Joined
·
6 Posts
6300 miles and going strong. Just finished a 12 day 3500mi road trip and got 24.7 mpgs overall. Only "problem"so far is that the horn is much squeakier now than when I bought first bought it but I think that's because I went through too deep of a "puddle" too quickly and shorted it out a bit. Still works but not as beefy. The horn is apparently behind the driver side headlight just fyi for those who drive through water. Taking it in on Monday to see if they can fix/replace it.
 

·
Registered
Joined
·
31 Posts
Sport 4x4 Model
Coming up on the 5k mark.

Got a random 4wd unavailable light / service 4wd.
Shut jeep off and restarted, light went away. Has done it one other time.

No more issues with locks.
Still averaging around 28mpg with 80% highway
 

·
Registered
Joined
·
141 Posts
Just passed 5000 the other day. Only problem was at 100 miles. They did the computer update and have had no other issues. I love the vehicle. It appears that many (at least who have found this thread) have had similar positive experiences. Although you wouldn't think if you just look through this forum.
 

·
Registered
Joined
·
64 Posts
Will probably be about 5200 or so when I get home tonight. Aside from the 2 times I have been towed I am enjoying it. The kid and the giant dog are enjoying it. No noises, vibrations or rattles. I really do love the way it drives and am over the moon in tight parking lots! So if we are done with the computer talking to the transmission I will be selling one wherever I go!
 

·
Registered
Joined
·
1,612 Posts
Will probably be about 5200 or so when I get home tonight. Aside from the 2 times I have been towed I am enjoying it. The kid and the giant dog are enjoying it. No noises, vibrations or rattles. I really do love the way it drives and am over the moon in tight parking lots! So if we are done with the computer talking to the transmission I will be selling one wherever I go!

Giant dog? Pics?
 

·
Registered
Joined
·
221 Posts
6600 Miles
2015 Jeep Renegade Trailhawk
Purchased the 3rd week in April 2015
Offroad active

No major issues that have prevented me from enjoying the Renegade.


Minor Issues to note in no particular order.

- Took a long time to downshift. So I was on the freeway and I floor it to try and get around a slower car. Took a few seconds until it finally down shifted. From what everyone is experiencing with this, its the transmission learning your driving habits. It only happened once for me.

- The Uconnect 5.0 locked me out. When to fill up on gas and got back in the car. Started it up and the stereo lock out on me. Said I needed a pin to unlock it. It's a anti thief feature. After a quick search online, it turns out its a pain to get the code to unlock it. A trip to the dealer or arguing through the phone. Luckily when I went to use the Renegade the next day, everything worked again. I don't know what's going on. Only happened to me once.

- Auto transmission rolls a bit when changing gears. For a new car I don't expect this so soon or so much roll. When putting the car in park or switching from reverse to drive the car likes to roll a bit before doing what you want it too. I park in my drive way with a slight slant, put it in park, and as I release the brake, I naturally open my door at the same time. Then the car starts to roll. WTF! Hit the brakes. Now I find myself releasing the brake and waiting for the whole roll process to stop and make sure it doesn't keep rolling, even though I know it won't. Before I open my door. It's a un-nerving and un-natural process for me. It's the same when I reverse the car and when I go into the drive. The car tends to keep rolling back a bit before it starts moving forward. Hit the brakes! Am I in the right gear? Yes I am. Remember the car likes to roll back a bit first.

- Metal rattling under the car. After offroading a bit, I get some rattling when going over bumps, ruts, and wash board dirt roads. I think the rubber hangers for the exhaust has broken in / loosen up and the catalytic converter or resonator is banging around under there.

- 4WD Service. Came on after I got off of work. Drove the car in limp mode and was not able to switch any of the drive modes. Turns out the solution was to turn to car off and back on. This is like a check engine light for the transmission and 4WD system. You need to take it into the dealer to do maintenance. But it shouldn't be coming on this early. Only happened to me once.

- Alarm won't turn off. Went to pick up a friend. Turned the car off, walked around to help the friend load some gear. Walked back around to the driver door and opened it. The alarm start going off. I can't turn it off using the key fob, inserting the key into the door, inserting the key into the ignition. Nothing. I can start and drive the car with the alarm blaring. After a few minutes it finally turns off. No idea what happened. Only happened to me once.
 

·
Registered
Joined
·
1,624 Posts
. . . - The Uconnect 5.0 locked me out. When to fill up on gas and got back in the car. Started it up and the stereo lock out on me. Said I needed a pin to unlock it. It's a anti thief feature. After a quick search online, it turns out its a pain to get the code to unlock it. A trip to the dealer or arguing through the phone. Luckily when I went to use the Renegade the next day, everything worked again. I don't know what's going on. Only happened to me once. . .
I had this problem once too (only once). Turned off the car and everything was normal afterward.
 
1 - 20 of 89 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top