Jeep Renegade Forum banner
1 - 20 of 34 Posts

·
Registered
Joined
·
216 Posts
Discussion Starter · #1 ·
Is anyone having problems with their 6.5infotainment system in their Renegade?
Anything acting up, functions missing, weird reboot, no apps, Yelp app missing, etc?? Thanks everyone!!:ReneBlueWave:
 

·
Registered
Joined
·
59 Posts
I don't know if there is a setting or not. But the wife is complaining about the Navigation . it does not mute the radio when the Nav is giving directions, so you have the Nav talking and the radio playing at the same time. I thought that the radio would mute. Also radio does not mute when receiving phone calls either.
hard to hear the call.
 

·
Registered
Joined
·
216 Posts
Discussion Starter · #3 ·
VARenegadeUSA-- mine does not do that, have not had any issues with phone yet, BT, etc. I believe there is a setting in NAV that will mute/stop avatar voice. What kind of apps do you have loaded in your system??
 

·
Registered
Joined
·
59 Posts
VARenegadeUSA-- mine does not do that, have not had any issues with phone yet, BT, etc. I believe there is a setting in NAV that will mute/stop avatar voice. What kind of apps do you have loaded in your system??

We haven't signed up for the apps yet, probably later today or tomorrow.
The wife is out and about visiting family. Will let you know if I have any problems when I download the apps.
 

·
Registered
Joined
·
59 Posts
Went through all the headache setting this radio up and the apps for the phone.
YELP doesn't work !!!! was on the phone with them for a hour and now have a Ticket number and somebody will get back to me.....
The remote lock and unlock feature from the mobile phone works, along with the flash headlamps and sound horn. Do not have remote start (jeep not equipped with it)
I have the voice texting through the radio and it works. seems every thing works except Yelp.
Voice command to "Launch Yelp" is not recognized.

On the Nav the voice comes out of the LEFT side speakers and the music still plays on the right speakers turned up the volume on the Nav unit so the left side is louder than the right side. to me that still doesn't sound right it should mute the radio.
but what do I know.
 

·
Registered
Joined
·
216 Posts
Discussion Starter · #7 ·
Wow!! same problem as me. Sucks being on phone that long trying to fix problem; I have spent 5+hrs on phone with them and still have (2) open tickets and my problem has been sent to senior tech folks plus my dealership reported issue and they have STAR reps contacting the radio system folks(folks who build and program the radio) for help. Hopefully more Renegade owners with this issue (which I assume there are many more out there that have not reported it or realize they should have Yelp feature). Keep me posted and I will do the same. Thanks for info and update on my post in Renegade forum:)
 

·
Registered
Joined
·
216 Posts
Discussion Starter · #8 ·
VARenegadeUSA- can you go into your NAV, settings and goto your map icon setting and see if your map icons change when you select diff ones like Ram, Fiat, Dodge, Jeep, etc. My icon just stays the regular blue triangle no matter what I change the icon to and only thing I noticed that changes some is color of main roads. In my 14 Jeep Cherokee, when you change the map icon, it will actually change to diff vehicles like a grand cherokee, or old jeep or dodge charger, etc. I think this is another software issue with this 6.5/RA4 system:(
 

·
Registered
Joined
·
59 Posts
VARenegadeUSA- can you go into your NAV, settings and goto your map icon setting and see if your map icons change when you select diff ones like Ram, Fiat, Dodge, Jeep, etc. My icon just stays the regular blue triangle no matter what I change the icon to and only thing I noticed that changes some is color of main roads. In my 14 Jeep Cherokee, when you change the map icon, it will actually change to diff vehicles like a grand cherokee, or old jeep or dodge charger, etc. I think this is another software issue with this 6.5/RA4 system:(
OK just went out and checked and the same as you stated;
"My icon just stays the regular blue triangle no matter what I change the icon to."

I went through all of them no change same blue triangle icon. :(

Wish they had where you could download icons like the TomTom


Not sure if it a software issue or they just have a CHEAP program.

PS NO Yelp yet and never received a call back from tech support.
 

·
Registered
Joined
·
27 Posts
My only "complaint" is the only app available as of today is Yelp. No Pandora, for example. Other than that is perfect!
 

·
Registered
Joined
·
216 Posts
Discussion Starter · #11 ·
Thanks for checking your nav; at least we now know this is an issue with all 6.5 systems with nav. It has to be the software, sorry no one has called you back. Thing is, none of the Uconnect reps know what the problem is. It's probably going to take someone to actually get with folks who programmed them.
 

·
Registered
Joined
·
216 Posts
Discussion Starter · #12 ·
Joelg1988- I am assuming you have the 6.5 uconnect system and you do have the yelp app? Was this feature pre-loaded in your 6.5 system or did it activate and appear once you registered your vehicle and uconnect account? Can you change your nav map icon to other icons except the standard blue triangle?
 

·
Registered
Joined
·
216 Posts
Discussion Starter · #13 ·
6.5 infotainment problems

Joelg1988- I am assuming you have the 6.5 uconnect system and you do have the yelp app? Was this feature pre-loaded in your 6.5 system or did it activate and appear once you registered your vehicle and uconnect account? Can you change your nav map icon to other icons except the standard blue triangle?
 

·
Registered
Joined
·
59 Posts
My Nav mutes the LEFT speaker(s) only and the right keeps playing at full volume. Kinda cool feature since only the driver really needs the nav info.
Question: if your LEFT speakers mute for the navigation how do you hear the turn by turn instructions with the right side speakers playing music?

This is my problem with the Navigation system and a safety issue.
It has been suggested that you mute the radio to hear the Nav instructions. :(

So, you have to take your hand off the wheel and eyes off the road to mute the radio.
This is suppose to be a HANDS FREE radio. DUH! :confused:


Don't think I would want to be doing this in rush hour traffic in Detroit, Los Angles or Atlanta. :rolleyes:

Problem is this is a NEW radio and the Navigation is controlled by U-Connect and unlike the older Nav radios, that had a hard drive with the maps loaded on to it. The older systems MUTED the radio music while giving you turn by turn instruction.

Hopefully there will be an update to the software to correct this.
and if you don't want to listen to the turn by turn instructions you can disable it.
 

·
Registered
Joined
·
2 Posts
Not even able to register

I purchased a 2016 Renegade with the 6.5 UConnect a week and half ago. I don't even have the ability to register. The assist button doesn't work. The dealer put in all new equipment. They called UConnect and were told that there is a software patch with an undetermined release date that will be needed before I can even register. There is no option to register on the apps screen. So, I have no apps. I also have no voice texting, either.


The dealer gave me my car back and told me I have to wait on the update from Chrysler.


I opened a ticket with UConnect yesterday and am waiting for them to call me back. Any advice on any other avenue I should be taking to have this problem addressed?


Thanks!
 

·
Registered
Joined
·
183 Posts
I'm also in the same boat and have the 6.5 radio. I am looking into getting some kind of compensation for this not working, but am going to keep my Jeep and wait for a fix. I also have a ticket open with Uconnect. Doesn't look like there is going to be a fix anytime soon.

Keep us posted on your progress.

Thanks, jjp
 

·
Registered
Joined
·
2 Posts
I'm also in the same boat and have the 6.5 radio. I am looking into getting some kind of compensation for this not working, but am going to keep my Jeep and wait for a fix. I also have a ticket open with Uconnect. Doesn't look like there is going to be a fix anytime soon.

Keep us posted on your progress.

Thanks, jjp
Spoke with UConnect, yesterday. No, ETA on the fix. But, they are working on it and will call me when there is a solution. Whenever that may be...
 

·
Premium Member
Joined
·
3,154 Posts
I assume this affects all vehicles fitted with the 6.5 in U-Connect? By all I mean Alfa Romeo, Chrysler etc. If so, that is going to be a lot of peeved owners.
 

·
Registered
Joined
·
5 Posts
There are multiple issues with this system even to the point of class action law suits. Have had a trouble ticket on my vehicle since the day after I bought it. Dealer has washed their hands of it and don't even bother to contact me any longer. I call Uconnect to get status updates only to be told they don't know when it will be fixed but I am assured that, "it will definitely be this year". There is a thread here about this.... There's so many things that don't work on mine that we are actively looking to replace it.
 
1 - 20 of 34 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top