Jeep Renegade Forum banner
1 - 20 of 51 Posts

·
Registered
Joined
·
154 Posts
Discussion Starter · #1 ·
So I've covered just over 1000 miles with no issues and then today boom!
I approached the car, opened the door (keyless entry) and off goes the alarm. It wouldn't respond to remote fob. I could start the engine but alarm still blaring and amber warning lights were coming up on the dash...I think it was auto windscreen wipers and auto lights warnings?
Anyway, this went on for a good few minutes and finally the alarm responded to the remote fob and stopped.

Note this is the 1.4 petrol version, not diesel.

Anyone else who had the alarm issue, what was the fix?
I know Raff had a new bcm fitted to his but what about the others?
 

·
Registered
Joined
·
13 Posts
I thought the alarm problem had resolved itself since there have been no more posts on the subject of late. Remind me again which models was it affecting in the UK? I sincerely hope your problem is 'fixed' soon.
Regards Herm
 

·
Registered
Joined
·
154 Posts
Discussion Starter · #3 ·
I think it was supposed to be the 1.6 diesel that had the issue.
I'm hoping mine was a one off fault today but I really can't understand what triggered it in the first place. It was very random so could possibly happen again.
 

·
Registered
Joined
·
70 Posts
I disabled the passive entry feature via UConnect as I feel more comfortable knowing that I have locked/unlocked the car, plus I've heard lots of reports of cars being stolen in this way since would-be thieves are able to intercept the signal emitted by the car to detect the fob and so gain access.

That said, I have had a couple of instances where the alarm has gone off for no reason, but it always responded to the key fob, and the only warning I had on the screen was "Break in attempt detected". For reference, I've a 1.6 diesel Longitude.
 

·
Registered
Joined
·
221 Posts
4200 miles and it happened to me too. Parked the jeep got out to greet/pick up a friend. Was out of the jeep for less than a minute and walk around to the passenger side only. Got back in the driver side and the alarm went off.

I pressed all of the buttons on the key fob and started the car as well. Nothing was turning off the alarm. Got in and out of the car, locking and unlocking it. Still nothing. Usually a press of the key fob or inserting the key into the ignition works on other cars, but my Renegade has a push start system.

After a like 3 minutes I turned it on and decided to move the jeep onto my driveway so I can look at it closer. When I put it in drive and started moving it finally stopped. Don't know if that stopped it or the alarm is on a timer and auto shutsd off to save the battery from going dead.

Drove it out and back. Still hasn't happened again.
 

·
Registered
Joined
·
154 Posts
Discussion Starter · #7 ·
I've had another four incidences that I know of where the alarm has gone off randomly and then stopped after a minute or so thankfully. No flashing lights just the sound.
Obviously its only a minor issue for me at the moment but I wish they would come up with a fix.
 

·
Registered
Joined
·
115 Posts
I had the same issue a few weeks after I bought my TH. Wouldn't shut off no matter what I did. This was followed by the locks not working. Finally it shut off after what seemed 10 minutes with every person at a softball tourney giving me a death stare. Hasn't happened since.
 

·
Registered
Joined
·
1 Posts
Three times for me!

Hi Guys,

Just to let you know that I've had the issue happen three times.

The first time it happened the alarm was going off for around 10mins before it stopped on its own. The trouble I had was on doing so, everything else went dead. The hand brake button wouldn't work so I couldn't even take it to the dealer. On phoning the dealer they said that I had to call Jeep direct with the issue. No number was given, I found this under the drivers sun visor. I then waited an hour or so for the Jeep engineer who on arrival still didn't have the correct software on his laptop as the Renegade was too new. He then lifted the bonnet and disconnected the battery and after a minute reconnected. He said if it happened again then firstly, take it to the dealer after doing the battery trick.

The second time was while I was shopping, but the alarm turned off after pressing the key.

The third, last night, has to be the worst. I had to pick my girlfriend up from work at midnight. The alarm went off in our driveway and wouldn't go off. After 5mins pressing buttons on the key, opening closing door it finally did. I drove away and halfway down the road it went off again. So I was driving while the alarm was going off with nowhere to stop. Very embarrassing. I must of looked like I stole the car. I managed to pull over somewhere, lift the bonnet and disconnect the battery. Alarm still going, I then reconnected and the alarm finally responded to the key. The dash said "break in attempt" and then reset itself.

Jeep are aware of this but I assumed it was fixed. I had to wait three weeks before I could pick it up as they said there was a software fix for the alarm. This has obviously not worked.

I love the car but this is a little scary and extremely embarrassing.

Just for reference, I have the Opening Edition 1.6 here in the UK
 

·
Registered
Joined
·
44 Posts
Touch wood no problems with mine for a while it's such a shame for all owners who've had this problem really takes the shine off a new car purchase!

Mine has been in reinstalled three times inc one before picking it up, also an opening edition diesel.
 

·
Registered
Joined
·
73 Posts
Woken up this morning by the car alarm. Couldn't turn it off - buttons on key wouldn't work. Woke up all the neighbours!

No lights were flashing, which I was surprised at, and when i put the key in the ignition (one of my desparate attempts to shut it up) a message said check running lights - so i think it may be a wider electrical problem. Anyway, it eventually shut up and all seems ok now.

I have a standard manual key on my renegade (1.4 2wd manual), so not a keyless start related issue.
 

·
Registered
Joined
·
45 Posts
I must have a good relationship with my dealer. I refuse to call Jeep. I get the dealer to do it whilst they come and pick my car up. The dealer is 80 miles or 1.5 hours drive away. This means taking off work for a day and and a couple a gallon of diesel.
Remember if there's dash warning lights on, you should not drive your car any distance.
Jeep do have a recovery system in place with your warranty.
It's amazing how my warning lights are out when the recovery lorry arrives.
 

·
Registered
Joined
·
27 Posts
Happened to me last nite,alarm going dash lit up like a Xmas tree,windscreen wipers wouldn't switch off and no lights ,drove home parked in drive and disconnected the battery which seems to fix it. Cars now back with dealer till they can fix ?
 

·
Registered
Joined
·
105 Posts
Happened to me last nite,alarm going dash lit up like a Xmas tree,windscreen wipers wouldn't switch off and no lights ,drove home parked in drive and disconnected the battery which seems to fix it. Cars now back with dealer till they can fix ?
Well it was all going so well, three weeks & 850 miles of perfection. Until that is when I decided to show one of my colleges my new car. Pulled on the handle to open the car & the alarm went off & no matter what I tried it would not stop!. Eventually it stopped but when I started the car I got "Check daytime running lights" then various other warnings. I drove the car to the dealer which was not very clever as had no brake lights or indicators, windows did not open either so I could not even do any hand signals.

Well the long & the short of it the car was fixed in less than an hour, the body computer was flashed. Apparently this new programme is the fix for this issue.

So there is a fix, hopefully that's it now and I can continue to enjoy my car.
 

·
Registered
Joined
·
221 Posts
Sounds like all these experiences have been the same. I seems to me like the alarm is shutting itself off after a minute or 2. Most alarms systems do this to prevent the alarm from draining your battery.

Still not solid solution to this problem yet.

As for me, just the one incident I had the last time I posted here. Hasn't happened to me again since then.
 

·
Registered
Joined
·
5 Posts
Same alarm issue

I've had my 1.4 petrol Limited for a month now - the alarm has gone off randomly a couple of times for no apparent reason - unlocking the door has stopped it though (keyless entry). Am worried it's part of a bigger issue reading other's comments - is there an update I can do myself or is it one for the dealership?
 

·
Registered
Joined
·
154 Posts
Discussion Starter · #19 ·
Supposedly there is a software update to fix it at the dealers. However I've heard folk saying they had this done and then the alarm played up again.
Mine has been quiet for a good month now and I live too far from the nearest dealer so I haven't had mine updated as yet.
 
1 - 20 of 51 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top