Jeep Renegade Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi! Im new here!
I bought my 2015 Jeep Renegade Trailhawk, brand new, about one month ago. It has the amplified speaker and subwoofer package. To me the subwoofer sounded great. But the day I drove it home the speakers sounded horrible. I thought it was just the drivers side front speaker that sounded bad. It was fuzzy and crackly. It sounded like it had been blown out. I took it in to the dealership and they said it was all of the speakers that were doing it. Their solution, after calling Jeep, was to replace the amplifier. To me that didn't seem like it would fix the problem but I let them change the amplifier. Nope, did not fix it. Now Jeep is saying to replace the whole radio. I think that is extreme! If its the speakers that sound blown out maybe the wiring is loose or the speakers are bad. I don't understand how replacing the whole in dash radio will fix this.
Also, after getting my Jeep back from the dealership, after they replaced the amplifier. My odometer is blinking, the bass is non existent and I can't use my surround sound function. The bass beforehand sounded great! I only needed to set it up 3 notches. Super loud, just like I like it. But now I have it turned all the way up and there is almost no bass. With the surround sound I was able to turn it off and back on but now it says its not compatible. WTF!? I called them about the odometer and they don't know what to do. UGH!!! I have another appointment this Friday, January 8th.
Im pretty upset that the speakers sounded this horrible in a brand new car, after paying for the upgraded system. AND the dealership people are a fucking joke. I go in to fix one thing, they don't even fix that and now they've created 3 new problems.
HELP?!
Thank you
April
 

·
Registered
Joined
·
78 Posts
Some good news on the 2015

I have the 9 speaker with amp and sub upgrade on my 2015 and it sounds better than my last 3 vehicles of which one was a BMW with a $2500.00 Audio Upgrade System in it, I think the OP with the 2015 will get this worked out once they figure out what the problem is.


The beats system cant tell ya, seems to be no one happy with that system from all post I have read.


Chris
 

·
Registered
Joined
·
144 Posts
I have a 2015 with the 6 speaker system. I think the amp is fine, unlike the Beats system where the way the amp is programmed makes it sound terrible. The speakers are cheap junk, however, but pretty easy to replace. With replaced speakers, I think my system now sounds pretty good- not fantastic, but pretty good!
 

·
Registered
Joined
·
155 Posts
I wonder if, when they replaced the Amp, you got the Beats premium (their terms, not mine) amp? One of the complaints about the Beats Premium system is that it seems that the Amp processor sends very little signal to the subwoofer.
 

·
Registered
Joined
·
534 Posts
the beats system is a dog pile ..and I am being kind
I am bringing mine in to complain...
 

·
Registered
Joined
·
155 Posts
The 6 speaker sound system sounds like crap as well, but an easier fix- replace the cheap speakers. However, I think those of you who paid extra to get "premium sound" and aren't should complain loudly!
 

·
Registered
Joined
·
607 Posts
Thanks Still. I'm glad you took the time to reply.Even though it was a sarcastic non-answer. I appreciate the effort.
Lol,sorry was in a dick mood I guess. There is a update that can be applied to amp at dealer. Waaaaay better.
Nice save. :)
:laugh::laugh::laugh::laugh:

You guys are funny. And I have an appointment with my local dealer next week to get my "Amp Update" for my beats audio system. I like the way my beats audio system is now (after adjusting the equalizer), so if the update makes it better then that'll just be icing on the cake!
 

·
Super Moderator
Joined
·
3,597 Posts
A bad install or a bad replacement can cause the blinking. The fuzzy crackles can be the speakers, amp (in the 9 speaker/beats setup), or head unit. The Beats system rolled out in the US buggy as sin. It's entirely possible they replaced a patched but messed up unit with an unpatched but messed up unit, or did a bad install on an unpatched but good unit.

If it was all four speakers, I'd guess it was the amp or head unit too. The odds of all four blowing at once without having input some seriously loud signal to the stock system is pretty low. Maxed out on my 2015, it was hard to get the stock system to distort or clip from satellite or radio. I had a couple of song like objects that could, but they are genuinely weird in how they are mixed and I was running them through EQ as well. Still didn't blow any of the stock speakers.

There is a patch for the beats system to improve things. They should be able to combine this with a working head unit for your ride. Have faith, and supplement with a call to JeepCares if needed.
 
1 - 19 of 19 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top