Jeep Renegade Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Hey everyone, hoping to get some feedback on this issue I've been having since I purchased my car in December.

The auto start stop or ess does not work most of the time. It constantly says battery charging. Initially after I got the car I just thought it was because it sat on the lot for several months and up until recently it said it was ready to use off and on. It's now said battery charging every time I drive the car. I drive short distances to work and really only get one good drive in on the weekend but I just drove 150 miles over the past two days and it still says it's charging.

If it's completely normal I won't worry about it but on other renegade forums I have seen a 50/50 split of users saying they just let it go and it works off and on, mainly attributing it to them not driving long distances often, and the other half have said the dealer put in a new secondary battery and it now works fine. Being that it took my dealer over 2 weeks to fix a separate issue last time it was in I'm hesitant to jump to take it back. I remember bringing it up to them as well and they said it's because I don't drive enough for the battery to charge but wouldn't driving 150 miles be enough?

I'm also one of those who doesn't really see any benefit to using ess in my driving situations,but the battery always saying it's charging makes me feel like it's not holding a charge, and I'll have other issues down the road so that's why I want the system to engage, even if I don't see a benefit to using it.

Thanks to anyone who chimes in on this, I am looking to finally have some piece of mind. Seems like this car has raised more questions than answers since purchasing it and I just want to be able to fully enjoy my new car
 

·
Super Moderator
Joined
·
3,788 Posts
Some thing is wrong with your little Jeep bring it in to the dealer. You should never have codes or battery charging popping up all the time!
 

·
Registered
Joined
·
22 Posts
I’ve got 4K on mine since I bought it in Nov and have never had the system activate. It’s always charging. The dealer is aware, when I take it in for the first oil change they plan on looking at it. I haven’t lost a wink of sleep over it ?
 

·
Registered
Joined
·
18 Posts
I do not have that feature on my 2017 Renegade, but my wife has that feature on her 2016 Cherokee. You lose battery power when the outside temperature drops, especially in the winter and the auto start/stop feature monitors battery power level and disables the feature if the power level drop below a certain point. Some winters the feature will not work all winter long because the battery is not at it's peak charge to handle all the starts and stops. I find that the feature can become quite annoying, especially in city driving so I manually override it.
 

·
Registered
Joined
·
1,125 Posts
Hey everyone, hoping to get some feedback on this issue I've been having since I purchased my car in December.

The auto start stop or ess does not work most of the time. It constantly says battery charging. Initially after I got the car I just thought it was because it sat on the lot for several months and up until recently it said it was ready to use off and on. It's now said battery charging every time I drive the car. I drive short distances to work and really only get one good drive in on the weekend but I just drove 150 miles over the past two days and it still says it's charging.

If it's completely normal I won't worry about it but on other renegade forums I have seen a 50/50 split of users saying they just let it go and it works off and on, mainly attributing it to them not driving long distances often, and the other half have said the dealer put in a new secondary battery and it now works fine. Being that it took my dealer over 2 weeks to fix a separate issue last time it was in I'm hesitant to jump to take it back. I remember bringing it up to them as well and they said it's because I don't drive enough for the battery to charge but wouldn't driving 150 miles be enough?

I'm also one of those who doesn't really see any benefit to using ess in my driving situations,but the battery always saying it's charging makes me feel like it's not holding a charge, and I'll have other issues down the road so that's why I want the system to engage, even if I don't see a benefit to using it.

Thanks to anyone who chimes in on this, I am looking to finally have some piece of mind. Seems like this car has raised more questions than answers since purchasing it and I just want to be able to fully enjoy my new car
Hi Reno,
I understand why this would be concerning to you- have you already brought this to the attention of your dealer? I would recommend a proper diagnosis first, then feel free to reach out to us privately if you have any further questions.

Kathryn
JeepCares
 

·
Registered
Joined
·
1,676 Posts
Same as Red Renny, I have disconnected the Start/stop and have never used it.

For me it seems more of a gimmick than a proper usable feature.
 

·
Registered
Joined
·
131 Posts
Auto stop start seems to be a political Greta Thunberg thing. I think it's biggest impact is to kill batteries, and dead batteries are not want you want with this model. Mine is permanently switched off. I don't have ESS but I can't see that being a problem. I could live without it. Hey, I do!
 

·
Registered
Joined
·
1,676 Posts
Time to install a small solar panel on your Renegade front dashboard :unsure::p

Auto stop start seems to be a political Greta Thunberg thing. I think it's biggest impact is to kill batteries, and dead batteries are not want you want with this model. Mine is permanently switched off. I don't have ESS but I can't see that being a problem. I could live without it. Hey, I do!
That silly wee lassie has got so much to answer for. We had the young Millenials not wanting to work and now Greta GreenThunberg and her Green gang. My diesel engine will be staying alive if I can help it for a long time :ROFLMAO: :ROFLMAO: :ROFLMAO:
 

·
Registered
Joined
·
28 Posts
After a long motorway drive, mine works fine for a few days of urban driving and then stops until I take it for a long run again. This is despite the dash readout saying it has 14V on the battery (maximum on mine). As a test, I connected a proper battery charger once for about 30 mins (after a few weeks city driving) and immediately the stop start worked afterwards so it looks like the ECU monitors the charge (or amps draw) and either enables or disables it.

Not unusual for it to never come on during winter and cold termperatures with all the toys swirched on (heated seats, wheels, etc.). I quite like the stop start, there are real demon traffic lights near my place that are green for only 8 secs (I've timed them!) before switching back to red for 2 mins. This is all the fault of the useless local councils, I mean just what is the point of ...... (snip. Ed)
 

·
Registered
Joined
·
1,676 Posts
DH, where did you find the Voltage setting. I had a look around and found it when I wasn't needing it. Now I can't find it at all :cry::cry::cry:

That's just typical.
 

·
Registered
Joined
·
4 Posts
I’ve got 4K on mine since I bought it in Nov and have never had the system activate. It’s always charging. The dealer is aware, when I take it in for the first oil change they plan on looking at it. I haven’t lost a wink of sleep over it ?
Did the dealer ever kid this for you? I’ve had mine over a year and it has only worked maybe 6 times. I’ve had in into the dealer 4 times and they keep doing a reset. It works the very next day for one or two stops and then it doesn’t work again. They tell me the battery is at max charge.
 

·
Registered
Joined
·
4 Posts
Anyone actually ever had the dealer be able to fix the issue. Mine is in for the 4th time. New vehicle, had in over a year and it has never worked right. Maybe 6 times. I’ve driven other cars with this feature and know how it is suppose to work and reasons why it doesn’t sometimes. They tell me the second battery has a full charge. They do a reset and it will usually work 1 time after that the next day. Having bought it brand new I just feel like it should work. I’m ready to just give up but think for resale it should have the features it came with.
 

·
Registered
Joined
·
29 Posts
I fixed mine by paying for and having the dealer put in an AGM battery. Everything was checked and working, so I decided to have them do my fix. Prior to this AGM battery the PCM and IBS were replaced, battery was also tested as being good.
 

·
Registered
Joined
·
1,676 Posts
@dmnjr Great to see you replaced the old with a new AGM battery. Quite a lot of the forum users have gradually being facing the same issues and problems but resolving them with a new battery.

Great work and thanks for the updated solution (y)(y)

ps: If anyone can use a spanner or a socket then replacing the battery is really easy and will save you on a garage installation cost unless of course your car is already in the gargage.
 

·
Registered
Joined
·
29 Posts
Thanks Puddlesplasher. Was acually trying to get it done under warranty. Price was negotiated down to about $10 over what I could have installed it for. Not pleased that a JEEP under a year old would have this problem, now all is good.
 

·
Registered
Joined
·
1,676 Posts
I think my 2015 Jeep was around 1year old when the Dealership replaced the battery free of charge. There were a few issues that were fixed with an Dealership update for the on-board computer (or whatever you guys call it) but it didn't fix the battery. Once they fitted a higher amperage battery it all worked out well. The battery is now almost 4 year old but this forthcoming Winter will be the telling moment. if so then I will expect to pay around £170 for a new one.
 

·
Registered
Joined
·
4 Posts
Forgot to mention 2019 Renegade with the 1.3 turbo.
Thanks, just got it back after the dealer had it 10 days. Worked on day 1 and has quit working again. Battery charging! They said they changed the battery sensor. Will be bringing it back for the 5th time. Mine also is the 1.3 turbo. They keep giving me the “there’s lots of reasons it doesn’t work” yet my loaner car from them was a 2020/21 renegade and it worked perfectly.
 
1 - 20 of 22 Posts
Top