Jeep Renegade Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hello everyone,

I wanted to share my recent experience with the issues that I ran into with my new 2016 Rene auto tranny.

So on Wed, with a whopping 660 miles on the odometer, I proceeded to put the Jeep in reverse and backed out of the parking space and put it into drive. I then hit the gas to accelerate and it struggled to get going. I then received a warning to put the vehicle in Park and reselect the gear. I did this and the transmission light came on along with a service engine soon warning. I pulled over to access what to do. I realized I was close to the dealership so I limped over with the transmission light illuminated. The Jeep wouldn't start in first (this is an assumption as it would not allow manual mode). It felt like it was starting in third gear because of the extremely sluggish response. It wouldn't switch gears so like I said thank God I was close. While driving, I also noticed the traction control light flickering erroneously as well on the drive over.

The service dept. stated the Jeep was throwing "20" different codes so he didn't know where to start. He did a reset and said everything is OK at this point. Obviously there is something really wrong. I spoke with the GM at the dealership and he suggested I start a case with Jeep. I contacted them and was told that a case manager would contact me in 1 business day to help resolve the issue.

This is extremely disappointing as you can imagine. I buy new cars and pay the premium to not have to deal with these issues. Especially after under 700 miles.

I do a lot of long distance traveling and I don't want a vehicle that could leave me stranded at any minute. To make it worse, I haven't even made the first payment .

Has anybody else dealt with this type of situation or have any advice on what to do?

Sent from my SAMSUNG-SM-G925A using Tapatalk
 

·
Registered
Joined
·
79 Posts
Oh, I feel sorry for you, that is scary and disappointing. Never heard this but I assume that it could be what happened to the 2015 Rene according to many complains. So is the 2016 not reliable like the 2015?
Mine will arrive at my dealership in a month and I've already sign the purchase order with a deposit.
Fear is in my mind. Did I pick the right car? I always wanted a Jeep and not those Asian brand SUV that are really reliable. Don't forget that most of us keep a car for at least 6 years and in your case a new Jeep, that is really not serious. Where is the real american Jeep? Ummm Italian Fiat designed in USA? Hope I'm wrong.
 

·
Registered
Joined
·
78 Posts
What the heck

Am I missing something here, the dealer reset it and its fine now, and then the 2nd post, I don't even know what to make of that one, hahahaahaha.


I think people need to do more research going in, on any large purchase.


I knew going in there may or may not be an issue with the 9 speed.


So far 1900 miles and it shifts perfect, I am not an aggressive driver, I go easy on it.


????? Chris


Oh, I feel sorry for you, that is scary and disappointing. Never heard this but I assume that it could be what happened to the 2015 Rene according to many complains. So is the 2016 not reliable like the 2015?
Mine will arrive at my dealership in a month and I've already sign the purchase order with a deposit.
Fear is in my mind. Did I pick the right car? I always wanted a Jeep and not those Asian brand SUV that are really reliable. Don't forget that most of us keep a car for at least 6 years and in your case a new Jeep, that is really not serious. Where is the real american Jeep? Ummm Italian Fiat designed in USA? Hope I'm wrong.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
Am I missing something here, the dealer reset it and its fine now, and then the 2nd post, I don't even know what to make of that one, hahahaahaha.


I think people need to do more research going in, on any large purchase.


I knew going in there may or may not be an issue with the 9 speed.


So far 1900 miles and it shifts perfect, I am not an aggressive driver, I go easy on it.


????? Chris
I have not taken possession of the Jeep yet. I just spoke with the dealer. They were told by Chrysler to check for grounds that may have come loose.... They did that and found nothing. They reset the codes and no codes returned after a 15 min test drive. I have no doubt that this issue will reoccur. Something is obviously wrong to lock out the tranny to not allow manual intervention and to throw so many different codes. I have an open case with Jeep and I'm going to talk to the GM at the dealership tomorrow about what could be done to get out of the vehicle. I would advise everyone to do their research on anything with this 9 speed transmission (ZF 948TE). Obviously there continues to be issues.

Sent from my SAMSUNG-SM-G925A using Tapatalk
 

·
Registered
Joined
·
78 Posts
Jumping the gun

I would talk to the GM and see if they can help you if the issue occurs again, which I may or may not ever do this again. This is a new one I haven't seen before, and there seems to be plenty of happy owners not having any issues with the vehicle, just a small scattering of very vocal owners with issues.


Don't know, I drove 3 when I did my test drive and they all shifted fine.


I would give it a second chance then get crazy and look for a way out if it happens again. Chris


By the way Chris. I followed the break in to the T. I hardly take it over 3k. I babied this vehicle from the beginning. This is no fault of mine.

Sent from my SAMSUNG-SM-G925A using Tapatalk
 

·
Registered
Joined
·
79 Posts
Mine will be a 6 Speed Auto Dual Clutch 1.4 litre 4 cylinder Multi Air turbo. Hope no issues. Time will tell.
@flaps, OP said that even if it was reset and working, still unsure this issue will reoccur.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #8 ·
Different tranny. Should be ok. I'm sending over good vibes.

Also, I forgot to mention, the loaner they have me is a Chrysler 200 and has 15k miles on it. Same 9 speed tranny. I know this is a loaner and people drive it differently but the transmission is horrible. To prove the point I asked my girlfriend to drive it to make sure it wasn't just me. Same thing. The car lunges forward on every 3-1 downshift harshly. It skips 2nd unless you are going extremely slow. In the 200 it shows you what gear you are in. I wish the Rene did as I would have been able to tell what gear it was stuck in. If my 15k vehicle drove anything like this 200, I would be at the dealer every day.

Sent from my SAMSUNG-SM-G925A using Tapatalk
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top