Jeep Renegade Forum banner
Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
175 Posts
Discussion Starter · #1 ·
I have the 1.4L Turbo / Manual Latitude Jeep Renegade with a bit over 9000 miles on it. Have not had any big problems until now. We just left on a big road trip on Sunday, except it's without our Renegade. I went out Sunday morning to move the Jeep closer to the garage to load up the luggage and it wouldn't start. Put on the battery charger and it started after 30 min charge, but amperage was low and percentage was only at 70% when we started charging. I made a spot decision to pack up the Toyota FJ Cruiser instead, and my brother in law who is watching the house checked it again on Monday morning. On Monday the battery was again down to I think 75% or so after being 100% the night before.

So the local dealer has towed it in and they are now looking at it. Will post back when I find out more. Anyone have any theories? :)

Well it sucks that we don't have the Renegade on our trip from Northern Idaho to Santa Cruz, CA - it would have been fun.
 

·
Registered
Joined
·
261 Posts
Had the same problem after two weeks I got my Reni. My Start n Stop was not working at all from day one, and after about 3-4 weeks the battery could not retain its charge for 1 day. Jump started it, took it to the dealer and complained about it. Turns out the battery that was installed when I got my Reni was way underpowered from what this specific car should have had. It was very small and the starting Amps of it were too low. The dealer replaced my battery with a proper one for this car (Gel type battery, specific for Start n Stop cars, with 640 starting Amps). Never had a problem since. Demand from your dealer to install a good and powerful battery. This car needs it more than any other car. It is a software on wheels. Battery is the Alfa and the Omega for this car (advertising my Greek language... :p )
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #3 ·
Thanks for the info - I just called Service and told them about the larger battery solving the problems. I don't have stop/start but I would prefer a bigger battery regardless. They are letting it sit today and will check amount of discharge tomorrow morning and decide the next steps.
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #4 ·
So I checked in with the service department yesterday and they said the battery is not discharging. So the problem isn't happening now that they have it. I suggested checking for software updates that are needed. Weird that it's not happening now.
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #5 ·
Just returned from my road trip and picked up the Renegade. They started it every day while I was gone and it did not have any problems. No software updates available - I guess we'll just keep driving and see if it happens again. If it does I will demand the larger battery.

After I picked it up the read brakes were making a clattering sound when brakes were applied. Called the service department and they told me about rust build up from the e-brake engaging the rear calipers and said they would just drive it and apply brakes several times to get the rust layer off. I drove back to the dealer and brakes were already quieting down by the time I got there. They took it for a drive with me and the brakes seemed fine. I guess this problem will probably not happen again if we're driving the Jeep every day.
 

·
Registered
Joined
·
21 Posts
My battery died twice over the past two weeks, it was after it would sit longer than two days without driving it. It's at the dealer now, but they didn't find any codes against it. They said the flashed (reset) the BCM and they offered to give it back to me. I told them to keep it for two days and THEN try starting it to see if it happens again. Anyone else see a fix or was the battery replacement or BCM reset the way to fix it?

Thx!

Duck
 

·
Registered
Joined
·
1 Posts
help pleaseeeeeee!!!

so im in mexico, all the way central mexico and my jeep renegade trail hawk 2015, died... so i jumped the jeep, the jeep started but it has a code and it says transmission maintenance... the transmission is stuck on parked, and i can't go ANYWHERE... the closest jeep is 500miles away, can't go.... any help for me!!!
 

·
Registered
Joined
·
4 Posts
I have this same problem after battery dead, check engine, check 4x4, check transmission. Shifter on parking stuck. Please help. Use elm327 reset errors?

Wysłane z mojego Redmi 4 przy użyciu Tapatalka
 

·
Registered
Joined
·
4 Posts
Solved:

After connecting a new battery - the computer has lost the Transmission Control Module. Module was not visible at all. The dealer reloaded the missing module and checked the updates of the remaining modules.

Greeting from Poland
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top