Jeep Renegade Forum banner
1 - 20 of 30 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter · #1 ·
Has anyone has issues with the black side trim/moulding coming off? I had a piece on the right rear door pop partially off. Turns out there are 2 broken clips and the trim adhesive eventually gave way. I have not had it repaired yet but just curious if this has been an issue?
 

·
Registered
2015 Trailhawk
Joined
·
404 Posts
Has anyone has issues with the black side trim/moulding coming off? I had a piece on the right rear door pop partially off. Turns out there are 2 broken clips and the trim adhesive eventually gave way. I have not had it repaired yet but just curious if this has been an issue?
I have not had that problem.
 

·
Registered
Joined
·
604 Posts
joejamiejeep, you seem to be the first with this particular problem. Congratulations?

I'd take it in and have them replace the clips and redo the adhesive. It could have been a bad install from the factory, or some freak impact that caused them to break.

Where on the vehicle is the trim coming off? Is it under one of the doors, where it says "NO STEP", by any chance? >:D
 

·
Registered
Joined
·
1,266 Posts
This is not a common concern that I've heard on my end, joejamiejeep. I'd recommend a trip to your dealership to take a look at this. If you would like assistance scheduling an appointment, please feel free to reach out.
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #8 ·
Thanks everyone. I already called the local dealer and it is a first for them. Of course they do not have the clips in stock. One good thing, it sounds as if mine is an "odd ball". Most appear to have the trim installed correctly. In fact on the rest of my vehicle, the trim appears to be on solid
 

·
Registered
Joined
·
1,613 Posts
Thanks everyone. I already called the local dealer and it is a first for them. Of course they do not have the clips in stock. One good thing, it sounds as if mine is an "odd ball". Most appear to have the trim installed correctly. In fact on the rest of my vehicle, the trim appears to be on solid
Which piece of trim was it?
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #14 ·
Jack

Yes, thanks a bunch for asking. The local dealer in Clearwater Florida ordered the clips and will let me know when they arrive. So far they have been very responsive, understanding that there have not been many Renegades to date with this problem. It is pretty obvious what occured; the moulding was not installed correctly at the factory (at least two broken clips), the tape was the only thing holding it in place and not much tape at that. The heat and rain took its tool over the past 8 weeks since delivery and off it came.

JoeJamie
 

·
Registered
Joined
·
1,266 Posts
Jack

Yes, thanks a bunch for asking. The local dealer in Clearwater Florida ordered the clips and will let me know when they arrive. So far they have been very responsive, understanding that there have not been many Renegades to date with this problem. It is pretty obvious what occured; the moulding was not installed correctly at the factory (at least two broken clips), the tape was the only thing holding it in place and not much tape at that. The heat and rain took its tool over the past 8 weeks since delivery and off it came.

JoeJamie
No problem! I'm happy to hear your dealership is taking good care of you. Please keep us posted on this once the new clips are installed!
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #16 ·
Jack

I am going to bring the Renegade into my local dealership Wednesday. The clips are on factory backorder but they claim they may have another clip on hand that will work. It is a real bummer driving around with a new vehicle with a side molding held on by tape. I will wait to see the outcome on Wednesday but do not have much confidence with the body shop manager's correspondence with me via phone

Thanks
JoeJamie
 

·
Registered
Joined
·
1,266 Posts
Jack

I am going to bring the Renegade into my local dealership Wednesday. The clips are on factory backorder but they claim they may have another clip on hand that will work. It is a real bummer driving around with a new vehicle with a side molding held on by tape. I will wait to see the outcome on Wednesday but do not have much confidence with the body shop manager's correspondence with me via phone

Thanks
JoeJamie
JoeJamie,

If this doesn't get worked out for you tomorrow, reach out to me through PM with your VIN, contact info, and dealership info, as well as the part number and order number for the clips (if your dealership provided you with this). I can see if it's possible to expedite things at all.

If a part is on backorder, unfortunately it may not be possible to expedite it, but there is a chance it could be done.

It happened to me twice (each on both sides) when they installed my hitch receiver.
Has this since been resolved for you, reyTHny?
 

·
Registered
Joined
·
85 Posts
JoeJamie,

If this doesn't get worked out for you tomorrow, reach out to me through PM with your VIN, contact info, and dealership info, as well as the part number and order number for the clips (if your dealership provided you with this). I can see if it's possible to expedite things at all.

If a part is on backorder, unfortunately it may not be possible to expedite it, but there is a chance it could be done.



Has this since been resolved for you, reyTHny?
Jack,

Yes, but it took them 2 months overall to install my hitch receiver right. Excuses from; first time they did it so mistake happens, need to order special tools, wrong parts ordered, wrong parts delivered, parts on back order, technician absent, etc.
I was already dealing directly with the service manager, parts manager, general manager, and the owner but still all these incompetency on there part is unbelievable and their dealership has a 5 star rating from chrysler.
 
1 - 20 of 30 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top