Jeep Renegade Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
Has anyone else had this issue? My TH Reny just hit 1k miles and it hasn’t been too cold to use my seat warmers. This past weekend was a bit chilly in my area so I turned on the Driver and Pass heated seats. The Drivers seems to be working okay but I noticed that after I turned the passenger seat about 5 minutes passed and a strong burnt rubber smell emerged. The seat light (Indicator) started to flash on and off then eventually turned off completely. I attempted to turn the seat warmer on again but that lights just flashed on and off and the smell just go stronger. I left it alone for the remainder on the day. I attempted to use the seat warmer a couple of days later and it seemed to work…. For 10 minutes, then again the lights flash on and off and the smell returns…. I’m going to take it in to the dealer but I was wondering if anyone has dealt with this?
 

·
Registered
Joined
·
113 Posts
Are you using seat covers? I noticed in the manual it warns against using blankets or cushions with the heated seats because of the possibility of overheating. Of course I read that after I installed my seat covers. So I was concerned about it. But I have turned on the heating a couple of times so far with no issues.
 

·
Registered
Joined
·
1,628 Posts
My guess is a defective seat heater. Let the dealer replace it. And it's possible that the seat cover & cushion need replacing too.

If they won't replace the seat cover & cushion, I would insist that the tech shows me the seat while it's apart to replace the heat pad so I can see for myself that the cushion & cover are not burnt. I wouldn't want a burnt smell in a new car.
 

·
Super Moderator
Joined
·
3,641 Posts
Stop using the seat heater and get it to the dealer. Failure of a seat heater can range from nearly nothing to all out car fire. With a burning smell it isn't worth pushing your luck.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #5 ·
I wasnt using any aftermark seat covers. I made an appointment with the dealer, we'll have to wait and see what they tell me. Thanks for the heads up on what to request! Good Looking!
 

·
Registered
Joined
·
113 Posts
I wasnt using any aftermark seat covers. I made an appointment with the dealer, we'll have to wait and see what they tell me. Thanks for the heads up on what to request! Good Looking!
Yes I agree it looks like a fault, and you shouldn't turn it on again without having it looked at. I hope it can be fixed easily. Keep us posted.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top