Jeep Renegade Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
2015 with only 2600 miles on it. I just bought it slightly used 4 days ago...haven't even finalized my financing on it yet and then this happens:

Driving along the highway and the ETC light (lightning bolt with parentheses) starts flashing and the check engine light comes on...then the car would not accelreate. I pushed the gas pedal to the floor and it was stuck at 54 mph. I pulled over called Chrysler roadside assistance and they wouldn't help me because I was on a "restricted" road (toll road). An officer came to help and Googled the problem and said to try turning the car off and then back on. I did and then was able to accelerate again. The ETC light went off but the check engine light stayed on. I was able to make it back home.

Anyone else having this problem? Or can share how the dealership fixed the problem. I really like the Renegade but am thinking of returning it to the dealership and shopping for another brand after all the similar problems I have read on the forum.
 

·
Registered
Joined
·
580 Posts
Everyone should have an OBD II reader. It would give you trouble codes. Without that tool it'a guessing game. It could be a CTS or IAT sensor. If either one is intermittently malfunctioning or defective the ECU can't determine the proper A/F mix and will push engine management into limp mode, which allows you to drive with reduced power only. Could be a variety of causes.
 

·
Registered
Joined
·
2 Posts
2015 with only 2600 miles on it. I just bought it slightly used 4 days ago...haven't even finalized my financing on it yet and then this happens:

Driving along the highway and the ETC light (lightning bolt with parentheses) starts flashing and the check engine light comes on...then the car would not accelreate. I pushed the gas pedal to the floor and it was stuck at 54 mph. I pulled over called Chrysler roadside assistance and they wouldn't help me because I was on a "restricted" road (toll road). An officer came to help and Googled the problem and said to try turning the car off and then back on. I did and then was able to accelerate again. The ETC light went off but the check engine light stayed on. I was able to make it back home.

Anyone else having this problem? Or can share how the dealership fixed the problem. I really like the Renegade but am thinking of returning it to the dealership and shopping for another brand after all the similar problems I have read on the forum.
I'm late, but i had the same issue. My gas pedal needed to be replaced and the wires going to the gas pedal were melted. 54K 2017 Jeep Renegade 2.4 non turbo AWD
 
1 - 5 of 5 Posts
Top