Jeep Renegade Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi - had a Renegade new in Oct and I'm really pleased with it overall. One niggle though, the DAB seems to have given up, it never connects to any stations now. It worked ok at first, then almost gave up for a while, then came back and has now gone again (for a couple of months, seems permanent). Anyone else had this ? I just get 'station unavailable' on all stations now. FM / AM works fine, so I'm guessing it might be that it hasn't got a working ISP perhaps or something similar, is that feasible ?


I've had a letter advising me to take it in soon for 'software upgrades' so maybe it'll be cured then, or maybe not.


Can anyone come up with a fix or does it need to go back to the dealer for this one ? Thanks :ReneBlueWave: <<<though mine's orange and RHD>>> :)
 

·
Registered
Joined
·
45 Posts
I have the exact same problem. I had the car in for its first service 2 weeks ago and mentioned this to the dealer. He said that they have had a few cars with this problem and they have traced it to a faulty aerial base.
My car is booked in this Wednesday to have the base renewed.
 

·
Registered
Joined
·
45 Posts
Up date on this.
Took car to dealer on Wednesday.
Apparently if the base is faulty it will also affect the Sat Nav. As mine was working OK they carried out 4 computer updates.
I have to say after 2 days the DAB is working great. No loss of transmission.
 

·
Registered
Joined
·
21 Posts
Glad I found this post!

After 6 months of faultless DAB reception, the reception on my Uconnect was having none of it today. :(

As mentioned, FM was fine DAB would play for 3 to 4 seconds and then loose the station.

Looks like a trip to the dealer is coming up...
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top