Jeep Renegade Forum banner
1 - 14 of 14 Posts

· Registered
Joined
·
99 Posts
Yes I agree get them to sort it. What I can't understand is why they did not use LED lamps which are available more penny pinching by Fiat and they would look much better with a whiter, brighter look:)
 

· Registered
Joined
·
20 Posts
Discussion Starter · #4 ·
Oddly, my DRL is not actually out. The dash clearly indicated that one was. I drove to work with in indicator on... Left work, started the car, no indicator! Walked aroynd, not noticiable lights out! Strange! I did hit my PANIC by accident this morning before leaving.
 

· Registered
Joined
·
12 Posts
Light out (or not)

Oddly, my DRL is not actually out. The dash clearly indicated that one was. I drove to work with in indicator on... Left work, started the car, no indicator! Walked aroynd, not noticiable lights out! Strange! I did hit my PANIC by accident this morning before leaving.
I have had a similar problem. Have has my Trailhawk for a little over a week and three separate times was warned that a reverse light was out. Had someone with me each time to check that the bulb was still working. I'm suspecting something electrical and plan on taking it in to have it checked. Could just be a computer glitch. Strangely it always seemed to give me the issue in the evenings and then fix itself by morning. Could be coincidence.
 

· Registered
Joined
·
1,633 Posts
Have the dealer remove the suspect bulb and carefully clean it and its socket. That might solve the problem if there is crud on the bulb.

Sure you could do it yourself, but having the dealer do it will make sure it is on record in case there is another underlying problem.
 

· Registered
Joined
·
216 Posts
my backup lights are doing the same, message that they are out. I have replaced alot of bulbs to LED but left my backup/reverse lights stock and I get this message. I will get lights-out message sometimes from LED lights due to low resistance and the can-bus system.
 

· Registered
Joined
·
4 Posts
Are you still having this issue? If not, how was it resolved?
Yesterday when I started up my Renegade my dash warnings started flashing through all my lights (brake lights, turn signals, daytime running lights, etc.) saying they were all out. This has happened randomly once or twice in the past 6 months. Checked all lights and they are functioning. Proceeded to drive home, shut car off and restarted and warning lights were gone.
Any thoughts?
 

· Registered
Joined
·
715 Posts
A software update should take care of it.
I was recently in for my hitch recall. Didn't tell them I've had this problem recently, but it always goes away after a couple miles of driving the 3 times it's happened. Anyways, they said they tried to run an update but it didn't go through. I'll go back soon, but any info on this new update?

Also have the horrible sticking/noise from closing my MySky, said they needed to order the lubricant ?. I've got a twin TH out there who's said dielectric grease works.. just not super sure I wanna try that..
 

· Registered
Joined
·
4 Posts
A software update should take care of it.
It never has for mine. I've had the issue every 6-8 months since I got the thing in 2015. I've had multiple software upgrades. Still on occasion I start the engine and get a warning that half of the lights on the vehicle are out. A quick check shows none of the lights are out. It usually requires me letting it sit over night if I want the system to clear and act normally, or I can just disconnect the negative battery terminal for about 5 minutes and everything is fine afterwards. I have no corrosion on my battery terminals as some have suggested, since I always use dielectric grease on the terminals to avoid it. It is never an issue when I take it to the the dealer, but they do a software update anyways and nothing changes. Something else that never changes, since I have owned the vehicle, October of 2015, my stupid lane assist sensor in my 2015 renegade turns itself off constantly! CONSTANTLY! If I drive more than 10 miles it will turn off at least twice. It turns itself off sometimes at startup. But it happens several times every time I drive the thing. No software update has ever helped that either. It's incredibly frustrating! The last time it was in the shop they updated the software and drove it and said it was fine. I get in the car and within 1 mile the stupid system shut itself off again. But I was the last customer and they locked the door behind me as I left so I didn't go back. I haven't been back since. Anybody have any ideas on that one?
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top