Jeep Renegade Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Please help. This is doing my head in. Couple of weeks ago I got the low tyre pressure warning. Off to garage pumped it up and drove away. And I’ve been stuck with the tyre pressure display in the d I d ever since. No controls work on the steering wheel except cruise control. Can’t adjust radio volume or use the arrow navigation.
I’ve tried deflating a tyre to get the warning etc as per other forums but no joy.
Was going to pull the fuse until I realised what a pain it is to get to the fuse box.
Seriously unhappy. Please help!
 

·
Super Moderator
Joined
·
3,055 Posts
and enjoy the forum!

X2 for above if that dose not work off to the dealer you must go!
 

·
Registered
Joined
·
410 Posts
As a retired Firefighter I suggest that you don't play with matches near a petrol Renegade :ROFLMAO::ROFLMAO::ROFLMAO:

Sorry, my wit will be the death of me. :cry:

Welcome to the forum and I hope you get the Dealer to fix it. Keep us all updated as it's the collective experience from us all that allow a quick fix on issues. (y)
 

·
Registered
Joined
·
2 Posts
Discussion Starter #6
Hi everyone and thanks for taking the time to reply.
I’m almost embarrassed to admit that it was as simple as disconnecting the battery. Once re-connected it was back to normal. So thanks all for the fix.
One good thing to come out of this is finding this forum and the warm welcome I’ve received.
 

·
Registered
Joined
·
1,128 Posts
Hi everyone and thanks for taking the time to reply.
I’m almost embarrassed to admit that it was as simple as disconnecting the battery. Once re-connected it was back to normal. So thanks all for the fix.
One good thing to come out of this is finding this forum and the warm welcome I’ve received.
Glad it worked. Disconnecting the battery has fixed a number of issues over the years. Like I said, the Renegades are playing with us to see if we are paying attention.
 
1 - 7 of 7 Posts
Top