Jeep Renegade Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Posted snippets of this in the Warranty thread as I was asking a question. Thought I'd post here since I'm hoping the dealership has figured out the problem and it might be helpful to someone else in the future.

I purchased my TH on 11/29. The day after Christmas (less than a week of ownership), I got into my car to discover significant electronic problems:
  • The radio was dead (no screen light up)
  • My odometer had switched from miles to km
  • My AC was reading in Celsius and if I tried to turn the temp down the AC would run hard and loud
  • I was getting a greeting in Spanish or Italian on the driver display*
  • neither blinker worked, and obstruction lights in both side-view mirrors were on.

Took it immediately to dealer who said none of the electronics were talking to each other... No communication between systems. The dealership has had my car 10 days so far testing each module to try to isolate the problem. I called this morning and was told it was the Body Control Module (BCM). They do not anticipate receiving the part until Wednesday. Assuming they get the part on time and fix it that day, I will have been without my car 12 days.

Fingers crossed this is a fluke and not a harbinger of things to come. In the week I had it, I fell in love with my Renegade and am very much looking forward to having it back.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
Thanks, Thorpeland. From some quick Googling I've learned this module controls communications to a host of systems. So, hoping it's just one wonky part.
 
  • Like
Reactions: OZ2001

·
Super Moderator
Joined
·
3,641 Posts
Any chance you looked at the build date on the door sill before you handed it back?

Early production vehicles had some issues with a crushed wiring harness that would eventually short and cause electronic weirdness, or if bad enough, kill the BCM.

When getting it back, I'd ask them if they electrical harness on the fire wall for damage, as if they replace the BCM with damaged wiring still in place, you can just kill the BCM again.

Also, check your lemon laws for your state. If you have to proactively start the clock ticking by sending a letter, do it now. As another possibility of weirdness is that in manufacturing or updating stuff, you now have mismatched software on various modules that is nearly impossible to get re-flashed to be the right versions to talk to each other properly and correctly again. Their have been a couple of folks who had this issue (one manufacturing mistake or PDI mistake, and one definitely caused by dealer servicing issues), and the result for both of them was a buy back, but it took a while to get to that point. You don't want to have any other barriers in your way.

Good luck, I hope it is just the first BCM issue, or a bum BCM, as that's much more straight forward.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #5 ·
I did not think to look at the build date, but will do so and report what I find here. I mentioned that I'd read about the crushed wiring harness issue on the forum. Not sure if they will check, but I will ask. Thanks for the other info about mismatched software.

Virginia Lemon Laws kick in if in an 18-month period they can't fix same issue in three attempts OR one occurrence for a serious safety issue OR 30 days of your car being out of service. Assuming the part comes in on Wednesday AND they get it installed, I'm already at 12 days out of service.

I took the car in earlier for a roof rail repair (came to this dealer from another with a gouge int he rail) and reported a rear back-up cam issue (strange lines running through the picture making it difficult to see image). The tech said it was because I had a parking RFID tag in the car. EXCEPT, I'd had the tag in the car all week and had no issue until that day. I'd argue that report was making them aware of an electrical issue and attempt number one. This BCM issue would make attempt two. Not sure Jeep will agree. But, we'll see.

I've been looking at the requirements of the Lemon Law which say I need to alert the manufacturer. I need to find out how I go about that or if taking it to the dealership for repair constitutes that notification.

I don't know what to hope for: That this is a one-off issue and all is fixed. Or, that problems occur fast and either repeat or quickly run up 30 days.

Sigh. Not to be a whiner. Just stinks when this is a new vehicle. They've had the Renegade longer than I have, at this point. LOL.
 

·
Registered
Joined
·
55 Posts
My display went blank today. Dash display works - radio does not. The dash says radio off, but radio is on and volume works, but I can't change nothing else (stuck on one station).

Had the same issue with my JKU a couple times. Disconnected battery and cleared it both times. Had a few computer flashes at one of my free oil changes and haven't seen the issue since.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top