Jeep Renegade Forum banner
21 - 31 of 31 Posts

·
Registered
2015 Renegade Latitude FWD w/ 52K miles.
Joined
·
22 Posts
I have an older Actron scan tool and did try that early on and I was also unable to connect to read codes, live data, etc. I did try the Erase Codes function just to see if there was a difference and I got the message "engine running, turn key on, engine off." I thought that was odd... I did not check the pin voltage, but I'm assuming it was the same as yours.

And I totally agree. the flashing BRAKE indicator means something to someone. Finding that person is likely going to be difficult though... Sucks having to wait another week before I even get ours into the dealer.
I'm still waiting for Dealer to get back with me about anything. In the meantime, I went to Mopar's Tech Authority which is the official website for purchasing service and electrical information. It's delivered on a USB, and they are out of stock!

I've been searching Youtube for days trying to get any leads, and finally last night I found this guy (I'm attaching link). He has I think 3 videos on this Jeep as he troubleshoots and fixes it. Longer videos and he's a little different to listen to, but as I watched I soon gained an appreciation for him and his videos! Not exactly the same issue we have, but in the same ball park. Almost have to watch his three videos on this Jeep project to get the full understanding of where he started and how he got to the end point of success. He's a good asset I believe!

Back to the future jeep 2016 struck by lighting! Part # 1 - YouTube
 

·
Registered
2015 Renegade Latitude FWD w/ 52K miles.
Joined
·
22 Posts
Good afternoon JeepCreep! I'll be curious to learn what you learn this coming week on your wife's Renegade when the dealer has the opportunity to scan it. Hopefully they have some answers. Are you taking it there a day early or anything just to insure it makes it to the dealer?
 

·
Registered
2016 Renegade Trailhawk
Joined
·
14 Posts
Discussion Starter · #23 ·
Hey TWH! I was planning on taking it over there yesterday but didn't get around to it. We'll be driving it over there tomorrow afternoon as it's currently working normally, but I'm also secretly hoping something goes wrong on the way there so that they can diagnose the issue as it's occurring. I've been going out every other day and starting it up with the cold weather we've had, and it's been completely fine the past week. :cautious:

Feels very wrong that I'm hoping my vehicle is going to fail while I'm driving it, but here we are... I'll definitely update you with what they tell me!
 
  • Like
Reactions: 18Rene

·
Registered
2016 Renegade Trailhawk
Joined
·
14 Posts
Discussion Starter · #24 ·
Made it to the dealer, no problems at all :rolleyes:

At check in they pulled a list of codes about two pages long. Lots of red on the screen, not sure if they're all different codes or if there are so many because of the troubleshooting I did... Either way, hoping that there will be plenty of clues to point the tech in the right direction. I want a definite 'smoking gun' repair here... We'll see! I'll keep you all updated with what they say tomorrow!
 

·
Registered
2015 Renegade Latitude FWD w/ 52K miles.
Joined
·
22 Posts
Made it to the dealer, no problems at all :rolleyes:

At check in they pulled a list of codes about two pages long. Lots of red on the screen, not sure if they're all different codes or if there are so many because of the troubleshooting I did... Either way, hoping that there will be plenty of clues to point the tech in the right direction. I want a definite 'smoking gun' repair here... We'll see! I'll keep you all updated with what they say tomorrow!
Any luck?
 

·
Registered
2015 Renegade Latitude FWD w/ 52K miles.
Joined
·
22 Posts
Hey TWH! I was planning on taking it over there yesterday but didn't get around to it. We'll be driving it over there tomorrow afternoon as it's currently working normally, but I'm also secretly hoping something goes wrong on the way there so that they can diagnose the issue as it's occurring. I've been going out every other day and starting it up with the cold weather we've had, and it's been completely fine the past week. :cautious:

Feels very wrong that I'm hoping my vehicle is going to fail while I'm driving it, but here we are... I'll definitely update you with what they tell me!
Good morning! Just curious how things went with the Renegade at the dealership?
 

·
Registered
2016 Renegade Trailhawk
Joined
·
14 Posts
Discussion Starter · #27 ·
Wow, didn't mean to leave you hanging, TWH! I replied back in January but must have hit Preview instead of Post...

Anyway, they told me that the issue was a little Bluetooth tracker we had on the key fob. They said it was causing interference and confusing the Renegade causing it to lock up. :ROFLMAO: I didn't buy that for a minute. The battery on that tracker died years ago, and we had no issues when it was still working, but the service advisor assured me the tech "verified there was a signal coming from it." It just sounded like a load of BS to me. The problem wasn't occurring when the Renegade was at the dealership, though, so it would be hard to diagnose... Nonetheless, the tracker was removed and we didn't have any issues after that.

Fast forward to a couple weeks ago, we had the same issue start happening again. First the vehicle became unresponsive in the driveway like before. Left it there for a day and then it started working again. Then a couple days later we got the power steering, airbag and TPMS indicator lights again with a loss of power steering while driving. It would come and go sporadically. We were able to get back home, I made another appointment with the dealership (~10 day wait time) and it sat dead in the driveway for days. I disconnected the battery for ~24 hours, reconnected it and still nothing. Let it sit for another couple days and tried it and it started working. So weird... While it was working I drove it to the dealership to make sure we wouldn't need to tow it there.

Luckily it decided to fail in the lot and they had to push it in! 👏 They said the issue was no signal coming from the BCM. They're replacing it now and I'll be picking it up tomorrow, so we'll see how it goes from here. For $1150, I'm hoping that the BCM really is the problem...

How is it going with yours? Were you able to identify the issue?
 

·
Registered
2015 Renegade Latitude FWD w/ 52K miles.
Joined
·
22 Posts
Wow, didn't mean to leave you hanging, TWH! I replied back in January but must have hit Preview instead of Post...

Anyway, they told me that the issue was a little Bluetooth tracker we had on the key fob. They said it was causing interference and confusing the Renegade causing it to lock up. :ROFLMAO: I didn't buy that for a minute. The battery on that tracker died years ago, and we had no issues when it was still working, but the service advisor assured me the tech "verified there was a signal coming from it." It just sounded like a load of BS to me. The problem wasn't occurring when the Renegade was at the dealership, though, so it would be hard to diagnose... Nonetheless, the tracker was removed and we didn't have any issues after that.

Fast forward to a couple weeks ago, we had the same issue start happening again. First the vehicle became unresponsive in the driveway like before. Left it there for a day and then it started working again. Then a couple days later we got the power steering, airbag and TPMS indicator lights again with a loss of power steering while driving. It would come and go sporadically. We were able to get back home, I made another appointment with the dealership (~10 day wait time) and it sat dead in the driveway for days. I disconnected the battery for ~24 hours, reconnected it and still nothing. Let it sit for another couple days and tried it and it started working. So weird... While it was working I drove it to the dealership to make sure we wouldn't need to tow it there.

Luckily it decided to fail in the lot and they had to push it in! 👏 They said the issue was no signal coming from the BCM. They're replacing it now and I'll be picking it up tomorrow, so we'll see how it goes from here. For $1150, I'm hoping that the BCM really is the problem...

How is it going with yours? Were you able to identify the issue?
LOL! I was wondering.

I have not worked on the vehicle since our last conversation because I was very involved with a work project that took all of my attention. That project finished last Thursday! I did receive the quarter panel finally but I still need to install that too. I’m hoping to start focusing on this Renegade again by next week. I’llkeep you updated.

thanks!
 

·
Registered
2016 Renegade Trailhawk
Joined
·
14 Posts
Discussion Starter · #29 ·
Well, less than 24 hours after picking it up from the dealer, it went right back. Wife came out of work yesterday and it was dead again. And now they can’t replicate the issue and all connection tests are passing. They opened a STAR case with the engineers to try and come up with something.
 

·
Registered
2015 Renegade Latitude FWD w/ 52K miles.
Joined
·
22 Posts
Well, less than 24 hours after picking it up from the dealer, it went right back. Wife came out of work yesterday and it was dead again. And now they can’t replicate the issue and all connection tests are passing. They opened a STAR case with the engineers to try and come up with something.
Yuck! I might go spend some time on mine today, see if I can find something I missed from a few months back. I still believe our problem is with the LIN bus communication where something isn’t connected. LIN bus uses one wire to communicate and it daisy chains through all of the devices. Yours is intermittent, mine is not, and it could be at any of the many devices. (In my opinion)
 

·
Registered
2015 Renegade Latitude FWD w/ 52K miles.
Joined
·
22 Posts
I spent some time earlier today checking the wiring and such and then reconnected the batter only to have the same comatose problem as before. I think next week I'm going to ask around to some of the other local Jeep dealers to see if I can get someone to come to my shop to do some diagnosing with their scan tools. If not then I'll be looking into getting setup with the Mopar Technical Service Portal and purchasing what's needed to do this myself using everything that the Dealers would be using with all the same capabilities. I'm now thinking before I spend more time installing the quarter panel and preparing for paint I need to actually get this thing running again so I can move it around.

For the TSP here's the Home page link, you would register as Aftermarket and not Dealer.
Mopar TSP
 
21 - 31 of 31 Posts
Top