Jeep Renegade Forum banner
21 - 26 of 26 Posts

Registered
Joined
4 Posts
Hello!

I have a 2016 Jeep Renegade 1.6 Multijet Longitude Diesel. I bought the car second hand from Arnold Clark as the second owner and it was a previous disability car.

So far my external temperature gauge has gone, my gear box stopped working and my sound system wiring needed redone causing issues with my rear parking sensors! Now my engine light is on along with the stop start and Autocare are telling me to take it to Arnold Clark for diagnostics. They cant take it in until mid December and I am reading a lot about battery issues causing this fault. Could anyone help and tell me how much Jeep batteries are? If inexpensive I can take it to my local mechanics who have had to fix all the other issues for me. Thanks in advance for any help or advice. I understand without the diagnostics it is difficult to comment.


This car is a money pit 馃槴馃槴
 

Registered
Joined
4 Posts
That all sounds very promising, you鈥檙e getting somewhere!
My main 2 codes were about the engine- engine position and camshaft position or timing. Think it was p0008 and p0011. If the independent mechanic doesn鈥檛 get back to me then I鈥檒l be waiting to next Wednesday to drop it to the dealer!
I have the same car year and engine . I bought a new battery for 拢120 and O2sensor for 拢95. Had. Them fitted and the codes all cleared and for six weeks now it is running great
 

Registered
Jeep Renegade Longitude 2016
Joined
11 Posts
Discussion Starter · #23 ·
So, interesting twist this morning. Mechanic drove the car to the other garage and they couldn鈥檛 recreate the codes. No lights on the dash. Check the sensors and they seemed fine.
Drove the car back to his garage and ran it again. Still no codes and car driving well. Ive to go pick the car up free of charge, not even a charge for time.
Eerily similar to when the gear box chucked it. Local garage got codes then they could recreate them at AC and the car drove fine again. So odd.
 

Registered
Joined
499 Posts
So, interesting twist this morning. Mechanic drove the car to the other garage and they couldn鈥檛 recreate the codes. No lights on the dash. Check the sensors and they seemed fine.
Drove the car back to his garage and ran it again. Still no codes and car driving well. Ive to go pick the car up free of charge, not even a charge for time.
Eerily similar to when the gear box chucked it. Local garage got codes then they could recreate them at AC and the car drove fine again. So odd.
My O2 codes would come and go. Sometimes it would stay clear for weeks, then pop back up. Trust me, it's still going to need those sensors.
 

Registered
Joined
10 Posts
Thank you for getting back to me! It is the original battery as far a Im aware. I dont know how to do a load test. Im not great with cars past basic maintenance like lights and fluids. Im in the UK so not sure prices are the same here but I really appreciate the response!
We have 2 renegades, and in both the original batteries only lasted 3 years. We had problems with all dash lights, door locks, everything electrical inside the vehicles. We purchased new batteries (mine $74 ... I went cheap... hubby鈥檚 $200, top of the line). Had to drive them about 75 miles after the replacement before everything got back to normal. Hope this helps.
 
21 - 26 of 26 Posts
Top