Jeep Renegade Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
New here so bear with me....had my 2016 Trailhawk for about 10 days now and today it randomly changed all my settings! Got in, started it and everything was metric, parking brake was set to auto on, door locks, etc. were different settings. Anyone else have this happen? In previous car experience it was always a sign of a dying battery....but my baby is brand new!! Insight? Thanks!
 

·
Registered
Joined
·
1,628 Posts
The first thing I would do is to check to see if the battery terminals are tight. There were a couple reports on here of loose terminals causing similar issues.
 
  • Like
Reactions: TXboymom

·
Registered
Joined
·
210 Posts
Most of these issues are, indeed software bugs. I've been a "tester" (reluctantly though cooperatively) now two or three times with software bugs in my 2015 latitude that did the same thing as the OP described. Actually went 18 days without the car while they ordered in a new head-end Uconnect, only to find it wasn't the problem. The latest March update for the larger-screen (6.5) units worked for me, fixing the bugs listed below with only the side effect of the console lights turning red above me, then green when touched, then off.

The software engineer who came to my dealership has taken both my information, and screenshots I sent him from this forum to those who write the software to see if they can fix the console lights. (911 and Uconnect.) In my case, the update which I think was dated March 3rd fixed my parking brake randomness, the tire pressure readout, the lights not staying on after key-off, it added a longer off time for them at 60 seconds instead of 30, it updated the voice in my phone prompts, and seems very smooth. The ONLY side effect has been the emergency console lights and funtion.

As soon as the tech/engineer responds to me I'll post what I know. He was great to work-with, and seems genuinely concerned at the issues we're all encountering. I pointed this forum out to him, and he's worked closely with my local dealership. Very impressed.

Bottom line: MOST annoying issues fixed for 6.5 eligible vehicles with the March 2016 update, but it introduced the overhead console issue. Known issue now. I'd recommend somehow when we all post here we ID the year, model, Which Uconnect, and software which was most recently updated and we'll have an easy way to track issues and symptoms. Agree? Disagree? We have a good pipeline going on bugs now, maybe we can try to make this easier for everyone.

Thoughts?
 

·
Registered
Joined
·
302 Posts
I second bwbike - check the battery connection. Also, I1430 Radio makes a good point. When you report a fault, the more info you provide the better we'll be able to respond. For example, I have the UConnect 5.0 so my issues may not relate to problems someone is having with the 6.5. The Renegade is built in a lot of different configurations and what applies to one will not necessarily apply to all variants.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
y'all, I am overwhelmed with all your responses! Love it! I am learning how to navigate this site so hope those I need to thank can see this! I have a Uconnect 6.5 on my 2016 trailhawk. Will definitely check all of the above. Will also discuss the updates with the dealer when I go back next week to pick up my registration papers, etc. Love this site...thank you again! Hope to post a picture of my girl soon! She's granite metallic and I love it!
 

·
Registered
Joined
·
60 Posts
New here so bear with me....had my 2016 Trailhawk for about 10 days now and today it randomly changed all my settings! Got in, started it and everything was metric!

It's a sinister plot by the new world order to force the US into getting in line with the rest with the metric system
 

·
Premium Member
Joined
·
3,154 Posts
We got some of the metric system in the UK. Petrol and diesel is sold by the litre, not gallons, yet distance from place to place is measured in miles. Yet in the pub a beer is sold in pint or half pint and not litres or half litres. In the supermarket produce is marked in per kilo.
 

·
Registered
Joined
·
2 Posts
Any progress on getting the console lights fixed?
I am at the same point had the wandering settings on the radio and dash last update in june seemed to fix them but mine also seemed related to cold weather,So we had to wait for cold (20deg) temps again to make sure.That seems to be fixed but I too still Have the Red LED's on 911 and jeep assist.
In my case I had these before the update.They seem to be related to a quick restart cycle where I would stop to get gas and then restart the Jeep and the red lights come on.
Dealership has been in contact with the field engineer and under his direction changed the head unit twice, the antenna, and 2 wiring harnesses between the two.
Result is lights came on a mile from the dealership when I restarted after getting gas.
Am currently waiting on the dealer loaner schedule,the field tech schedule,and my work schedule to line up so they can try again.


Don't know if this is trim level specific but it seems to be
mine is a 2105 latitude with the manual trans and the nav system.
 

·
Registered
Joined
·
1,189 Posts
Any progress on getting the console lights fixed?
I am at the same point had the wandering settings on the radio and dash last update in june seemed to fix them but mine also seemed related to cold weather,So we had to wait for cold (20deg) temps again to make sure.That seems to be fixed but I too still Have the Red LED's on 911 and jeep assist.
In my case I had these before the update.They seem to be related to a quick restart cycle where I would stop to get gas and then restart the Jeep and the red lights come on.
Dealership has been in contact with the field engineer and under his direction changed the head unit twice, the antenna, and 2 wiring harnesses between the two.
Result is lights came on a mile from the dealership when I restarted after getting gas.
Am currently waiting on the dealer loaner schedule,the field tech schedule,and my work schedule to line up so they can try again.


Don't know if this is trim level specific but it seems to be
mine is a 2105 latitude with the manual trans and the nav system.
my 911 and assist also stay red until i push one of them
then they both go green and work without issue
have u tried pushing them to test ?
and are u paid into uconnect ?
maybe thats why it does not work for u if u push them ? not sure but just a thought
 

·
Registered
Joined
·
2 Posts
I was paid in but should be expired now did not renew till they get the system to function.

Mine will be red till I push one then go green for a few seconds then go out.But they do not work after that. Nothing happens at all if I push either button again.

I believe this is intentional at the moment basically they disconnected the system so I could get the the lights to at least go out. Have had several other annoying pop up codes for the e-brake and such that have been diagnosed as a bad BCM but it is on back order.The hope is that the BCM has been the culprit all along but no for sure answer just wait till it comes in and try replacing it and see if the rest of the system in functional then.

Mainly annoying, If I bought the car used I would not care if the system worked or not I will probably never use it, but on a brand new car it SHOULD work.

It is a shame because otherwise the Jeep has been great, drives great, rides nice, goes anywhere I ask it to go, and gets good gas mileage to boot, but when someone asks me about it I can't say I love it because I have had what should be a minor issue drag out for over a year now.

And as other in this thread have said I am getting great response and care from my dealer, They ARE trying everything they know to try and everything they are being told to try.Just too much new stuff in them that they have never seen before.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top