Jeep Renegade Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter · #1 ·
My Trailhawk came with a bad O2 sensor from the factory and they have to replace it before they can sell it to me. It was drivable but was causing the check engine like to come on.

Is this a common occurrence for new models? Has anyone else had any issues the dealer had to fix before purchase? Does this not bode well for my Renegade or is it just something that happens randomly?
 

·
Registered
Joined
·
62 Posts
teddy, having to replace parts at a dealer is part of the pre delivery inspection (PDI) process. This is the reason for PDIs. Many manufacturers have to replace parts during PDI. You shouldn't worry much. I have seen a whole truck load of vehicles have to have parts replaced due to a post production part change. It happens more than customers know. The trouble sometimes is getting dealers to actually perform the PDI correctly and not just peel the wrapping off.

My advice, thank the dealer for being honest and performing the PDI correctly. Thanking them will hopefully put you on their good side so if anything else comes up they will fix it without argument. Hope this helps.

Don't forget to enjoy your new Renegade! :)
 

·
Registered
Joined
·
105 Posts
My Trailhawk came with a bad O2 sensor from the factory and they have to replace it before they can sell it to me. It was drivable but was causing the check engine like to come on.

Is this a common occurrence for new models? Has anyone else had any issues the dealer had to fix before purchase? Does this not bode well for my Renegade or is it just something that happens randomly?
Make sure they handle that. It's very simple and somewhat common that a sensor sometimes needs replacement during delivery. Post pics once you get it.
 

·
Super Moderator
Joined
·
3,641 Posts
It could be abundant sensor, or improper install on a grounding strap or connector. If they are getting a part it's one of the first too. Bad ground connections can be hard to diagnose.
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #7 ·
Hi teddyfirehouse,

Have they replaced the sensor for you yet? Please feel free to PM me with your VIN, contact info, and dealership info so I can look into this further.
Hey yep it's all fixed as of today, I'm gonna go pick it up tonight. I guess the real issue was that a dealership from Delaware gave them the faulty Jeep without telling my dealership there was an issue with it!
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top