Jeep Renegade Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 · (Edited)
Well this is how my 'Gade started......June 3rd took delivery of a '16 Sport



Since then I have added a direct fit Android based 7" touchscreen radio:




18' Latitude? wheels, smoked the side markers and 20% tint:



Custom retrofit headlights and added fog lights with 5k HID in both. Plastidipped grill rings, fog light bezels and front emblem. Also LED bulbs everywhere, including interior:


\


Finally today, got to smoke the taillights, third brake light and lower reflectors. The tinting of the exterior lights was all done with Lamin-x film



Very happy with the outcome of everything! (Gonna plastidip rear emblems soon, been busy)
 

·
Registered
Joined
·
753 Posts
Looks awesome!

I'd really like info about that radio as well! :)

Also, seeing the front bumper all naked and un-hidden like that. I wonder how similar it is to the rear-bumper that gets replaced when you add the factory hitch-kit (from RenegadeReady.com). I'd love to add another hitch-capable bumper in the front so I could use a plate-mounted winch - which is the type of setup I had on my old '98 XJ.

Excellent work! :)
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #7 ·
Ok i got the radio from eBay. No name brand from china. It says it is plug and play for a dodge ram and a renegade but the seller messaged me and said a few things wont work with the renegade. I didnt care because I cant stand the 3.0 radio and Im used to having to "MacGuyver" things. Without the correct interface like a maestro or connect2, a few things in the car stopped working. Everything was plug and play, but the radio had no switch power. So I found a 12v that came on with the ignition. Radio works fine and sounds amazing! It came with a module that I guess was supposed to retain the steering wheel controls, well that didnt work. Cruise control works but i cant change anything on the instrument cluster. Also the turn signal indicator and sound dont work inside but they flash like normal outside. No high beam indicator inside but works outside. The lights dont flash when I hit lock and unlock the doors but the horn honks. It sounds like alot but i can deal with it. it seems as if even on the base model, the radio is part of the "brain" for the whole car. One thing that i am happy doesnt work, is the light out error. Since there are led bulbs everywhere as well as HIDs, I definitely would have a bulb out error. Although i have the correct harness for the headlights not to give the error, I didnt connect the load resistors that came with it because I wont get the error lol. Im waiting for some feedback on one of the modules.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top