Jeep Renegade Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
153 Posts
Discussion Starter · #1 ·
Well, it took a couple of weeks, but my new Jeep has just gone through the 1,000 mile barrier.

Delivered on a Tuesday, filled the (strangely small) tank, and did a 200-mile journey to Leeds on the Thursday, 100 miles to Milton Keynes on Friday, and 250 miles to High Wycombe on the weekend.

These journeys were pretty much all Motorway, so I kept the speed and revs down, and got all those journeys out of the first Tank. Happy with that!

First impressions - Wind noise less than I thought, comfortable for the longer journey (love the heated steering wheel), Satnav seems good, and glass roof provides so much light into the cabin! UConnect works well, and has self-downloaded some updates already

Niggles?

  • No front parking sensors (even though it has front-collision avoidance)
    The heated seats aren't perhaps as warm as my last car
    People can't seem to open the rear doors until I unlock the drivers door. Heating fan seems noisy from cold

But overwhelmingly, I love the car :D
 

Attachments

·
Registered
Joined
·
11 Posts
I've just done a week in mine and love it so far!
According to the trip I'm getting 35 miles per gallon since I filled up. I do just under 30 miles per day 5 days a week, and went to Bury from Wigan and back at the weekend as well. I've still got half a tank left. I was surprised that to fill up from empty it cost me £42 - I was sure it would cost most than that!
 

·
Registered
Joined
·
63 Posts
I put £42 in mine when it was on 2 bars, Avg says 30.8 mpg on trip A (it has been reset from new).
fuel cost is 110.9 per litre at esso.
jeep holds 48 ltr (10.55 gallon)

16 reg longitude 1.4 manual
 

·
Registered
Joined
·
157 Posts
1100 MILES. Nothing to complain about. Returned to Jeep dealers for an update because the flippin alarm went off and wouldnt switch off. Now fixed. I have disabled the PASSIVE ENTRY, just a gimmik really. I have also disabled the stop-start. Still cant figure out why the radio comes on on engine start up even though it was switched off before turning off engine. I have it set for OFF on uconnect. Currently running at 44MPG. Changed the DRLs to LEDs. Also built my own adjustable cargo shelf for less than £15.Squealy brakes disappeared after 300miles.
 

·
Registered
Joined
·
182 Posts
us yanks feel left out....
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top