Jeep Renegade Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
help me out here, ok have borrowed the weans iPhone ,registered with uconnect,downloaded the app, connected phone and car via Bluetooth, started the app, it detects the car then error try again later, any ideas what I haven't done?, speedy answers please ,costing me a body fortune in FIFA points every time I borrow the phone
 

·
Registered
Joined
·
74 Posts
I'd love to know how many people have got their iPhone to connect. I'd love to move to TomTom Live services by upgrading to 15.21.37, but I only want to do it if I know that my FCW+ won't start failing all the time and that I can definitely get TT Live to work for the speed camera's. Cause the settings aren't remembered on 15.21.37...

What a mess!

I was thinking of upgrading myself before I take it to the dealer for it's 6 month check up... but I'm not so sure now. Think I might put it in the dealers hands. Why is it this hard to get something that works?!
 

·
Registered
Joined
·
1,612 Posts
I'd love to know how many people have got their iPhone to connect. I'd love to move to TomTom Live services by upgrading to 15.21.37, but I only want to do it if I know that my FCW+ won't start failing all the time and that I can definitely get TT Live to work for the speed camera's. Cause the settings aren't remembered on 15.21.37...

What a mess!

I was thinking of upgrading myself before I take it to the dealer for it's 6 month check up... but I'm not so sure now. Think I might put it in the dealers hands. Why is it this hard to get something that works?!
What does the speed camera warning sound like?
 

·
Registered
Joined
·
74 Posts
You get a couple of bongs about half a mile away from the speed camera, and then a couple of bongs again when you're pretty much on top of it.

15.04.31 you just get the bongs, no visual warning (took me a LONG time to figure out what the bongs where!)

15.21.37 You get an icon on the Nav Screen with the speed limit. You always get the icon, but only get the bongs if you first turn the speed camera warnings off (even if they're on) and turn them on again, before EVERY trip.

I'm wondering whether to upgrade my UConnect to 15.21.37 now that the iOS UConnect Live app is working for some people. As you're supposed to get that information through TomTom Live services... But it still seems a bit hit and miss as to whether people can get it working...

I hear the FCW+ can fail if your windscreen has rain/dirt over the camera.
 

·
Registered
Joined
·
1,612 Posts
You get a couple of bongs about half a mile away from the speed camera, and then a couple of bongs again when you're pretty much on top of it.

15.04.31 you just get the bongs, no visual warning (took me a LONG time to figure out what the bongs where!)

15.21.37 You get an icon on the Nav Screen with the speed limit. You always get the icon, but only get the bongs if you first turn the speed camera warnings off (even if they're on) and turn them on again, before EVERY trip.

I'm wondering whether to upgrade my UConnect to 15.21.37 now that the iOS UConnect Live app is working for some people. As you're supposed to get that information through TomTom Live services... But it still seems a bit hit and miss as to whether people can get it working...

I hear the FCW+ can fail if your windscreen has rain/dirt over the camera.
That will be the double bongs I have been hearing occasionally.
There are very few cameras here but they may have been positions used by mobile units.
Mine seems to work on 15.21.37 then.
 

·
Registered
Joined
·
28 Posts
All

You need to read the App Store Reviews, the UConnect App doesn't work correctly with Jeep Renegade. I have iPhone 6s, IOS 9.1 and I always get the error. I have chosen a new dealer after SG Petch of York were so rubbish, and they are rolling it back from 15.21.37 to 15.04.21 to try and resolve the FCW+ randomly disabling itself
 

·
Registered
Joined
·
74 Posts
I've just upgraded from 15.04.21 to 15.21.37, after the FCW+ started failing randomly again (sorry NoNav!)

I was also getting the error message on the iOS UConnect Live app, that most seem to be getting, but there are people on here that do have it working.

So I reached out to Jeep on Twitter, they told me to call them. So I did, auto message kept telling me not to hang up, but they hung up after 11 minutes. Moaned on Twitter, and got a call back. Who logged my issues. Got another callback from an Italian guy, who's English wasn't great.

Basically I'd forgotten to create a master record against my username when I created it. WTF - How the **** is that my fault! There's one button to press - login!

Anyway... I've got to wait now for an email, of terms and conditions... and then I'll be able to log in... apparently...

Not holding my breath.

It's sucks it's this fecking difficult to do. It should be s simple job getting access.
 

·
Registered
Joined
·
367 Posts
Pretty sure mine is the 15.21.37 and so far works perfectly.
Tomato. HD is perfect with bang up to date traffic and symbols, speed camera alerts seem correct, although there is an area near me where they just seem to go off at random.
Deezer, Reuters, TuneIn all work spot on - haven't tried Twitter.
My:car and Eco:drive also seem good but early days yet.
 

·
Registered
Joined
·
74 Posts
So, Jeep's official response.

If you're renegade was built before 5th July, it will NOT support UConnect Live - doesn't have the right chip set.

I'm gob smacked. We've been promised this since we bought the Renegade, it's in ALL the marketing material...

VERY ANGRY RIGHT NOW!!!!
 

·
Registered
Joined
·
76 Posts
Brilliant, nice to see that yet again the customer gets screwed over.

Officially as well, the UConnect will not support iPhone 6 or iPhone 6s. It will only support the iPhone 5s.
I have an iPhone 6 & have had no problems with the UConnect or live services working the phone.

I drove to Manchester in the first week I had the car & the live traffic showed a problem & suggested an alternative route to avoid a 25 min delay.

The software version is 15.31.4.
 

·
Registered
Joined
·
28 Posts
Hi Richard

Looks like you have a later release of UConnect on your system, I have checked on my VRN and the latest available is 15.21.37. You may be one of the lucky people who's car was built after July 2015 and the UConnect Live may actually work based on WanderinClumps email.
 

·
Registered
Joined
·
1,612 Posts
Hi Richard

Looks like you have a later release of UConnect on your system, I have checked on my VRN and the latest available is 15.21.37. You may be one of the lucky people who's car was built after July 2015 and the UConnect Live may actually work based on WanderinClumps email.
Mine was not ordered until august. Delivered at the end of October. It has version 15.21.37.
 

·
Registered
Joined
·
153 Posts
Mine's just been delivered to the dealer - hope these wrinkles have been ironed out!

I've got an iPhone 5S now, but am about to change to an iPhone 6 (or 6S) - would be nice to know it'll work properly...
 
1 - 19 of 19 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top