Jeep Renegade Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Well had my Jeep in for service for the oil consumption recall. Had motor replaced, n after a week of driving I started to get service engine, service transmission message on display. Then would go out. I drive everyday on the highway. Last trip I made my Jeep started to jerk and a lot of lights came on the display. Like service engine, service transmission and oil temperature to high and it went into limp mode, had to pull over on the highway cause I lost throttle. The codes come and go. But mostly pop up on long trips on the highway and also I notice the new motor consumes more oil then my old motor. Has anyone had this issue cause it’s getting me tired don’t wanna trade it in cause it’s almost paid off
 

·
Super Moderator
Joined
·
3,500 Posts
What codes? I mean the most likely thing with an engine R&R is leaving a hose detached or yanking/squishing something electrical that doesn't like that.

If it isn't throwing up OBDII codes, but rather a christmas tree of warning billboards on the DID, then odds move towards electrical/wiring. Most of those are for more complex can-bus stuff and you can get a lot of weird combos just because the can-bus has bad ground or gets flooded with bad data from one source.
 

·
Registered
2017 renegade trailhawk 9 spd auto glacier metallic, preferred package 27E
Joined
·
532 Posts
Well had my Jeep in for service for the oil consumption recall. Had motor replaced, n after a week of driving I started to get service engine, service transmission message on display. Then would go out. I drive everyday on the highway. Last trip I made my Jeep started to jerk and a lot of lights came on the display. Like service engine, service transmission and oil temperature to high and it went into limp mode, had to pull over on the highway cause I lost throttle. The codes come and go. But mostly pop up on long trips on the highway and also I notice the new motor consumes more oil then my old motor. Has anyone had this issue cause it’s getting me tired don’t wanna trade it in cause it’s almost paid off
must be some kind of warranty on the replaced motor--- bring it in
 

·
Registered
Joined
·
1,195 Posts
Well had my Jeep in for service for the oil consumption recall. Had motor replaced, n after a week of driving I started to get service engine, service transmission message on display. Then would go out. I drive everyday on the highway. Last trip I made my Jeep started to jerk and a lot of lights came on the display. Like service engine, service transmission and oil temperature to high and it went into limp mode, had to pull over on the highway cause I lost throttle. The codes come and go. But mostly pop up on long trips on the highway and also I notice the new motor consumes more oil then my old motor. Has anyone had this issue cause it’s getting me tired don’t wanna trade it in cause it’s almost paid off
Hi Rene15,
Sorry to hear of the trouble you’re experiencing. If you decide to address this concern with your certified Jeep dealer, please feel free to send us a private message. We would be happy to provide you with an additional layer of assistance for that process.

Rob
Jeep Cares
 
1 - 5 of 5 Posts
Top