Jeep Renegade Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hope someone could help me with a problem on a hire car here in Italy.

I have a Jeep Renegade Limited 2016 model however all the language settings have been set to French. Since this is an Italian registered vehicle it suggests that it should also be possible to change the language to English. My question is how ?

I have been through all the menu options (including the sub menus) on the central panel in the dashboard but cannot find anything to do with language settings.

I have also tried pressing and holding down the buttons on the steering wheel.

Can anyone advise how to change the language please ?

Thanks

Robert
 

·
Registered
Joined
·
29 Posts
Hope someone could help me with a problem on a hire car here in Italy.

I have a Jeep Renegade Limited 2016 model however all the language settings have been set to French. Since this is an Italian registered vehicle it suggests that it should also be possible to change the language to English. My question is how ?

I have been through all the menu options (including the sub menus) on the central panel in the dashboard but cannot find anything to do with language settings.

I have also tried pressing and holding down the buttons on the steering wheel.

Can anyone advise how to change the language please ?

Thanks

Robert
On the information center in the instrument cluster go to "Display" and then to the subsection "Language"
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks for your advice. Problem is I don't seem to be able to get into the information centre.

When I turn on the ignition I see a picture of the car showing the parking and side distance sensors.

I have tried pressing the up,down,left right and Ok buttons on the steering wheel in various combinations but cannot seem to get into the main menu.

What a I doing wrong ?

Robert
 

·
Registered
Joined
·
29 Posts
Thanks for your advice. Problem is I don't seem to be able to get into the information centre.

When I turn on the ignition I see a picture of the car showing the parking and side distance sensors.

I have tried pressing the up,down,left right and Ok buttons on the steering wheel in various combinations but cannot seem to get into the main menu.

What a I doing wrong ?

Robert
Appears to be broken then. I should go to another screen after start.
 

·
Registered
Joined
·
269 Posts
The instruments display (behind the steering wheel) will show Park Sense image when parked, unless you disable it. To remove the image of the car and its surrounding distance info in order to see the instrument settings, press the park sense button (ie turning it off). The park sense button is under the radio unit, in the row of buttons and has a "P" with a triangle cone.

As mentioned above, the language settings are set elsewhere in the UConnect unit (the thing that looks like the "radio") system.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #11 ·
Hi everyone

Thanks for all the helpful suggestions.

I have now cracked it. Solution is via the central radio panel using the "plus" button and subsequent menu options. It is just so much more difficult when the options are in another language.

Anyway language now successfully set to English and I can see all the warnings etc and hear the sat nav in English. Will make the driving for the rest of the holiday much more straightforward.

Thanks again for everyone's help.

Robert
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top