Jeep Renegade Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hiya

We've got a new to us 2015 Renegade Longitude that we picked up a couple of weeks ago. Thankfully from a dealer with a warranty.

The TPMS light was on when we collected the car and the dealer had told me before we picked it up, that it would be fixed. Their suggestion was that it would sort itself out after driving for about 20 mins. Which in their defense, is all the "re-learn" procedure is. I then proceeded to drive the 3.5 hours back home, where the light did not go out!

Basically you have two "alerts" on the info screen which are "Low Tyre Unavailable" and "Low Tyre Pressure" .

My local trusted garage reset the codes and performed an MOT for peace of mind and all was well.... Until a couple hours later when I got back in the car and the system failed again with the same error(s).

I'm now going to be taking the Renegade to a local (ish) Jeep/Fiat/etc dealer who are going to try and diagnose the problem. Thankfully this is all going to be at the expense of the (Citroen) Dealer that I bought the car from. Although I may have to pay for it first and get it refunded to me - which could get expensive at £145/hr!!!!!!

Has anyone had issues with their TPMS system like this before?
 

·
Registered
2017 renegade trailhawk 9 spd auto glacier metallic, preferred package 27E
Joined
·
374 Posts
Hiya

We've got a new to us 2015 Renegade Longitude that we picked up a couple of weeks ago. Thankfully from a dealer with a warranty.

The TPMS light was on when we collected the car and the dealer had told me before we picked it up, that it would be fixed. Their suggestion was that it would sort itself out after driving for about 20 mins. Which in their defense, is all the "re-learn" procedure is. I then proceeded to drive the 3.5 hours back home, where the light did not go out!

Basically you have two "alerts" on the info screen which are "Low Tyre Unavailable" and "Low Tyre Pressure" .

My local trusted garage reset the codes and performed an MOT for peace of mind and all was well.... Until a couple hours later when I got back in the car and the system failed again with the same error(s).

I'm now going to be taking the Renegade to a local (ish) Jeep/Fiat/etc dealer who are going to try and diagnose the problem. Thankfully this is all going to be at the expense of the (Citroen) Dealer that I bought the car from. Although I may have to pay for it first and get it refunded to me - which could get expensive at £145/hr!!!!!!

Has anyone had issues with their TPMS system like this before?
bad TMPS sensor. i had the same problem. mine said passenger rear bad and turned out to be drivers front. TMPS replaced and all worked well
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
bad TMPS sensor. i had the same problem. mine said passenger rear bad and turned out to be drivers front. TMPS replaced and all worked well
Well the thing is, whilst it briefly worked - all 4 corners showed up just fine. Then it stopped working and nothing is displayed because it's "unavailable". So I'd be surprised if it's a single TPMS sensor, but I guess it could be!
 

·
Super Moderator
Joined
·
1,786 Posts
Better to get Fiat to look at it. So fair play to your supplying dealer for agreeing to that.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
Better to get Fiat to look at it. So fair play to your supplying dealer for agreeing to that.
Yeah, they've got to pay for it some how! They know it should never have left them with any warning light on - which I have in writing!

Annoyingly there's a Fiat dealer round the corner from me that isn't comfortable doing it. They're very new to Fiat though, and used to be only Vauxhall. I did try explaining that most of the car is Fiat!! Hence going to a place an hour from me that is a Jeep dealer.
 

·
Super Moderator
Joined
·
1,786 Posts
It is a Fiat serviceable for the most part. Engine, gearbox etc. 4x4 might be a push, but any good indy should also be able to service it for you.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
It is a Fiat serviceable for the most part. Engine, gearbox etc. 4x4 might be a push, but any good indy should also be able to service it for you.
So am I right in saying that most of the electronics are Fiat based?
 

·
Super Moderator
Joined
·
1,786 Posts
More-or-less. Although there is a fair amount of Magneti Marelli and Bosch.
 

·
Registered
2017 renegade trailhawk 9 spd auto glacier metallic, preferred package 27E
Joined
·
374 Posts
Well the thing is, whilst it briefly worked - all 4 corners showed up just fine. Then it stopped working and nothing is displayed because it's "unavailable". So I'd be surprised if it's a single TPMS sensor, but I guess it could be!
sorry i was talking about one bad sensor, but my read out told me the wrong one
 

·
Registered
Joined
·
6 Posts
Hello, I have the same issue. I've phoned the dealership and they are saying that they need to inspect the car first as it might not be the sensors but the radio receiver etc... all in all very expensive to check something so minor.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #11 ·
Hello, I have the same issue. I've phoned the dealership and they are saying that they need to inspect the car first as it might not be the sensors but the radio receiver etc... all in all very expensive to check something so minor.
Sorry to hear you're having the same problem! I honestly suspect its the receiver for the system as well not the sensors. Once my car goes in I'll definitely report back to tell you what happens!
 

·
Registered
Joined
·
6 Posts
Thanks, I'm booked in myself for the 7th of August. I'll write here as well what the problem is. Now that I think back, I did install a rear dash cam and they are notorious for leaking radio waves, I believe that this is what caused my issue.
 

·
Registered
Joined
·
143 Posts
I had a similar problem with my '15 TH after I had the tires replaced. The Jeep dealer said it could be wither the sensor in the tire or the receiver. (With either, the TPMS light comes on, the code says TMPS unavailable and all four of the tire pressure readouts just show dashes.) I took it back to where I got the tires (Discount Tire). They replaced the sensor (for free). After driving for about 20 minutes, the TPMS warning light went out and the pressure readings were displayed again.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #14 ·
I had a similar problem with my '15 TH after I had the tires replaced. The Jeep dealer said it could be wither the sensor in the tire or the receiver. (With either, the TPMS light comes on, the code says TMPS unavailable and all four of the tire pressure readouts just show dashes.) I took it back to where I got the tires (Discount Tire). They replaced the sensor (for free). After driving for about 20 minutes, the TPMS warning light went out and the pressure readings were displayed again.
Interesting, so one sensor can in theory brick the whole system?? If so that seems pretty stupid.

I really hope it is a simple fix for ours. I will keep you posted.
 
1 - 14 of 14 Posts
Top