Jeep Renegade Forum banner

1 - 20 of 56 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
I was putting a K&N on the other weekend and noticed my motor mount underneath the air box looks bad. I wonder if this is why I get a weird wobble like I'm driving over bumps on smooth road when I turn left. Also I wonder if this contributes to the weird vibration around 30MPH. What do your motor mounts look like, shredded like mine? Is it normal?
 

Attachments

·
Registered
Joined
·
30 Posts
I haven't looked at mine yet but some of the symptoms you describe sound similar to what I'm dealing with. I talked with a buddy who said his brother (who's a mechanic) said he's seen a bunch of these renegades come in with passenger side motor mounts going out by 60,000 miles. I've got about 23k on my 2015 so I'm starting to wonder if mine is bad too.

Sent from my SM-G920V using Tapatalk
 

·
Registered
Joined
·
124 Posts
Sounds like what I have been hearing on mine as well, just over 20k miles. I crawled under to check suspension components when I did the oil change a couple of weeks ago, but now it looks like I have something else to check. Did a quick search on the part, 68278029AC, and have been finding it for about $150. Looks simple enough to swap out, but it seems ridiculous to have to be swapping this part out so quickly, if that is what it is.

Erik
 

·
Registered
Joined
·
124 Posts
Mine was squeaking over slow speed bumps, changed at 13k miles.
Not that i have a dealership nearby that I would want to work with over a $150 part and the hassle of the entire service call, but was this a warranty item or "normal" wear and tear since it is a rubber mount?

Erik
 

·
Registered
Joined
·
105 Posts
Not that i have a dealership nearby that I would want to work with over a $150 part and the hassle of the entire service call, but was this a warranty item or "normal" wear and tear since it is a rubber mount?

Erik
It was covered by the warranty, as was the seat belt buckle, turbo oil return pipe, clutch, fly wheel, four attempts at repairing core plug. Now needs a new Engine as core plug can't be fixed !!.
 

·
Registered
Joined
·
124 Posts
I was wondering if it would be possible for someone with a new or newer Renegade post a picture of what their passenger side motor mount looks like? I just looked at mine and it doesn't look as bad as Krull's, but not sure what it should look like. Also lifted up the front end to try and see if there was anything with play in it suspension wise and did not find/hear anything.

Thanks - Erik
 

·
Registered
Joined
·
124 Posts
The edit option went away before I got the pictures of my mount downloaded. Here are three pictures, top and both sides of what my mount looks like. Looking at the pictures closer and blown up, I can see what looks like a tear across the top of the rubber in the third picture.

Thanks - Erik
 

Attachments

·
Registered
Joined
·
32 Posts
I'm glad I found this thread. This sounds like the problem I'm having. I have 17K and the sound just started this weekend (or noticed it), coming from the passenger side. I can feel the vibration sometimes. Crawled under it and couldn't find the problem. I'll have to take a look at it later.
 

·
Registered
Joined
·
908 Posts
I'm glad I found this thread. This sounds like the problem I'm having. I have 17K and the sound just started this weekend (or noticed it), coming from the passenger side. I can feel the vibration sometimes. Crawled under it and couldn't find the problem. I'll have to take a look at it later.
Hey bonesky,

If we can provide any assistance if you decide to use your Jeep dealership to tackle this, we're happy to help! Please reach out in a PM with your VIN if you need anything.

Kori
Jeep Social Care Specialist
 

·
Registered
Joined
·
124 Posts
Hey bonesky,

If we can provide any assistance if you decide to use your Jeep dealership to tackle this, we're happy to help! Please reach out in a PM with your VIN if you need anything.

Kori
Jeep Social Care Specialist
Any chance of posting a picture of what the mounts should look like? Since the sound is now coming from both sides of the engine bay, I have broken down to having the local dealership look at it next Monday. Hopefully their service department is better than their sales department was.

Erik
 

·
Registered
Joined
·
908 Posts
Any chance of posting a picture of what the mounts should look like? Since the sound is now coming from both sides of the engine bay, I have broken down to having the local dealership look at it next Monday. Hopefully their service department is better than their sales department was.

Erik
Hey Erik,

I will check and see if that's something I can provide. Hang tight!

Kori
Jeep Social Care Specialist
 

·
Registered
Joined
·
32 Posts
I got a photo of the passenger side mount. I can't really tell if it's torn or not. The driver side mount under the battery I can not see at all.

Driving to lunch yesterday, I could hear the noise and seemed to be getting louder. Then on the return trip, I can't hear it and I have not heard it again. I have the radio off when I'm trying to figure out where it's coming from. But I can hear it sometimes with the radio on. I did feel a vibration through the gear selector once, but now it's gone. This is going to be a fun problem to solve.
 

Attachments

·
Registered
Joined
·
908 Posts
Any chance of posting a picture of what the mounts should look like? Since the sound is now coming from both sides of the engine bay, I have broken down to having the local dealership look at it next Monday. Hopefully their service department is better than their sales department was.

Erik
I checked and am not able to post anything from my end. It was advised to have Rene diagnosed at the dealership, which you are already on top of!

Kori
Jeep Social Care Specialist
 

·
Registered
Joined
·
124 Posts
I checked and am not able to post anything from my end. It was advised to have Rene diagnosed at the dealership, which you are already on top of!

Kori
Jeep Social Care Specialist
Kori,

Thanks for checking. I will see what they say on Monday.

Erik
 

·
Registered
Joined
·
124 Posts
New Mount

I looked up part 68278029AC. https://www.moparpartsgiant.com/parts/mopar-damper-engine-mount~68323461aa.html Mopar parts giant shows to have it replaced by 68323461AA. I would assume its exactly the same? Superseding part number?
Stopped by the dealer today to take a look at a new mount and compare it to the one that is in my Jeep. Well, I guess they finally realized that there was an issue, hence the superseded part number. They have completely redesigned the mount and I am hoping that its replacement will fix my clunking and some of the vibration issues.

Here are a couple of pictures of what the new mounts look like.

Erik
 

Attachments

·
Registered
Joined
·
30 Posts
Is that the new mount in your pics? How much did you pay for it?

Sent from my SM-G920V using Tapatalk
 
1 - 20 of 56 Posts
Top