Jeep Renegade Forum banner
1 - 20 of 24 Posts

· Registered
Joined
·
8 Posts
I felt compelled to write a post about what I'm experiencing with my new Renegade. I took delivery of the car the afternoon of July 2nd and by the night of July 4th it was dead in my garage.

Everything was working fine earlier in the day and I had been enjoying the new car feeling but when I went to pick up my son after a fireworks display on Saturday night the car would not start. Not only would not start but went crazy. It was like the car was possessed. The dash lights all came on and were blinking at my, the wipers started going on their own, the e-brake displayed with the light on an we couldn't turn anything off. The brake was locked up so I couldn't push it down to start the car.

Some other things on the car continued to work without issue such as the windows, drivers power seat, and the Uconnect system.

We had the car towed back to the dealership this morning and I was just informed that they found the fuse that powers the computer was blow. They replaced it and it blew again. They are trying to figure out what is causing it to blow and if there is a short somewhere. They are now waiting on further instruction from Chrysler as to what they need to do to fix it and make sure we don't have this issue again.

Has this happened to anyone else? What did they find? Was it fixed and if so, has everything gone well since?

Thanks!
 

· Registered
Joined
·
602 Posts
I felt compelled to write a post about what I'm experiencing with my new Renegade. I took delivery of the car the afternoon of July 2nd and by the night of July 4th it was dead in my garage.

Everything was working fine earlier in the day and I had been enjoying the new car feeling but when I went to pick up my son after a fireworks display on Saturday night the car would not start. Not only would not start but went crazy. It was like the car was possessed. The dash lights all came on and were blinking at my, the wipers started going on their own, the e-brake displayed with the light on an we couldn't turn anything off. The brake was locked up so I couldn't push it down to start the car.

Some other things on the car continued to work without issue such as the windows, drivers power seat, and the Uconnect system.

We had the car towed back to the dealership this morning and I was just informed that they found the fuse that powers the computer was blow. They replaced it and it blew again. They are trying to figure out what is causing it to blow and if there is a short somewhere. They are now waiting on further instruction from Chrysler as to what they need to do to fix it and make sure we don't have this issue again.

Has this happened to anyone else? What did they find? Was it fixed and if so, has everything gone well since?

Thanks!
There was another owner who had a short in the steering column. FCA ended up buying it back
 

· Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Update - I just heard back from the dealers service department. They said it that the fuses keep blowing but that there appears to be no issue with the wiring so it must be a bad Body Control Module. They said the ordered it before the cut off time today so they hope to have the part in by tomorrow (no guarantees).

I told them I am very nervous that this is going to be a recurring issue or that something crazy like this might happen while I'm actually driving the car. They said they would drive it around a few times after it is fixed, etc. I love this car but if it's defective I want them to replace it!

Anyone with BCM issues?
 

· Super Moderator
Joined
·
3,685 Posts
Update - I just heard back from the dealers service department. They said it that the fuses keep blowing but that there appears to be no issue with the wiring so it must be a bad Body Control Module. They said the ordered it before the cut off time today so they hope to have the part in by tomorrow (no guarantees).

I told them I am very nervous that this is going to be a recurring issue or that something crazy like this might happen while I'm actually driving the car. They said they would drive it around a few times after it is fixed, etc. I love this car but if it's defective I want them to replace it!

Anyone with BCM issues?
There have been a few people with a bad BCM. Replacing it seemed to fix things for them though.
 

· Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
Day 5 and still no car in my garage. Dealer keeps telling me my part was shipped and expedited but he hadn't received an ETA yet. Noon today I got tired of waiting for another update so I called the service department but my contact was out to lunch. I instead called FCA directly and explained my situation. She actually asked me "what would you like me to do". Really? What would you like me to do...how about get me the car I paid for. She then called my dealer service dept and got some info from them then came back on line to tell me that the part was expedited by my dealer and now by them. I asked what expedited meant.... going from a three week wait to one week and she actually said yes. She then goes on to tell me that the part I need is on backorder and will ship out to my dealer as soon as possible but there is NO ETA. But for my troubles she's happy to offer me two years worth of free oil changes at any Jeep dealership. I explained that I felt that was all well and good but still doesn't put a car in my driveway by any gauranteed date, nor are we even sure this part is an absolute fix. The dealer has another limited on site but it doesn't have my 9 speakers nor the navigation. I told her I wanted them to outfit that car same as mine and sell me that one instead. If that doesn't work out I honestly want to push to return the vehicle. I don't need this stress. Buying a new car is supposed to be fun and exciting, not frustrating and unsettling. I am sick over this. I've been patient about as much as I can be. I don't blame the dealer but I do expect them and FCA to make this right immediately. Buying a new car and carrying a car payment was no small decision for me and now I don't even have the car to go along with my car payment.

Any advice?
 

· Registered
Joined
·
105 Posts
Day 5 and still no car in my garage. Dealer keeps telling me my part was shipped and expedited but he hadn't received an ETA yet. Noon today I got tired of waiting for another update so I called the service department but my contact was out to lunch. I instead called FCA directly and explained my situation. She actually asked me "what would you like me to do". Really? What would you like me to do...how about get me the car I paid for. She then called my dealer service dept and got some info from them then came back on line to tell me that the part was expedited by my dealer and now by them. I asked what expedited meant.... going from a three week wait to one week and she actually said yes. She then goes on to tell me that the part I need is on backorder and will ship out to my dealer as soon as possible but there is NO ETA. But for my troubles she's happy to offer me two years worth of free oil changes at any Jeep dealership. I explained that I felt that was all well and good but still doesn't put a car in my driveway by any gauranteed date, nor are we even sure this part is an absolute fix. The dealer has another limited on site but it doesn't have my 9 speakers nor the navigation. I told her I wanted them to outfit that car same as mine and sell me that one instead. If that doesn't work out I honestly want to push to return the vehicle. I don't need this stress. Buying a new car is supposed to be fun and exciting, not frustrating and unsettling. I am sick over this. I've been patient about as much as I can be. I don't blame the dealer but I do expect them and FCA to make this right immediately. Buying a new car and carrying a car payment was no small decision for me and now I don't even have the car to go along with my car payment.

Any advice?
Have they provided you with a free loaner vehicle. at least?
 

· Registered
Joined
·
8 Posts
Discussion Starter · #8 ·
Yes I have a crappy loaner at least. I do believe the dealership wants this to go right as badly as I do. But at this point the car is a dud and they should be finding me a new one and then they can fight with FCA to be set back to rights.
 

· Registered
Joined
·
194 Posts
Yes I have a crappy loaner at least. I do believe the dealership wants this to go right as badly as I do. But at this point the car is a dud and they should be finding me a new one and then they can fight with FCA to be set back to rights.
Hopefully that's what they end up doing, have you tried to bring that up with them? I think if brought up as a possible outcome of the direction this could head they might provide some insight on doing just this.
 

· Registered
Joined
·
62 Posts
Sounds like a typical European car with either a grounding issue or a dead battery.

Hopefully the BCM solves the issue for you. No use throwing away a perfectly good vehicle because of a bad BCM.

Everyone must remember that these vehicles are made by people and things that are made by people are not always perfect. Thank the fact that the dealer is taking their time to do it right. Many dealers will just do the cheapest jerry rig possible to make you go away. You are fortunate. Good Luck
 

· Registered
Joined
·
8 Posts
Discussion Starter · #11 ·
My husband reached the dealer himself this afternoon and expressed all of our concerns, etc and the GM and sales manager both conferenced with him. They are being very supportive and understand the lack of communication is causing anxiety. The sales manager called me and promised he'd call me everyday by noon with updates even if it's just to say we are still waiting. He said they are also working with Chrysler tech support who told them to go through the car, every single wire to see if any wires are pinched because they've run into this issue before. If they find a pinched wire it may turn out to not be the BCM and they will a.so replace the wire harness, etc. He also told me he was working to see if they could make my first car payment which to me would make up for all of this. Then I don't feel like I'm paying for a car I don't have to drive. He said they hope to have the BCM by Friday so we will wait and see. But overall I have faith in this dealership. Hearing them say they are in this with me makes all the difference. If we can get passed this issue I know it'll be worth it because I love this car.
 

· Registered
Joined
·
454 Posts
So sorry to hear this. I honestly wouldn't push for the first payment. I would push hard for a free extended warranty. Worth way more and with the troubles you have had it's worth asking.
 

· Registered
Joined
·
8 Posts
Discussion Starter · #14 ·
Thanks everyone for the comments and suggestions. My dealership service manager just called me to tell me he had GOOD NEWS! Welcome words to my ears as I really need a bit by now. So he said he spent an awful lot of time on the phone with a rep in Detroit who told him that some of the cars early on had an issue with a pinched wire behind the intake manifold that was causing the BCM to short out and go down. So he said first thing this morning he and the techs pulled out the wiring harness and sure enough there was a "mangled wire stripped right down to the metal" that was causing the fuse that powers the BCM to blow. He said that if all goes well I shouldn't need the new BCM and that he hopes to be pulling my Renegade into the wash bay by 11 am to get it ready for Simonizing and I should be able to pick it up today. Fingers crossed that the pinched wire is the fix and this ordeal will be done with!
 

· Registered
Joined
·
1,633 Posts
. . .a pinched wire behind the intake manifold that was causing the BCM to short out and go down. . .
Could you ask the service guy to point out the wire and then take a picture? I'd like to look at mine to and try to prevent it from rubbing raw sometime in the future.
 
  • Like
Reactions: Hdreserve

· Registered
Joined
·
8 Posts
Discussion Starter · #17 ·
Got my Renegade back from the dealer at 2 pm yesterday afternoon. So thrilled. The BCM was fine and as they suspected yesterday morning it was a pinched wire. They showed me the yellow wire when I picked it up. The thing was smashed flat and the insulation had been melted away in places where the copper wire came through and grounded out on the intake manifold. FCA started a case on my car so that if this happens to others they'll know to check this first. Glad it turned out to be something so simple. The car is prefect and I'm so happy to have it back.

It's worth noting that my dealership was amazing through this process. It's a great group of down to earth people who were really sharing my pain. lol The GM gave me a gift card to a really nice restaurant in town as a personal apology. When I picked the car up they had simonized it, cleaned it all up inside again and gave me another full tank of gas. FCA is giving me two years of free oil changes as well. I'm satisfied and I have high hopes that this was the last of the glitches.
 

· Registered
Joined
·
471 Posts
It's worth noting that my dealership was amazing through this process. It's a great group of down to earth people who were really sharing my pain. lol The GM gave me a gift card to a really nice restaurant in town as a personal apology. When I picked the car up they had simonized it, cleaned it all up inside again and gave me another full tank of gas. FCA is giving me two years of free oil changes as well. I'm satisfied and I have high hopes that this was the last of the glitches.
So happy your problem is resolved & nice to hear they took good care of you!!
 

· Registered
Joined
·
62 Posts
Glad this came out ok. If you have photographs of the wire and location, or at least the location, that would be excellent to document on here so as to help others. If Chrysler is taking notes, why shouldn't the community?

Thank you ahead of time!
 
1 - 20 of 24 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top