Jeep Renegade Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2015 Jeep Renegade Limited. When I try to turn on my heated seat the buttons lights up and just blinks off and on for about 15-20 seconds and then shuts off. The heated seat does not heat up at all. The heated steering wheel works perfectly fine.
Does anyone have any idea what is going on with the seat. The dealer wants to charge me $150 a hour to just look at it. And who knows how long they will take to figure it out. And at $150 a hour i can not afford to have them taking 3 hour to figure the problem out.

PLEASE HELP
mzkelley1971
 

·
Registered
Joined
·
1,124 Posts
I have a 2015 Jeep Renegade Limited. When I try to turn on my heated seat the buttons lights up and just blinks off and on for about 15-20 seconds and then shuts off. The heated seat does not heat up at all. The heated steering wheel works perfectly fine.
Does anyone have any idea what is going on with the seat. The dealer wants to charge me $150 a hour to just look at it. And who knows how long they will take to figure it out. And at $150 a hour i can not afford to have them taking 3 hour to figure the problem out.

PLEASE HELP
mzkelley1971
Hello mzkelley1971,
We are certainly sorry to hear about your most recent concern and understand your frustration. You can certainly choose to visit a different dealer for a second opinion. If you’re not familiar with any other dealers in your area, you can head to https://www.jeep.com/find-dealer.html?sid=1037056&KWNM=jeep+dealer+locator&KWID=43700041643746041&TR=1&channel=paidsearch&ds_rl=1273287&ds_rl=1267886&ds_rl=1272981&gclid=EAIaIQobChMI9Iz6jLzg5gIVBNvACh166Q4MEAAYASAAEgIqW_D_BwE&gclsrc=aw.dsand enter your ZIP code to find a dealer near you. If you proceed to go this route and would like additional assistance throughout that process, please reach out to us privately. We're always happy to help.
Laura
JeepCares
 

·
Registered
Joined
·
609 Posts
Someone may know specifically what makes the light blink (probably some engineer in Italy), but until you contact that person I recommend you root around under the seat looking for damaged wires or loose connections. I'd also check the fuse. My 2015 owner's manual tells me it's F8 (20 amp in fuse holder #1 - in the cargo area).
 

·
Premium Member
Joined
·
1,340 Posts
Good call @rsanges, Plus 1 for an unplugged connector under the seat.

If not, it sounds like you could have a heating element that has failed.
 
1 - 4 of 4 Posts
Top