Jeep Renegade Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey all, just got done installing my Rough Country lift with Eibach springs on my 2018 Renegade Sport 4x4. While driving theres a clicking noise? Resembles that of a playing card in a bicycle wheel and it sounds like its traveling through the steering wheel. Only happens when accelerating and the faster I go the faster it goes too. It also shakes/vibrates at higher speeds and I’m not sure if its associated but it idles rougher in drive and reverse as well. Goes away completely in neutral, leaning towards driveshaft/driveline or maybe an axle issue? Any help or insight is welcome and appeciated!
 

·
Registered
Joined
·
21 Posts
I've experienced a similar issue, but it was prior to having my lift installed. I have the Daystar 1.5 inch spacer lift installed, but the sound was evident both pre and post-lift. I'm curious if anyone can weigh in on this.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I've experienced a similar issue, but it was prior to having my lift installed. I have the Daystar 1.5 inch spacer lift installed, but the sound was evident both pre and post-lift. I'm curious if anyone can weigh in on this.

Yes me too. I have talked to a lot of different people and they all say different things. Could be driveshaft, axles, anything. Most people are telling me its the axles being maxed out.
 

·
Registered
Joined
·
34 Posts
I have the same rough country lift. I know for a fact that I did not have the noise prior to the lift but do now. I suspect the installer did not cut enough of the strut off when he installed it. It sounds to me like something is loose but i have checked multiple spots and everything is tight...
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I have the same rough country lift. I know for a fact that I did not have the noise prior to the lift but do now. I suspect the installer did not cut enough of the strut off when he installed it. It sounds to me like something is loose but i have checked multiple spots and everything is tight...
you have just the rough country lift, no springs? Thats odd. Yeah if the struts werent trimmed id imagine thats it for you. I flushed the bottoms of mine in. But the noise is frustrating but I’m doing lots of research and slowly checking over everything day by day. Checking subframe after work today. Inner axles will be checked later too.
 
1 - 5 of 5 Posts
Top