Jeep Renegade Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Well i finally did it. I purchased my 2016 Latitude Renegade Thursday night. So far it was been awesome! I am super happy with it and look forward to all the adventures ahead. I have two questions for all of you. I noticed that when i use the wiper fluid i get the smell inside the cabin, any fix with this? Also I have my iphone 6+ connected via bluetooth. Only problem is that when i get notifications on my phone it only vibrates and doesnt make the usual notification noise. My phone is not on silent/airplane/do not disturb mode. Any ideas?

Thanks so much everyone!

:ReneBlueWave:
 

·
Registered
Joined
·
126 Posts
I suspect the wiper fluid smell will go away once you have used it all and refilled with something else. If you are not receiving text alerts through uconnect than it may need an update. When I first got mine I received alerts then it stopped, dealer did an update and it works again.
 

·
Registered
Joined
·
302 Posts
Welcome fellow Michigander! What part of the state are you in?
1.) Renegades come with a european washer fluid which contains more alcohol than what you'll find in the US. The problem will disappear when you refill with the US stuff. In the meantime - shut off your blower while you're squirting the windshield and you shouldn't suck in too much of the fumes.

2.) Same problem. I don't get text notifications with my iPhone 6 + even though the manual says I should...... I called UConnect and they said they haven't tested iPhones with a '16 Renegade yet so there may be some software updates coming. Give them a call and tell them your problem. The more complaints they get the more likely they are to address it. Their phone is 877-855-8400

You can check if your Jeep has any outstanding UConnect updates here https://www.driveuconnect.com/software-update/ You'll need to enter your VIN.
 

·
Registered
Joined
·
31 Posts
Well i finally did it. I purchased my 2016 Latitude Renegade Thursday night. So far it was been awesome! I am super happy with it and look forward to all the adventures ahead. I have two questions for all of you. I noticed that when i use the wiper fluid i get the smell inside the cabin, any fix with this? Also I have my iphone 6+ connected via bluetooth. Only problem is that when i get notifications on my phone it only vibrates and doesnt make the usual notification noise. My phone is not on silent/airplane/do not disturb mode. Any ideas?



Thanks so much everyone!



:ReneBlueWave:

Congrats on new Latitude! Hope you enjoy your new ride. Pics would be great!

With the uconnect system you might just need to carefully adjust a setting. I changed a uconnect setting after I purchased my jeep that fixed that iPhone text issue, but can't recall exactly what I did. You might need a flash update for your uconnect. You might search for TSBs for your issue and model and perhaps there is a flash update needed

Welcome to forum!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
367 Posts
Try setting 'show notifications' on on your iPhone.
Go to settings/Bluetooth and click the 'I' with the circle next to the uconnect device you have synced to.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
Congrats on new Latitude! Hope you enjoy your new ride. Pics would be great!

With the uconnect system you might just need to carefully adjust a setting. I changed a uconnect setting after I purchased my jeep that fixed that iPhone text issue, but can't recall exactly what I did. You might need a flash update for your uconnect. You might search for TSBs for your issue and model and perhaps there is a flash update needed

Welcome to forum!


Sent from my iPhone using Tapatalk
Here is a pic. I am waiting to wash it and take better pictures on a sunny day.
 

Attachments

1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top