Jeep Renegade Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi,

First time poster, long time fan of the site. So I just became a car owner for the first time in 8 years. Living in the heart of Chicago, I never could justify having a car with such good public transit and no garage. Well now I have a garage and I just got my Renegade Limited 4x4 w/ MySky after waiting almost 5 months.

To be fair the MySky was a non negotiable, so I decided to wait for them this summer. I was surprised at the lack of fully loaded Renegades that are out there. I ultimately got the one that had the most features I wanted, but am still considering adding the security group in the future.

So, here's my question, I've put on about 600 miles in the week that i've had it, but I noticed a strange quirk. My speedometer switched over to km/h and even tho I go into the "Units" section to reset it, it doesn't change back? It just happened in the last 100 miles that I could tell, has this happened to anyone, how do I fix it? The manual doesn't specify this kind of issue.

Any suggestions would be greatly appreciated. thanks!
 

·
Premium Member
Joined
·
1,541 Posts
Hi and welcome! Post some pics when you get a chance!

Try this for the speedometer:
Push and release the UP or DOWN arrow button until “Speedometer” is highlighted in the EVIC. Push the OK button to change the speedometer scale from MPH to km/h (km/h to MPH).
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top