Jeep Renegade Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter · #1 ·
I've just seen that new software for UConnect 6.5 was released on 17 May: only a few days ago. It is available for download on the UConnect web site. The revision number is 16.02.34. That site also contains service bulletin information that describes problems fixed by the update.

I plan to ask my dealer to install it when I take my TH in for its 1000km courtesy service. I'm tempted to go ahead and install it myself, but I don't want to disturb my good relationship with the dealer at this early time!

By the way, the UConnect site doesn't list the Renegade, so select another Jeep model that has UConnect 6.5 (for example, a 2016 Compass) and then enter your own vehicle's VIN.

I'll be interested to hear comments from anyone who has it or gets it.
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #3 · (Edited)
I see in another thread that there is a software version 16.05.32 for UConnect 6.5, in addition to the just-released 16.02.34. Going by the dates of the posts, 16.05.32 appears to pre-date 16.02.34. The discussion on that other thread is rather mixed up, but seems to mainly relate to different models of Renegade to mine (mine is Jan 2016 build, Australian TH). Obviously the 16 prefix means 2016 release, but I'm now wondering whether different models get different software packages. Previously I had thought not, since many of us seem to be on 15.21.37, and that version also apparently relates to some Fiat 500's. I'd like to know the real story on FCA's software versioning policy.
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #5 ·
OK, so we now have at least three version numbers all released in 2016. Clearly the first two digits (16) represent the year (2016). The second two digits DO NOT represent the month. Also, since iamstillvince sees no newer update, they must be quite vehicle or model specific.

I have a few issues with my TH (not problems, just strange behaviour) so I will try to get my dealer to update the software.
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #7 ·
16.02.34 finally installed onto my 2016 TH by dealer. They tried 3 times. I tried once and also failed, even though I thought I had the correct swdl.iso file on my USB.

It hasn't fixed all my issues, but perhaps some. I'll wait and see.
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #9 ·
OK, from all the evidence in posts to this forum, it seems that there are numerous different 2016 versions (all begin with 16). So they are obviously customised for different markets and different models, and perhaps even for subtle build variations.

My recent 16.02.34 update hasn't fixed everything. Actually I don't know for certain whether it's fixed ANYTHONG, but certain things haven't re-occurred yet so there's hope. Here are some of the (fairly trivial) problems that I had -

* Audio equalisation (tone) controls have no effect (NOT fixed by update).

* Radio occasionally loses its preset stations (possibly only on AM band).

* English language selection occasionally reverts to Italian and has to be reset.

* Reversing camera loses its guide-lines and has to be reset.

* The Radio-on function (comes on with the engine, doesn't come on with the engine, or remembers the most-recent switch-off status) is irrational. I haven't figured out the pattern of the unpredictable behaviour. (NOT fixed by update)

* The park-sense inhibit switch will not extinguish its red light when pressed above the parksense-threshold speed. However, despite the lamp remaining on until the car slows down, the function is actually toggling between off and on with each press. For example, one press and it's back on (even though it doesn't indicate that). Two presses and it's off. Three presses and it's on. You can only know which way it is when you slow down to parking speed. It's a nuisance, and also could be dangerous if you think it's on but it is not. (NOT fixed by update)

Has anyone else got these issues? JeepCare, do you know about these problems? More to the point, does Jeep care?
 

·
Registered
Joined
·
1,266 Posts
OK, from all the evidence in posts to this forum, it seems that there are numerous different 2016 versions (all begin with 16). So they are obviously customised for different markets and different models, and perhaps even for subtle build variations.

My recent 16.02.34 update hasn't fixed everything. Actually I don't know for certain whether it's fixed ANYTHONG, but certain things haven't re-occurred yet so there's hope. Here are some of the (fairly trivial) problems that I had -

* Audio equalisation (tone) controls have no effect (NOT fixed by update).

* Radio occasionally loses its preset stations (possibly only on AM band).

* English language selection occasionally reverts to Italian and has to be reset.

* Reversing camera loses its guide-lines and has to be reset.

* The Radio-on function (comes on with the engine, doesn't come on with the engine, or remembers the most-recent switch-off status) is irrational. I haven't figured out the pattern of the unpredictable behaviour. (NOT fixed by update)

* The park-sense inhibit switch will not extinguish its red light when pressed above the parksense-threshold speed. However, despite the lamp remaining on until the car slows down, the function is actually toggling between off and on with each press. For example, one press and it's back on (even though it doesn't indicate that). Two presses and it's off. Three presses and it's on. You can only know which way it is when you slow down to parking speed. It's a nuisance, and also could be dangerous if you think it's on but it is not. (NOT fixed by update)

Has anyone else got these issues? JeepCare, do you know about these problems? More to the point, does Jeep care?
Hi Peter Freeman,

Sorry to hear about this! Our International Customer Care Team should be able to assist you further. You can reach them by phone at 00800-36343-000 or email at [email protected]. Please let me know if you have additional questions.

Andrea
Jeep Social Care Specialist
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #12 ·
Dear 'Jeep Cares' -

Thanks for your reply in this thread regarding my radio problems. I have acted on your suggestion and emailed Customer Care International. The text of my email is as follows -

Customer Care International -

I am the owner of a Jeep Renegade Trailhawk in Australia. It is model number BUUH7427F-8AL16, build date January 2016, purchase date May 2016, *VIN 1C4BU0000GPD14936. My vehicle is equipped (as standard) with a Beats Premium 9-speaker Audio System, with which I have been dissatisfied since*purchase.

A relatively minor issue is that its self-power-on at vehicle start-up is unpredictable. I have it set (via the U-Connect menu system) to NOT self-start, but it usually still does. This fairly trivial problem seems to me like a software issue, and I had* hoped that it would be**rectified when my software was updated from 15.21.37 to 16.02.34, but it was not.

Of more importance, the sound quality is poor, and the equalisation (tone) control has limited effect. The output of all speakers except the front pair seems to be quite low - especially the sub-woofer in the cargo compartment. I had hoped that this problem also might be rectified by the software update, but it too was unaffected. I have noted, via a Jeep Renegade internet forum,*that other owners complain of fairly similar symptoms. I have been made aware of a Technical Service Bulletin TSB 08-065-16, issued on 23 May 2016, that might offer a solution. Since my build date precedes that date, I assume that this TSB is applicable to my vehicle. I also have read (and I realise this is only anecdotal) that inspection and reconnection of the audio amplifier has rectified similar problems in some vehicles.*

Via the forum mentioned above, I have had contact with 'Andrea', the Jeep Social Care Specialist, identified on the forum by username*'Jeep Cares'. She advised me to contact you, and provided me with your email address.

Can*you please help me? My dealer seems to be not (yet?) skilled in addressing*problems with this vehicle, and*information from you, via me, might be useful to them.

Therefore can you answer -

1. Is there a known sound quality problem with audio *systems of my type?
2. If so, is there either a software or hardware fix for it?
3. Are there known problems with the wiring between the audio amplifier and speakers?
4. Is*TSB 08-065-16, referenced above, an* applicable fix?
5. Do you have any other, different, recommendations for me?

I look forward to your assistance.

Regards, Peter Freeman (an otherwise-satisfied Jeep customer)
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #13 ·
Jeep Australia Customer Care contacted me and facilitated my dealer to install TSB 08-065-16, which updates the AMP s/w from F2.07.00 to F2.08.00. This has fixed my radio quality problem. The sound has gone from pathetic to outstanding. However, I was really disappointed that I had to, myself through this forum, research and find the fix for my dealer. That's supposed to be their role.

Most of the other problems remain, but overall I'm happy with the car. It's lovely to drive on-road, and has been along a couple of VERY challenging tracks.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top