Jeep Renegade Forum banner
21 - 40 of 74 Posts

·
Registered
Joined
·
2 Posts
sames codes after accident

i will keep this thread updated as the repair process on the renegade moves forward at the dealership, and the final "fix", because from my research here and around the internet, this seems to be a somewhat common problem ?
* no 4wd,
* dynamic trq service req'd,
* service esc,
* service hill start
with the "traction control off" icon appearing on the instrument cluster and it's t.c. Button unresponsive

although,
from the other reports i could find no feedback of what the definitive "fix" was ?

It's never fun to have a problem with a brand new vehicle ?
That said,
i have to say that even for the brief 200 miles we drove the little renegade home from the dealership in a canadian winter storm dumping 12" of snow, through the rocky mountain passes where we live, to say that we were impressed with the way it hugged the road and dealt with the horrible road conditions would be an understatement !
The little renegade was fantastic in "snow" mode, never getting stuck, never sliding around, and it was unbelievably stable delivering a much appreciated confidence in such conditions.
I think fca have a winner here folks ?
 

·
Registered
Joined
·
2 Posts
You saying your Renegade handled well in the snow is causing me to think my husband was right in saying my Renegade lost steering control in the last snow we had. There was maybe two inches on the ground when the accident happened. It had only been snowing about an hour and we had people passing us on the main road. when I noticed we were moving off of the road toward a guard rail which we ended up slamming in to. He said the steering would not let him gain control that the steering wheel. He said it was turning almost all the way around. I am in a debate with my insurance company about it being repaired while it sits in my yard. When it does get repaired, I am selling it! I am afraid to get back in to it.
 

·
Registered
Joined
·
2 Posts
I have the same issue on a 2017 sport edition with about 40,000 miles. I just bought it less than a month ago. It is in the shop now, I will update it when they get back to me. Hopefully we figure this out! Until then I will enjoy my loaner vehicle from the dealership!
 

·
Registered
Joined
·
3 Posts
Interesting discussion. This happened to me at Christmastime. Dealer diagnosed a bad air bag sensor that was shorting; hence the code. Mine is fixed, but haven’t tried any heavy 4 wheeling in deep snow since, so hoping my fix was the right one. I asked about computer update at the time and was assured mine was fine.
 

·
Registered
Joined
·
32 Posts
Same issues, but completely resolved

I recently bought a 2016 Trailhawk with 31k miles. Almost immediately after purchase (from Carmax), I received four errors:
  • Dynamic Steering Torque
  • ESC
  • Hill Descent
  • Parking Brake

I first contacted Jeep's service department, and the tech indicated that they had seen this error before and it's usually a bad module. They had my Renegade for about a week. Since getting it back about 30 days ago, I have driven hundreds of miles, done a fully-packed camping trip and even done some mud-slinging off-road challenges with zero issues at all.

PS - Carmax was great, covered all costs for repair and supplied me with a loaner Renegade while getting the module replaced.
 

·
Registered
Joined
·
23 Posts
I have a very similar issue over the last week with my 2015 4WD 2litre with 30,000 on the clock. For no apparent reason multiple errors flashed up. The first referred to steering torque, but then at least 5 others including ABS, Hill Assist, ESC, Electronic parking brake, and 4WD errors.

Switched off and restarted. After about a mile the same errors. Disconnected the battery and restarted. All fine for a while then the same thing happened again after a few days and about 75 miles. Restarted and all has been good now for about 70 miles but I am sure that the light show will happen again! Telephoned main dealer, they had not heard of it and they can’t even get me in for a month! Any ideas please? Are these errors all connected? The car seems fine otherwise. I am therefore assuming this is a glitch of some sort and therefore the car is safe to drive until I get it in at the dealer’s.

Any thoughts welcome please!
 

·
Registered
Joined
·
32 Posts
Since I received the exact same errors at the exact same amount of miles, it's likely that it the exact same module. Here is what my paperwork from the Jeep service department states:

Concern: Customer states svc parking brake, svc esc, svc hill assist and svc dynamic steering lights have all come on at the same time.
Cause: Found internal component failure set in ABS. Found small leak present in pump lines.
Correction: Replaced pump and verified electronic braking system works properly. Verified all wiring is good as well.

The tech mentioned to me that the parking brake hydraulic line was leaking, and that an ABS module was failing. You can try calling other local mechanics and see if this is something that they can look at and repair so you don't have to wait a month. Good luck!
 

·
Registered
Joined
·
23 Posts
Thank you so much bkl182 for that useful information. It is so kind of you to let me have that detail and it will be a great starting point for me to mention to the service department - when I eventually get there! (Two UK JEEP dealerships have closed in the same area so consequently the remaining ones are booked solid which isn’t good). More dealerships in the Midlands UK please Jeep!
 

·
Registered
Joined
·
108 Posts
I just went through this on my 15 trailhawk. My motor mount was bad and caused stress on my passenger side. Replaced the abs sensor and the mount. Codes still on. The hub assembly was bad and was shooting the codes.1500 dollars later problem solved
 

·
Registered
Joined
·
2 Posts
Hello, I'm having the same issues. The dealer couldn't pull any codes so couldn't do anything. They drove it around but of course if didn't do it. I have taken pictures of the dash from the last 2 times to keep track.
Codes disappear when you turn it off and restart it so far. I'm thinking of getting a code reader so I can take pictures and show them the codes. Can anyone recommend a not to expensive model that will work?


Thing has only 8k+ miles on it and i'm getting the ripped off feelilng....
 

·
Registered
Joined
·
1,231 Posts
Hello, I'm having the same issues. The dealer couldn't pull any codes so couldn't do anything. They drove it around but of course if didn't do it. I have taken pictures of the dash from the last 2 times to keep track.
Codes disappear when you turn it off and restart it so far. I'm thinking of getting a code reader so I can take pictures and show them the codes. Can anyone recommend a not to expensive model that will work?


Thing has only 8k+ miles on it and i'm getting the ripped off feelilng....
Hi Schmo404,
We understand why this may be disappointing. Please send us a private message once you plan to return to your dealer and we'll have a case escalated in your behalf so you have some additional assistance going into that next appointment.
Lydia
Jeep Social Care Specialist
 

·
Registered
Joined
·
24 Posts
This happened to us for a little bit, even wrote around here and got little help. I think it just happens when something electronic is not working right. Our problem was water in the front fusebox from a poorly done engine wash got sulfated and was randomly fucking us up.

Maybe check there?
 

·
Registered
Joined
·
2 Posts
Thanks for the info.

It did it this morning when I just stopped at the bank. Thankfully its never messed with the driving. Ran it by the dealer and they told me it was showing codes for a bad wheel sensor and some other things. Wasn't told what other things but the service guy didn't seem concerned. Told me he would check on when they could get the part and go from there. Hopefully this will take care of it.
 

·
Registered
Joined
·
1 Posts
I will keep this thread updated as the repair process on the Renegade moves forward at the dealership, and the final "Fix", because from my research here and around the internet, this seems to be a somewhat common problem ?
  • NO 4WD,
  • Dynamic Trq Service Req'd,
  • Service ESC,
  • Service Hill Start
with the "Traction Control Off" Icon appearing on the instrument cluster and it's T.C. button unresponsive

Although,
from the other reports I could find no feedback of what the definitive "Fix" was ?

It's never fun to have a problem with a Brand New Vehicle ?
that said,
I have to say that even for the brief 200 miles we drove the little Renegade home from the dealership in a Canadian Winter storm dumping 12" of snow, through the Rocky Mountain passes where we live, to say that we were IMPRESSED with the way it hugged the road and dealt with the horrible road conditions would be an UNDERSTATEMENT !
The little Renegade was fantastic in "Snow" mode, never getting stuck, never sliding around, and it was unbelievably stable delivering a much appreciated confidence in such conditions.
I think FCA have a winner here folks ?

I agree my 2017 is awsome in snow!! However experiancing same issue as described here!! with the addition of parkassist and abs as well.. i will read on.
 

·
Registered
Joined
·
5 Posts
Bought a BRAND NEW Renegade North 4X4 Last Friday, drove 190 miles home so now total 256 miles on it as it had been out for a few "test drives" as I was told at the Dealership, the next day being Saturday I went to go to the store for Milk and there is NO 4 WD, the 4WD light won't come on nor will the selector move to "snow"(we have a foot of the fresh stuff), it just stays in "Auto" with only FWD and gets stuck, and now it is showing errors on the dash as follows:
* Dynamic Steering Torque Service Req'd
  • Service ESC System
  • Service Hill Start System


What gives here ?
Is this a common problem with Renegades ?
Has anyone else here experienced this problem with their BRAND NEW Renegade and if so what was the fix ?

Going back to the Dealership Tuesday morning, but we need a RELIABLE 4WD where I live here in Canada, hence why we bought it ?
I had that problem in November '19. I brought it in and they did software updates. It happened again today. It only happens when it has been in 4Low for awhile. It is really aggravating to be in the middle of difficult terrain and lose all 4WD capability.
 

·
Registered
Joined
·
1 Posts
Thank you to all who have posted. Yesterday I had the "Dynamic Steering Torque Service Required, Service ESC System, & Service Hill Start System" warnings come after my car slipped a little in a slushy pothole. It's a 2017 Renegade Latitude with 10800 miles. I called the dealership and they had me go out and start it and the warnings were still there so I made an appointment. I went out this afternoon to drive the ¼ mile to my mailbox and when I got back home the warnings were gone. I guess I'll wait a couple of days and see what happens before I cancel the appointment.
 

·
Registered
Joined
·
1,581 Posts
Welcome to the forum, Definitely wait before you cancel the appointment, the warnings could come back on. Usually if the warning lights are out when you take it in they will probably say it is ok. If the lights come back on I would drive by the dealership to show them what is going on while they are on.
 

·
Registered
Joined
·
4 Posts
I'm sorry to hear your wife experienced this. If I can assist in getting your Renegade back to the dealership, please let me know.

Kori
Jeep Social Care Specialist
Bought a BRAND NEW Renegade North 4X4 Last Friday, drove 190 miles home so now total 256 miles on it as it had been out for a few "test drives" as I was told at the Dealership, the next day being Saturday I went to go to the store for Milk and there is NO 4 WD, the 4WD light won't come on nor will the selector move to "snow"(we have a foot of the fresh stuff), it just stays in "Auto" with only FWD and gets stuck, and now it is showing errors on the dash as follows:
* Dynamic Steering Torque Service Req'd
  • Service ESC System
  • Service Hill Start System


What gives here ?
Is this a common problem with Renegades ?
Has anyone else here experienced this problem with their BRAND NEW Renegade and if so what was the fix ?

Going back to the Dealership Tuesday morning, but we need a RELIABLE 4WD where I live here in Canada, hence why we bought it ?
2018 Jeep Renegade Latitude 4x4..Exact same issues..did it to me with 86 miles and now at 16,500
 
21 - 40 of 74 Posts
Top