Jeep Renegade Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2015 renegade latitude with the 1.4 and 6 speed, it has around 3600 miles on it. I randomly get the service parking brake, service power steering, and check engine light coming on. I also notice that the radio and bluetooth are quirky. We joke and say that she has a mind of her own. When these lights come on, usually turning the car off and back on will make them disappear. Sometimes they return other times they do not. I finally took it in for service and of course there were no lights on at that time or for weeks prior. They scanned and drove the car with no problems, however did the appropriate updates. After leaving the dealer and getting 2 miles down the road, the service parking brake light came on. I turned around and went back to the dealer and asked them to scan it while it was running, because I was afraid that the light would go off if they shut the car off. It threw a code for a clutch switch which according to the repair chart from jeep requires a brake switch to be replaced. They have ordered it and will let me know when it comes in, I will update everyone once that happens. The service adviser told me that these cars are so new that they are learning about them as we go, so fingers crossed. I am hoping that this does not turn into a lemon case. Anyone else have these issues going on?
 

·
Registered
Joined
·
125 Posts
I have a 2015 renegade latitude with the 1.4 and 6 speed, it has around 3600 miles on it. I randomly get the service parking brake, service power steering, and check engine light coming on. I also notice that the radio and bluetooth are quirky. We joke and say that she has a mind of her own. When these lights come on, usually turning the car off and back on will make them disappear. Sometimes they return other times they do not. I finally took it in for service and of course there were no lights on at that time or for weeks prior. They scanned and drove the car with no problems, however did the appropriate updates. After leaving the dealer and getting 2 miles down the road, the service parking brake light came on. I turned around and went back to the dealer and asked them to scan it while it was running, because I was afraid that the light would go off if they shut the car off. It threw a code for a clutch switch which according to the repair chart from jeep requires a brake switch to be replaced. They have ordered it and will let me know when it comes in, I will update everyone once that happens. The service adviser told me that these cars are so new that they are learning about them as we go, so fingers crossed. I am hoping that this does not turn into a lemon case. Anyone else have these issues going on?
Wonder why they didn't order you a clutch switch. Weird.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top