Jeep Renegade Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
So, I had a scary experience this morning. Starting driving, noticed the Renegade was staying a 4500 rpms! Still driving fine, thought there might be something strange with the transmission, move the shift so that I can up or down shift and discovered it was stuck in 3rd gear.

As the "Service Engine" lights and messages start going off.

Brought it to the dealer a couple of hours later (had to wait that long), by which point the transmission was working again and the Service Engine had disappeared.

Still three software updates were identified by the service department, who installed them. One was for the transmission, it's actually working better now. One was for the engine, don't know for what. And one was for the display.

Now... the guides in the rear view camera while in reverse have disappeared.

Help? I know other people have had this problem, but I couldn't find any solutions.
 

·
Registered
Joined
·
2 Posts
So, I had a scary experience this morning. Starting driving, noticed the Renegade was staying a 4500 rpms! Still driving fine, thought there might be something strange with the transmission, move the shift so that I can up or down shift and discovered it was stuck in 3rd gear.

As the "Service Engine" lights and messages start going off.

Brought it to the dealer a couple of hours later (had to wait that long), by which point the transmission was working again and the Service Engine had disappeared.

Still three software updates were identified by the service department, who installed them. One was for the transmission, it's actually working better now. One was for the engine, don't know for what. And one was for the display.

Now... the guides in the rear view camera while in reverse have disappeared.

Help? I know other people have had this problem, but I couldn't find any solutions.
Check your Uconnect programmable settings to make sure the lines have not been programmed to off. Check your Uconnect settings in your manual if this is not clear and probably not. I don't have a Renegade but just looking and have a KL and if you have the same set up I do--it may just be that simple. Simpler is to take it back to the dealer and let them check it.
 

·
Registered
Joined
·
1,266 Posts
skoterbay,

Below are instructions on activating the backup camera active guidlines from pages 611 and 614 of the Owner's Manual. Hope this helps!

Safety & Driving Assistance
After pressing the “Safety & Driving Assistance” button
on the touchscreen the following settings will be available:

• ParkView® Backup Camera Active Guidelines — If Equipped
Your vehicle may be equipped with the ParkView® Rear
Back Up Camera Active Guidelines that allows you to see
active guidelines over the ParkView Back up camera
display whenever the shift lever/gear selector is put into
REVERSE. The image will be displayed on the radio
touchscreen display along with a caution note to “check
entire surroundings” across the top of the screen. After
five seconds, this note will disappear. To change the
Active Guideline Status, press the “Active Guidelines”
button and select the “On” or “Off” button. Press the
back arrow/Done button on the touchscreen to return to
the previous menu.
 

·
Super Moderator
Joined
·
3,685 Posts
Default mode is reverse guides off. It is one of those settings that don't persist through firmware updates.

Although I haven't tested it since I got updates, apparently it also gets turned off as well by trying to configure the 7" display in the trailhawk while moving.
 

·
Registered
Joined
·
261 Posts
I also have had issues with them turning themselves off for no reason. Dealer did a software update and hasn't happened since, but was only intermittent before so we'll see.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top