Jeep Renegade Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I bought my Renegade on Saturday and on Monday night driving to work I lost all RPMs and when you hit the gas pedal nothing happened. The check engine light came on and coasted to the side and put it in park; after restarting it I was able to make it to work. I took it to the dealership and they had it all day tuesday and called to tell me nothing was wrong with the car so I could pick it up. On my way home from the dealership it did it again. Anyone know what might be causing this because they seem to think my car is just fine? It only has 100 miles on it.
 

·
Registered
Joined
·
753 Posts
I'd take it back, be adamant about them keeping and driving it until they figure it out. Get a loaner while you wait.
^ second that ^

There's a number of TSBs (Technical Service Bulletins) listed on the forums:

http://www.jeeprenegadeforum.com/forum/522-tsbs-recalls/

It's possible your Renny needs one or more updates.

But again, the dealer shouldn't be giving it back without fixing something. There's most certainly an error code stored in the computer - unless they simply cleared it and kicked it back out the door.
 

·
Super Moderator
Joined
·
3,600 Posts
Take it back and don't accept an answer that says there is no problem.

For you own peace of mind though, I'd pop the hood and check how well attached the negative battery cable is. If it is really loose, you can wind up with intermittent loss of ground, which can stall out the engine. IT can happen without a code being set.

Another no code possibility is the improperly attached tube to the vapor recovery cannister. Lots of people had rough idle from that and stalling out when topped up. If your dealer was like mine, they filled up the tank before giving you your car. Most people with that problem had no codes stored because none of the senors are showing anything out of spec. The leak it causes get unmetered air into the system which the car doesn't know about.
 

·
Registered
Joined
·
1 Posts
You are not alone!

Got a 2016 Jeep Renegade with 600 miles from Enterprise Rent a Car because our Toyota Sequioa was getting repaired. I drove it to work in the morning and everything was fine. Leaving work was a different story. I started the car, everything seemed fine until I tried to excellerate turning left to get out of the parking lot. I pushed the gas all the way down and was able to "speed up to 25mph. The Service Engine light was on all through this ordeal. I was able to drive it to the nearest Enterprise, which was thankfully only 1/2 mile away and exchanged it for a Camry.

Enterprise checked it out and drove the jeep and returned to tell me it is running fine. I showed them the picture I had taken of the dashboard with Service Engine light on, after the third or fourth time of restarting the jeep.

You are NOT crazy. I am just lucky that it was just a rental though.
 

·
Registered
Joined
·
580 Posts
An ICE needs three things to run: gas, spark and air. Without one of those it's a no-go. It's safe to say the problem you experienced is due to an interruption or malfunction having to do with one of those three basic needs.

If it's an intermittent electric bug, it is probably hard to track down due to lack of symptom until the malfunction occurs. Could be a sensor (MAP, IAT, CTS etc). If the stalling were to occur at idle, I'd suspect a defective ICV valve. It could be a wonky ignition switch. Maybe a bug in the ECU. I guess it could be intermittent fuel pump failure.

If you noticed total lack of power (no dash lights, no interior lights), a bad ground or battery connection could be at fault.

Since sudden loss of engine can be lethal, you have to insist the dealer find and fix the problem.
 

·
Registered
Joined
·
2 Posts
I bought my Renegade on Saturday and on Monday night driving to work I lost all RPMs and when you hit the gas pedal nothing happened. The check engine light came on and coasted to the side and put it in park; after restarting it I was able to make it to work. I took it to the dealership and they had it all day tuesday and called to tell me nothing was wrong with the car so I could pick it up. On my way home from the dealership it did it again. Anyone know what might be causing this because they seem to think my car is just fine? It only has 100 miles on it.
 

·
Registered
Joined
·
1 Posts
I bought my Renegade on Saturday and on Monday night driving to work I lost all RPMs and when you hit the gas pedal nothing happened. The check engine light came on and coasted to the side and put it in park; after restarting it I was able to make it to work. I took it to the dealership and they had it all day tuesday and called to tell me nothing was wrong with the car so I could pick it up. On my way home from the dealership it did it again. Anyone know what might be causing this because they seem to think my car is just fine? It only has 100 miles on it.
It can possibly be the pedal assembly, computer, accelerator pedal or something else.
My mom’s had this problem and it was the accelerator pedal. But I can tell you, Jeep Renegades are having tons and tons of issues. If you do a google search, you will be shocked with all that’s wrong with them. My mom has had to have so many repairs, it’s ridiculous. And hers is only a 2018-not very old. She has had problems from the start with this. And they are notorious for burning through oil at a ridiculous rate.
 

·
Registered
Joined
·
669 Posts
I bought my Renegade on Saturday and on Monday night driving to work I lost all RPMs and when you hit the gas pedal nothing happened. The check engine light came on and coasted to the side and put it in park; after restarting it I was able to make it to work. I took it to the dealership and they had it all day tuesday and called to tell me nothing was wrong with the car so I could pick it up. On my way home from the dealership it did it again. Anyone know what might be causing this because they seem to think my car is just fine? It only has 100 miles on it.
did anyone check the oil level??
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top