Jeep Renegade Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #1 ·
I have only had my TH 2 days and am concerned the security alarm is not working. I was told I need to do nothing to set it, but it concerns me that it is that easy to use. I read the book, on page 13 and it states a light on the panel is to blink 16 times and mine does not do that. Can someone explain or point to a video or something of what to do and what I should be seeing when it is set properly.

Thanks in advance,

Mickee
 

·
Registered
Joined
·
184 Posts
I just tried to post the procedure from the owner's manual, that I downloaded from the internet; but, it got all mangled. Look up Vehicle Security Alarm in your manual. There are a number of steps to follow.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #3 ·
Thank you. That is what I am doing but I just fear it is not setting. I don't see a light on the panel flashing at all, I also do not hear a chime. I wonder if I went out and tried to open it without the keyfob if it would alarm? I just hate to get it going and then I can't stop it easily either.

Mickee
 

·
Registered
Joined
·
184 Posts
In the 2015 manual, it shows the light at the bottom of the tachometer. I haven't set mine yet; so, I don't know if that is actually where the light is.

Is this the procedure you have in your manual?

1. Push interior lock button on driver or passenger door (with door open).
2. Push lock button on door handle (passive entry system).
2A. Push lock button on remote for Remote Keyless Entry (RKE) system.
 

·
Registered
Joined
·
184 Posts
I just checked my Limited; I'm pretty sure there is no alarm system. There is no light that blinks. I also checked the window sticker from my Jeep, and there is no alarm listed. Does your sticker show an alarm?
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #6 ·
Yes, my window sticker shows I have the alarm. The salesman said just lock it normally but I don't think that works for the alarm. I did do the steps in the book and did not see anything flash. I saw on the diagram where the indicator light should be but it did nothing. I may just take it back to the dealership and say - show me how it works and prove to me that it does work. Thanks for your help.

Mickee
 

·
Registered
Joined
·
56 Posts
Yes, my window sticker shows I have the alarm. The salesman said just lock it normally but I don't think that works for the alarm. I did do the steps in the book and did not see anything flash. I saw on the diagram where the indicator light should be but it did nothing. I may just take it back to the dealership and say - show me how it works and prove to me that it does work. Thanks for your help.

Mickee
Hi Mickee,

Keep us posted on what the dealer has to say.

Thank you,

Kathleen
Top Care Specialist
FCA Canada
 

·
Registered
Joined
·
112 Posts
I have the alarm and there is a red light in the cluster that blinks continuously, not the 16 times like the manual says, but it will blink forever like a normal alarm system?

I think the only way to truly know if it works is sit inside the car, with the keyfob outside the car at least 5 feet away from the sensors and then open the door from the inside?
 

·
Registered
Joined
·
1,221 Posts
I have the alarm and there is a red light in the cluster that blinks continuously, not the 16 times like the manual says, but it will blink forever like a normal alarm system?

I think the only way to truly know if it works is sit inside the car, with the keyfob outside the car at least 5 feet away from the sensors and then open the door from the inside?
Have you tested it with this method, Mead? If you are concerned that it may not be working, I would recommend a trip to the dealership. I can assist in scheduling an appointment if you PM me your info on here.
 

·
Registered
Joined
·
112 Posts
Have you tested it with this method, Mead? If you are concerned that it may not be working, I would recommend a trip to the dealership. I can assist in scheduling an appointment if you PM me your info on here.
It worked I was able to set off the alarm from the inside. Thanks for the concern and helpfulness.

Here's what happened. I unlocked the door and put the key fob about 10 feet away from the Jeep. Then I got inside, closed the door and push the power lock button. The cluster red alarm light began flashing. About 10 flashes I open the door and the alarm went off.

Once I got back in the car I noticed the overhead console LEDs were red. I also got a 'broken in' message in the center cluster. Finally I received a Uconnect email saying my alarm went off. This is so cool.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #11 ·
I am definitely going to give that a try in the morning. I have not seen any red light flashing at all. I have followed every step in the owners book as well as everything suggested on here until I just saw this one about testing it out by getting inside of it. I am excited to try this. I already have an appointment with the dealer on another issue and if I cannot get the alarm to work I will definitely bring it to their attention at that appointment.

One question though. After you set the alarm off, how did you get it to stop?

Million Thanks for all the help,

Mickee
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #13 ·
My alarm went off today and it was not a planned exercise. I had no idea how to shut it off and got no e-mail or message when entering the car. Why would I not get notification??

Mickee
 

·
Registered
Joined
·
112 Posts
Mickee, did you register your Jeep to the Uconnect access? If your are in the USA you have a one year subscription to Uconnect access.

http://www.driveuconnect.com/features/uconnect_access/registration/

With this service you can remotely start, lock and unlock your Jeep and also get notifications including a alarm set off. To get notifications you need to link your Email and phone. The notifications could take a few minutes.

Sorry to hear of your alarm setting off. To turn it off, press the unlock button on the keyfob.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #15 ·
Yes I did register with uconnect. In fact I just got off the phone with them and they said everything appeared to be working fine and that I was not supposed to get any kind of alert, e-mail or anything when the alarm goes off, that it just goes off and that is it.

Mickee
 

·
Registered
Joined
·
112 Posts
Mickee, ok I snooped around the uconnect access website https://www.moparownerconnect.com/Pages/global.aspx#

and could not find the notification option to email or text. However I am using the Uconnect mobile app for android and I have those options. If you're not using the mobile app I highly suggest you use it. In addition to remotely starting and unlocking your Jeep and getting alarm notifications...

... you can also send destinations to your Nav from your phone. Example, in the phone's map, locate the Starbucks you want and send it to your Jeep. It's that easy, no more voice or typing in Uconnect. Also you can locate your Jeep in the crowd. I hope this helps

Also did you sort out your alarm? are you getting the flashing red light? try sitting in it like I did.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #17 ·
Mead:
Yes, the alarm is working fine now. I didn't sit in but, when I lock it, before shutting the door, I looked for the red flashing light and I did get it. The alarm went off around 8 a.m. and when I got in the Jeep, after being in and out of it all day long, at 10 p.m. I get the notification that an break in had been attempted. That is when I called to verify that I was registered and all was working. They said, yes, I was registered but I should not receive notifications of any sort about a potential break in. I do have the mobile app and checked it today to be sure the setting were set and they are. I even added my phone # so I can get a text about it. I fear it will go back to the shop for some adjustments of some sort as I am having a few other issues, already.

Mickee
 

·
Registered
Joined
·
1,221 Posts
It worked I was able to set off the alarm from the inside. Thanks for the concern and helpfulness.

Here's what happened. I unlocked the door and put the key fob about 10 feet away from the Jeep. Then I got inside, closed the door and push the power lock button. The cluster red alarm light began flashing. About 10 flashes I open the door and the alarm went off.

Once I got back in the car I noticed the overhead console LEDs were red. I also got a 'broken in' message in the center cluster. Finally I received a Uconnect email saying my alarm went off. This is so cool.
I'm happy to hear everything worked well for you!
 

·
Registered
Joined
·
1,221 Posts
Mead:
Yes, the alarm is working fine now. I didn't sit in but, when I lock it, before shutting the door, I looked for the red flashing light and I did get it. The alarm went off around 8 a.m. and when I got in the Jeep, after being in and out of it all day long, at 10 p.m. I get the notification that an break in had been attempted. That is when I called to verify that I was registered and all was working. They said, yes, I was registered but I should not receive notifications of any sort about a potential break in. I do have the mobile app and checked it today to be sure the setting were set and they are. I even added my phone # so I can get a text about it. I fear it will go back to the shop for some adjustments of some sort as I am having a few other issues, already.

Mickee
What else will you be having the dealership look into? When is your appointment?
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #20 ·
Well....I had the Jeep in today as they had put deep scratches in the dash and on the plastic door panels behind the seats when they changed my seats out. So they replace about 4 sections of molding. I asked them to check the blinking odometer and they looked at me like I was nuts. But when they got in the Jeep and saw what I meant they did try to research it. They said they had never come across that issue before, which is very hard for me to believe. I still have the blinking odometer. The Security alarm does work now too. So pretty much all is well.

Mickee
 
1 - 20 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top