Jeep Renegade Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
So I've had my 2015 Jeep Renegade since September of last year. My subwoofer blew out and the dealer had it for a week. My rotors went bad and they had it for 2 days. My latest issue is the SERVICE ENGINE SOON light comes on the the mileage keeps decreasing. So I took it in last Monday around noon to the dealer I bought it from the service woman looked puzzled and asked me to leave it and get a loaner. I called Wednesday and got no response. I was told to stay in the loaner. I called Friday and was told my technician was off and I'd get a call Saturday. Saturday afternoon I got a call saying my car was ready. I got there and she explained that I needed major updates and they didn't know what the messages meant. So they had to contact Jeep to figure out the problem. My Jeep only has 8,093 miles on it by the way. After putting the updates in the message went away. I got in, drove home no problems. I drove Sunday. No problems. I get in today which is Monday and the message is popping back up. I'm wondering if anyone else might be having the same issues. I guess I'll be heading back to the dealer tomorrow. Summers in Chicago aren't long and I haven't really had a chance to enjoy my Jeep due to cold weather and it being in the shop. Help me please!!!!!
 

·
Super Moderator
Joined
·
4,902 Posts
We have Service Engine in 6 days it started at 30 and our dealer said to bring it in when it hit 0..


 

·
Registered
Joined
·
1 Posts
2015 Trailhawk, I had a similar situation, In my case I let it run down to zero days before bringing it in. Then the message was something like "perform service"

The dealership did a lot of software updates, and were unable to clear it. They finally ended up replacing the battery and were able to clear the problem. I checked OBD II beforehand and did not see any codes.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #6 ·
So I took it in this morning. When I got there they told me it would only take 5 minutes to reset it. They said that the ticket was still open from when it was there last. So it made the message stay coming up. They closed the ticket and brought me back the car and said everything was fine. I got in and started it and the same message showed up. They ended up giving me a loaner for the day. I just picked it up and the service engine soon message is gone but I don't know what they did because my service person was gone for the day. I'll try tomorrow to contact them to see exactly they had to do.
 

·
Registered
Joined
·
5 Posts
Bought my Limited Renegade back in April 2016....

2500KMs later, "Service Engine" light comes on, and the entire truck starts to shake for about 20 minutes or so, right after it started. Bring it to the dealer where is stays for the next couple days - they replace the Multi-Air on it. The following days I notice the light is back but does not shake... Wondering WTF is going on? I finally start it up one day, and boom! the same exact thing happens so I bring it right back to the dealer. This time they replace the PCM and reprogram the entire computer. Drive it back home where its okay for about a week. Guess what? @ 3300KMs, same thing happens - truck shaking terribly for about 20 minutes after cold start (sitting for about 24 hours) bring it back to the dealer for a 3rd time and now the mechanics seem to have no idea what is going on... I am now waiting for them to "try" something on it and tell me they "fixed" it - and for me to bring it right back to them, again...

Called FCA to open up a case and submit a formal complaint seeing it only has 3500KMs - very discouraged, not sure what else I can do.. Any advice?
 

·
Super Moderator
Joined
·
4,902 Posts
Yesterday It went to the dealer and they used the starscan on it to reset it. Now it show the count down at 365 days till service again.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top