Jeep Renegade Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello,

I am hoping someone can help.

I have been having an issue with my 2015 Jeep Renegade

Lately intermittently it seems as if my jeep is almost singing to me. there is a high pitched noise that increases and decreases when I accelerate or decelerate.

I have taken it to the dealership and they can't seem to find the noise.

Any ideas as to what it could be?

any help would be appreciated
 

·
Super Moderator
Joined
·
3,600 Posts
Hello,

I am hoping someone can help.

I have been having an issue with my 2015 Jeep Renegade

Lately intermittently it seems as if my jeep is almost singing to me. there is a high pitched noise that increases and decreases when I accelerate or decelerate.

I have taken it to the dealership and they can't seem to find the noise.

Any ideas as to what it could be?

any help would be appreciated
A whining noise? Perhaps traveling about 20-30mph?

Next time it happens, try disengaging traction control and see if it stops within about 1.5 seconds.

Other than that possibility, I'd suggest recording it and posting it. The only thing on a car I might describe as singing that wouldn't result in an immediate diagnosis of something wrong is a turbo spooling up.
 

·
Registered
Joined
·
210 Posts
I've heard similar or identical, but it doesn't seem to be anything harmful. I took it to be a combination of my (non stock) tires at certain speeds combined with engine noise....I have no grinding, rumbling, or vibrating that is unusual, so I don't think much of it, and only hear it now and then. Perhaps we all need to note the road conditions and speed when it occurs?
 

·
Registered
Joined
·
89 Posts
https://www.dropbox.com/s/a8ufmp1t028uruw/Video Feb 25, 6 19 45 PM.mov?dl=0

Had similar today, going between 60 and 65, it went away when I stopped at the stop light and I had to reach 70 mph to get it again, tried switching to manual and it didn't stop, forgot to try switching off the traction control. Any ideas? I'm at almost 18k miles and have driven at all speeds and today is the first time this has happened
 

·
Registered
Joined
·
89 Posts
It's still doing it today, after further investigation I think my air filter cover may be loose and the noise is wind whistling through the air filter cover. I'm going to tighten it up when I get home today and test it out. Hoping it's nothing too serious. I did try switching the Traction Control off on the way to work this morning, but it didn't affect the noise at all.

Let me know if you guys think of anything

-BP
 

·
Registered
Joined
·
182 Posts
I think having the year, model , engine, transmission option would be nice on their "signature" so people can diagnose quicker from that...
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top