Jeep Renegade Forum banner
1 - 20 of 20 Posts

· Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
Here is my timeline of how Jeep and FCA handles the issues that started after 1 day of ownership..... :(

Day 1: Wednesday 05/20/2015
Took delivery of 2015 Renegade Trailhawk that I spec'd out and the dealer located for me: Glacier Metallic with Cold Weather Group and preferred equipment package. I assumed the 4WD was working so I did not check it on delivery.

Day 2: Thursday 05/21/2015
Driving to work and "Service Engine" light comes on. Mileage about 115mi on the Odometer. Took vehicle over to dealer at lunch. Tech worked on it for 2 hrs. He said it was throwing a bunch of codes and I would need to drop it off next week and leave it for the day so he could do updates. None of the codes appeared to be safety related so the tech said I could drive it over the long weekend.
So, I made the appt and drove it as suggested.

Day 3: Friday 05/22/2015
I decided to test the 4WD system by chance and discovered the that the 4WD only will stay in Auto mode, and kicks back instantly into auto mode when trying to switch to any other mode. Plus the 4WD lock does nothing as well. I immediately called the dealer and had them add a notation to my open repair ticket that the 4WD wasn't working at all.

Day 4: Saturday 05/23/2015
I called the dealership to express my displeasure, and just happened upon the General Manager. He was very sympathetic and apologetic, and assured me the dealership would do whatever it takes to make it right. He said he would call at 9am on the next business day (IE, the day after Memorial day), and he did as promised. He said he talked to the owner of the dealership and informed him of the situation, and the owner is on-board in regards of doing whatever it takes to make it right.

Day 7: Tuesday 05/26/2015
Dropped off vehicle at 12 noon, and the gave me a loaner to drive. The normally do not have loaners and made in exception since my car was so new. They now have the car and I hope they can fix it quickly. I miss driving the Trailhawk!

More to follow......




 

· Registered
Joined
·
953 Posts
Well, that is not the best story to tell. It does seem like the dealer has given pretty good customer service given the circumstances though.

So sad that it had problems right from the start though. I really wish that FCA would tackle this problem they have with build quality. It really is weighing them down.
 

· Registered
Joined
·
24 Posts
Discussion Starter · #4 ·
The dealer has given me great customer support so far. The loaner I was given is a "Land Yacht" LOL!
A behemoth Chrysler Town and Country in a lovely black metal flake paint! It looks like something a Funeral Home Director would drive! Oh well...Beats walking or driving a Fiat 500!

-Keith
 

· Registered
Joined
·
24 Posts
Discussion Starter · #7 ·
Day 8: Wednesday 05/27/2015
Technician called and said I need a Drive Module...I think he meant Drive Control Module. He ordered it and it should be in tomorrow...Keeping my fingers crossed that this will fix it...

So I guess I'm driving the "Hearst" another day! LOL!

More to follow......
 

· Registered
Joined
·
831 Posts
Day 8: Wednesday 05/27/2015
Technician called and said I need a Drive Module...I think he meant Drive Control Module. He ordered it and it should be in tomorrow...Keeping my fingers crossed that this will fix it...

So I guess I'm driving the "Hearst" another day! LOL!

More to follow......
the Drive Control Module is specific to the 4WD system correct?
 

· Registered
Joined
·
24 Posts
Discussion Starter · #11 ·
Day 10: Friday 05/29/2015
The service Manager called me at 5pm today and gave me an update about my vehicle. The Tech was able to get the new AWD module and software working, and all modes of 4WD and AWD are working as expected. Also the service engine is off and seems to be staying off... The only glitch they can see id that the trip odometer is reading 800 miles, but there is less than 400 miles on the car. Chrysler Tech Support has not seen this, and it is unique to my vehicle. Chrysler Engineering is working diligently to find and fix this, and hopefully will have a solution on Monday....

I'm keeping a positive outlook that it will be resolved and I will be driving in my Trailhawk again early next week...:|

More to follow...
 

· Registered
Joined
·
24 Posts
Discussion Starter · #13 ·
I'm glad to hear that your Trailhawk is problem free after all that.....This gives me hope all will be well with mine...

If you don't mind, Could you please describe the symptoms your vehicle was having, and also the root cause? This will be helpful to other Renegade owners....

Thanks for the good news!

Best regards,
-Keith
 

· Registered
Joined
·
24 Posts
Discussion Starter · #15 ·
I really love my Trailhawk now!

Day 15: Wednesday 06/03/2015
Chrysler Engineering has yet to find a solution for my Odometer calibration issue. The service manager suggested I return the rental and pick up my Trailhawk and use it. He will call me when they have a solution and I can drop it off so they can recalibrate it.

The drive-ability of my Trailhawk is much better with the Transmission software updates. Smoother shifting and better gear selection going up and down hills....Also the AWD/4WD is working great, and I tried it out on some gravel roads on my commute home....I really love my Trailhawk now! :laugh:
 

· Registered
Joined
·
2 Posts
Here is my timeline of how Jeep and FCA handles the issues that started after 1 day of ownership..... :(

Day 1: Wednesday 05/20/2015
Took delivery of 2015 Renegade Trailhawk that I spec'd out and the dealer located for me: Glacier Metallic with Cold Weather Group and preferred equipment package. I assumed the 4WD was working so I did not check it on delivery.

Day 2: Thursday 05/21/2015
Driving to work and "Service Engine" light comes on. Mileage about 115mi on the Odometer. Took vehicle over to dealer at lunch. Tech worked on it for 2 hrs. He said it was throwing a bunch of codes and I would need to drop it off next week and leave it for the day so he could do updates. None of the codes appeared to be safety related so the tech said I could drive it over the long weekend.
So, I made the appt and drove it as suggested.

Day 3: Friday 05/22/2015
I decided to test the 4WD system by chance and discovered the that the 4WD only will stay in Auto mode, and kicks back instantly into auto mode when trying to switch to any other mode. Plus the 4WD lock does nothing as well. I immediately called the dealer and had them add a notation to my open repair ticket that the 4WD wasn't working at all.

Day 4: Saturday 05/23/2015
I called the dealership to express my displeasure, and just happened upon the General Manager. He was very sympathetic and apologetic, and assured me the dealership would do whatever it takes to make it right. He said he would call at 9am on the next business day (IE, the day after Memorial day), and he did as promised. He said he talked to the owner of the dealership and informed him of the situation, and the owner is on-board in regards of doing whatever it takes to make it right.

Day 7: Tuesday 05/26/2015
Dropped off vehicle at 12 noon, and the gave me a loaner to drive. The normally do not have loaners and made in exception since my car was so new. They now have the car and I hope they can fix it quickly. I miss driving the Trailhawk!

More to follow......




so what ever happened with this issue? I'm having same/similar failure mode with my vehicle and after 4 times at dealer where they've changed driver control module and did a bunch of software updates - issue still present? Any thoughts?
 

· Registered
Joined
·
1 Posts
I have a 2019 Renegade, and yesterday it started showing me the Swerve 4WD Not Available when I turned it on. Couldn't find that listed in the owner's manual, so I hit up the internet. So far, I haven't noticed any issues with the smoothness of the drive/ride, no issues changing gears. It just makes a loud alert noise, flashes that warning, then the SWRV 4WD light in red stays on the whole time I'm driving and it won't let me manually put it into any 4WD option (snow/mud/etc.)

I am still under warranty from my dealership and it is due to go back for a Recall Notice. I think I may just park it till it's appointment and ask the dealership What The Heck when I get there. [Thankfully, I still have my old truck]
 
1 - 20 of 20 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top