Jeep Renegade Forum banner
1 - 20 of 41 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
I just purchased a 4x4 Latitude - less than 300 miles on the car. My wife is the primary driver, and I rarely listen to the radio, so I hadn't noticed anything, but my wife points out to me that the front passenger door speaker is fading in and out and buzzing. It sounds like someone blew the speaker. Definitely wasn't us. I'm taking it in tomorrow to see what the dealer says. I was wondering if anyone else has had problems with their speakers (I apologize if this has already been addressed in a different thread, but I did not see it anywhere).
 

·
Premium Member
Joined
·
916 Posts
Is there a indicator light in the instrument panel that looks like a speaker with a line across it? There was another member that was inquiring what the icon was and it turned out that he had blown his speaker and the icon was telling him that it was not working. So I wonder if you have that same icon showing up on the instrument panel.

TS
 

·
Registered
Joined
·
15 Posts
They ordered a new speaker. Power door lock issue is more of a concern to me now.
I'm having the exact same issue after having it for a month. Speakers were amazing until a few days ago. Do you know how much they charged? Did you have to pay for it or was it covered? Thanks.
 

·
Registered
Joined
·
13 Posts
Drivers side speaker

I have the same issue. Within the first 100 miles I started hearing crackling from the stereo. I adjusted the fader/balance control to each speaker and found that the front drivers side speaker was cutting out bad, and sounded like crap. Brought it back to the dealer and they ordered a speaker to replace the malfunctioning one. I will update after they install it and let everyone know what the problem was. To me it sounds like a wiring issue. Sounds like one of the connections isn't fully "connected".
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #12 · (Edited)
Ok, I'm back. Sorry I didn't see the last reply. Its been 5 months since I got the Renegade and still having the speaker issue. I first took it in about a week after I got the vehicle in May. They told me they had to order a new speaker (which would take a while because it comes from Italy).

August rolls around, still haven't heard anything. I call the dealership up and they are like "oh, bring it in tomorrow." Ok so if they had the speaker there, why didn't they call to tell me its in? How long were we driving around with a buzzing speaker with the replacement sitting in the dealership? Anyways, I take it in .. they tell me they replaced the speaker, everything is fine. I drive it home, don't notice it buzzing.

Now my wife tells me the speaker is buzzing again, this time worse than before. I'm taking the vehicle in next Tuesday. At this point I'm thinking the best course of action is a whole new stereo if they already replaced the speaker and it is still buzzing (I should have asked to see the box or something to confirm they actually replaced it ... my problem is I'm always too nice about things like this instead of being firm about it).

I'm kind of ticked because I have brought it in twice but the first time they gave me no documentation whatsoever so I can't count it towards the 3 strikes for the lemon law. We will see what happens.
 

·
Registered
Joined
·
1,624 Posts
Maybe they didn't really replace the speaker. Could it be that they fiddled with it and it temporarily stopped buzzing and just told you that they replaced it?
 

·
Registered
Joined
·
210 Posts
I'm not an expert, but I am a "radio person." (collecting them, broadcasting, etc.)

Part of the reason speakers may blow so much could be the delayed response of the volume control when the UCONNECT is booting! You can be turning UP the volume, and there's no response, so you continue...then it catches up and BAM! A shot of "noise" to any and all speakers. Definitely a Uconnect design/software flaw.....and it can blow speakers easily, even if you don't remember doing this, it probably happened at one time or another. I've gotten used to turning DOWN the system when I shut the car off and waiting for full boot before turning it on.

Maybe? Possibly? A common thread in all these incidents?

Speakers do NOT like shots of audio suddenly, even if they're highly (wattage) rated. That's like shooting 'em with high voltage.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #17 ·
As far as we know, we never blew the speaker ... I'd remember getting my ear drums blasted. Not to say someone else didnt before we got it ... The "2nd" speaker they allegedly replaced thr fiest with should have been fine. We will see what happens.
 

·
Registered
Joined
·
212 Posts
Haven't noticed any speaker issues but twice this morning the speaker with the line across came on and the message said "Sound System Unavailable" eventually the radio came back on and the light went off.

Completely unrelated (I think) my exterior light warning light came on and we did a visual inspection of ALL THE LIGHTS and all worked fine... ??? Maybe an instrument cluster glitch?
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #20 ·
It's funny ... I mean I get the whole "its a new model and will have bugs" thing... But there's just a lot of weird things going on with these Renegades. I wonder if we look on the Honda HRV forum if there are this many posts with goofy problems ... At least I like the Renegade enough to put up with it .. For now
 
1 - 20 of 41 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top