Jeep Renegade Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
So, I start the Renegade and go to type in an address on the Nav screen when the screen suddenly goes black. Buttons don't work. Turning the radio off and on doesn't work. I get the initial welcome screen then it goes back to black again. Turning the vehicle off and on... also no joy.

I took it to the dealer. The guy who checked me in saw the radio was on, but the screen was black. They took it back to the service area but by the time the tech got to look at it, for some reason it started working again. They checked and found codes and no updates required.

So, I'm back to "if it happens again, bring it in" but otherwise there's nothing to fix.

A little over 1500 miles in.
 

·
Registered
Joined
·
100 Posts
What UConnect you have ?
I have 5.0. Something similar happened first at 2000 miles, after few minutes it started to work again, but one month later it happened again. Screen didn't work, only Jeep logo showed and radio played last station before break down. No response on any button. When put in reverse, rear view showed, but didn't turn off when driving.

Dealer replaced UConnect unit.
 

·
Registered
Joined
·
1,213 Posts
What UConnect you have ?
I have 5.0. Something similar happened first at 2000 miles, after few minutes it started to work again, but one month later it happened again. Screen didn't work, only Jeep logo showed and radio played last station before break down. No response on any button. When put in reverse, rear view showed, but didn't turn off when driving.

Dealer replaced UConnect unit.
Have you experienced any issues since? - Kevin T, Social Connect Team
 

·
Registered
Joined
·
1,213 Posts
So, I start the Renegade and go to type in an address on the Nav screen when the screen suddenly goes black. Buttons don't work. Turning the radio off and on doesn't work. I get the initial welcome screen then it goes back to black again. Turning the vehicle off and on... also no joy.

I took it to the dealer. The guy who checked me in saw the radio was on, but the screen was black. They took it back to the service area but by the time the tech got to look at it, for some reason it started working again. They checked and found codes and no updates required.

So, I'm back to "if it happens again, bring it in" but otherwise there's nothing to fix.

A little over 1500 miles in.
Is this the first time that this has happened? - Kevin T, Social Connect Team
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #5 · (Edited)
Yep. First time for the screen going blank. I haven't used the Nav since, but the radio screen seems to be working.

The only other issue has been the Assist and 911 lights which keep turning red. When the screen went blank yesterday I tried the Assist button but it didn't work. It did make me think about whether the 911 button will work if I ever need it.
 

·
Registered
Joined
·
1,213 Posts
Yep. First time for the screen going blank. I haven't used the Nav since, but the radio screen seems to be working.

The only other issue has been the Assist and 911 lights which keep turning red. When the screen went blank yesterday I tried the Assist button but it didn't work. It did make me think about whether the 911 button will work if I ever need it.

I'd bring it into the dealer for diagnosis. DM me if you need assistance establishing an appointment. Thanks - Kevin T, Social Connect Team
 

·
Registered
Joined
·
1 Posts
I have 2018 Jeep Renegade. Took it to dealership for recall and was told my screen on Uconnect was delaminating. When they put in the work order my I was at 35,000 but was over my warranty by 5 months and they wanted to charge me 1600.00. I tried to call Dodge and get a one time exception they called it something else and they denied it. All they keep saying is fix it save receipt and hope for a recall. They have a recall on the same issue on 2019 but not 2018. Any suggestions.

Tammy
 
1 - 12 of 12 Posts
Top