Jeep Renegade Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
  1. Hello, I just got a used Renegade Latitude 15 with 60 k Mi. The Jeep has been working great since I got it a week ago but now at least twice in a period of 3 days I have issues when trying to start it. This one came with the push button start, once I attempt to start it as normal the engine will fail to respond the following lights come on : Check engine, Service Hill start, service electronic parking break, and check transmission. If I leave if off for a couple of minutes and try again sometimes it starts up as normal and other times it will repeat the same patern but the engine will start. The thing is when that happens and I shift gears to Drive every shift the transmission abruptly shifts causing the Jeep to shake. I scheduled to have it looked at but wonder if anyone else has encountered this issue ?

Push button start
9speed auto
2.4 L
 

·
Registered
Joined
·
1,531 Posts
Welcome to the forum. Sorry to hear you are having troubles with your Renegade. Similar problems have been mentioned before, do a search of the forum on starting problems, etc, you may find the exact answer to your problem. It could be a weak battery, you could to go an auto parts store and they will check the health of your battery, usually for free, or you could just wait for your service appointment. Good luck and keep us posted.
 

·
Registered
Joined
·
629 Posts
Lots of problems with the 2015’s unfortunately.


Sent from my iPhone using Tapatalk
Certainly unfortunate for us 2015 owners. Mine has been virtually flawless (never been back to the dealer- which I partially account for the lack of problems). Yet I expect to have to pay someone to take it off my hands when the time comes. I'm due for the radiator fan recall but I don't want to let the Jeep service department near it.
 

·
Super Moderator
Joined
·
3,788 Posts

and enjoy the forum!
Search is your friend!

We has 0 problems with our 15!
Like dge401 said battery must be checked first if that dose not do it than you need updates!
The BU like 12.4-12.6 volts.
 

·
Registered
Joined
·
1,676 Posts
Hi Obrayyanmtz and welcome. So sorry to hear of your issue.

Was this a Private sale or from a garage. If it's from the garage I would be revisiting them and asking that they fix the issue perhaps as DGR intimates by getting the battery checked.

If it is a private sale with no come-back, no returns policy then bite the bullet and get a new battery. IMHO it is better to pay £150 for a brilliant battery than to mess around and second guess yourself. Almost on a weekly basis members new to the forum are reporting that after accepting advice in this forum that a new battery has solved almost all their problems.

You may also be one of the guys that report back with a successful conclusion shortly ;)(y)(y)(y)
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
Hey everyone!

I appreciate all the replies was able to get it into service today , I will post back an update on what they say.

I read a couple post here about turning on the Renegade without actually starting up the engine for a couple mins and then starting it, that seem to work a couple times but I am hoping they figure out what is wrong with it.
 

·
Registered
Joined
·
1,676 Posts
That was the old style start up procedure for a diesel engine with glow plugs. You would turn on the ignition till you seen the yellow coil light turn off, wait another few seconds and then start the engine.

I may be wrong but there should not be any need to wait a few minutes with the Renegade.
 

·
Registered
Joined
·
1,125 Posts
  1. Hello, I just got a used Renegade Latitude 15 with 60 k Mi. The Jeep has been working great since I got it a week ago but now at least twice in a period of 3 days I have issues when trying to start it. This one came with the push button start, once I attempt to start it as normal the engine will fail to respond the following lights come on : Check engine, Service Hill start, service electronic parking break, and check transmission. If I leave if off for a couple of minutes and try again sometimes it starts up as normal and other times it will repeat the same patern but the engine will start. The thing is when that happens and I shift gears to Drive every shift the transmission abruptly shifts causing the Jeep to shake. I scheduled to have it looked at but wonder if anyone else has encountered this issue ?
Push button start
9speed auto
2.4 L
We're sorry to hear about this. If you need any additional assistance while working with your dealer, please feel free to send us a private message.
Alex
Jeep Cares
 

·
Registered
Joined
·
3 Posts
Discussion Starter #10
2 days in the service department later and I finally got my Renegade back ! They diagnosed it as a bad battery cell , its been turning on without hesitation and it seems to be okay !

Thought I would update this since its been okay and thank y'all!
 
1 - 10 of 10 Posts
Top